Post by HATEPOLICY » Thu Aug 23, 2012 9:35 am

So, after upgrading from 1.5.3.1 to 1.5.4.1 on our test-shop we get this output:

Code: Select all

<div id="powered">Powered By <a href="http://www.opencart.com">OpenCart</a><br /> bla.com &copy; 2012</div>
<!--
OpenCart is open source software blabla
//-->
</div>
</body></html>();
?>
So, we now see ();?> bottom left of every page,
We have a custom template that also shows the same error, template is compatible with 1.5.4
Could anyone please advice?

Many thanks in advance.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by maccadon » Thu Aug 23, 2012 2:02 pm

Is it also visible on de the default theme?
Go to catalog/view/theme/your theme/common/footer.tpl and look at the bottom
if you see this

Code: Select all

</body></html>();
?>
Then remove the

Code: Select all

();
?>
Cause that shouldn't be there

Active Member

Posts

Joined
Thu Aug 05, 2010 9:57 pm

Post by HATEPOLICY » Thu Aug 23, 2012 9:11 pm

Hi,

Thanks for the reply,
Yes its also in the default theme,

1st thing I checked was the footer, then header, no joy.
I am lost :(

Thanks again.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by i2Paq » Thu Aug 23, 2012 9:25 pm

Did you modify core files?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by HATEPOLICY » Thu Aug 23, 2012 9:51 pm

Sorry I should have made that clear,

its a clean install, nothing modified, only vQmod installed, with a very simple xml for Slideshow order.
That's it.

Thanks again!

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by HATEPOLICY » Thu Aug 23, 2012 10:09 pm

Easier solution perhaps?
Can I just install a fresh 1.5.4.1 and use my database with out any issues?

Thanks!

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by i2Paq » Thu Aug 23, 2012 10:11 pm

Remove the vQmod slider xml and then?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by HATEPOLICY » Thu Aug 23, 2012 10:17 pm

i2Paq wrote:Remove the vQmod slider xml and then?
No joy :(

Can I just upload my images to 1.5.4.1 and use my DB from 1.5.3.1 with out issues?

Many thanks again.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by HATEPOLICY » Thu Aug 23, 2012 11:59 pm

I just did a fresh install, using SSH, used same DB from 153.1

The leaked code outside of html/body tags is gone, thank god.

My site seems to be working, admin also, will report back if I find any other errors,
Hopefully not so we can do this with our live store.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by HATEPOLICY » Fri Aug 24, 2012 12:28 am

Everything seems to be working except "customers online"
I get permission denied error for that, any idea's?

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by i2Paq » Fri Aug 24, 2012 1:54 am

Granted rights to access that module via you usergroups?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by HATEPOLICY » Fri Aug 24, 2012 2:11 am

i2Paq wrote:Granted rights to access that module via you usergroups?
Hashaka Bedankt!
I know I misspelled that, but u get me i hope! ;)

What a n00by mistake, granted rights and its sorted, gowan!

Thanks again mate!

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by HATEPOLICY » Fri Aug 24, 2012 11:46 am

Okay, I have hit a wall.
This is really strange, as reported before,
I just uploaded the latest version of OpenCart and used the current live db on a new "backup" db user/name.
Then, I uploaded our custom template and made a few little changes, everything was fine.

I then tried connecting the updated shop to the live db & we hit errors.
The shop is "busy" 23 orders processed and 11 new customers joined while i was sorting out the update,
But I don't see why or how those orders or customers could break the upgrade?...anyone?

I tried going through the above steps again with the updated live db and hit the same errors.

Front page error:

Code: Select all

Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30Notice: Undefined index: tag in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 23Notice: Undefined index: ean in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 27Notice: Undefined index: jan in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 28Notice: Undefined index: isbn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 29Notice: Undefined index: mpn in /home4/blabla/public_html/testshop/catalog/model/catalog/product.php on line 30
and when I try to login in now to admin I get this:

Code: Select all

Notice: Error: Unknown column 'salt' in 'where clause'
Error No: 1054
SELECT * FROM oc_user WHERE username = 'admin' AND (password = SHA1(CONCAT(salt, SHA1(CONCAT(salt, SHA1('blabla'))))) OR password = '8989') AND status = '1' in /home4/blabla/public_html/testshop/system/database/mysql.php on line 49
Seems strange only after a few more orders and customers the db is not compatible,
Maybe I need to run the upgrade.sql?
We just want to be secure, seeing as 153.1 has security issues.

Many thanks in advance.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by HATEPOLICY » Fri Aug 24, 2012 12:44 pm

I fixed it by running the 1.5.4 mysql entries on upgrade.sql

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by Rainforest » Tue Aug 28, 2012 2:03 am

What do you mean?
Sorry, can you tell me how to do that.

I'm getting the Salt error too on a clean install of 1.4.9.5 upgrading with the beta and then the upgrad.sql

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by HATEPOLICY » Tue Aug 28, 2012 2:11 am

You would need to run everything from upgrade.sql, separate, update by update, read the comments on the db file,
Mine was only one update since 153.1, db wise that is...

So I found the entries for 1.5.4, they are commented, on upgrade.sql and ran them on our db.

I am no Mysql guru tho, but it worked for me...

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by Rainforest » Tue Aug 28, 2012 2:18 am

doh!
I was so dumb. The instructions are annoyingly wrong. They say upgrade.php which of course doesn't exist. I got to work by running the beta script, then going to mysite/install/
it goes to index.php which then prompts you to upgrade and viola.

I'm shocked they have not fixed this TINY but important detail in the install package. I'm looking at tons of posts on the forum of ppl running into this error because the instructions are wrong. grrr.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by HATEPOLICY » Tue Aug 28, 2012 2:35 am

Ah, I didn't read the install docs, anyway, glad you got it sorted.

Skills: Ripp, copy, paste.


New member

Posts

Joined
Tue Nov 22, 2011 5:46 pm
Location - Boosting 30-80hz ranges.

Post by Qphoria » Wed Aug 29, 2012 2:42 am

Yea the install docs somehow got replaced with OOOOOOLLLDD copies when moved to Github.. next version has them corrected. For now you can refer to the "readme.txt" file for links to the correct install/upgrade steps

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Rainforest » Wed Aug 29, 2012 6:47 am

there is a next version coming soon? :crazy:
should I be waiting to upgrade. :laugh:

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am
Who is online

Users browsing this forum: No registered users and 14 guests