Post by SonKeller » Sun Jun 17, 2012 9:04 pm

Dear Sirs,
I just upgraded from version 1.5.2.1 to 1.5.3.1.
Unfortunately, the following error appear (similar to that reported in this forum but not implying 'information.php' but 'footer.php')
Notice: Undefined index: bottom in /home5/ronindog/public_html/catalog/controller/common/footer.php on line 26

in the footer of my website, pages 'information' are missing.

can you help me?
thankyou
With my best regards

Sonia
OpenCart: Version 1.5.3.1.


Newbie

Posts

Joined
Wed Mar 21, 2012 11:52 pm

Post by straightlight » Sun Jun 17, 2012 9:24 pm

Dear Sirs,
I just upgraded from version 1.5.2.1 to 1.5.3.1.
Unfortunately, the following error appear (similar to that reported in this forum but not implying 'information.php' but 'footer.php')
Notice: Undefined index: bottom in /home5/ronindog/public_html/catalog/controller/common/footer.php on line 26

in the footer of my website, pages 'information' are missing.

can you help me?
thankyou
With my best regards
Is it possible you haven't filled out any information from the admin ? To get rid of the error message, however, you could always go to your footer.tpl file and

replace:

Code: Select all

<ul>
      <?php foreach ($informations as $information) { ?>
      <li><a href="<?php echo $information['href']; ?>"><?php echo $information['title']; ?></a></li>
      <?php } ?>
    </ul>
with:

Code: Select all

<ul>
      <?php if (!empty($informations)) { ?>
      <?php foreach ($informations as $information) { ?>
      <li><a href="<?php echo $information['href']; ?>"><?php echo $information['title']; ?></a></li>
      <?php } ?>
      <?php } ?>
    </ul>
since there are no guarantee of showing the information on the footer until there has been information filled out in the first place. ;)

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by SonKeller » Mon Jun 18, 2012 3:42 am

Thank you for your message.
before upgrade there was 6 information pages
after upgrade there was no pages shown
Pls. see attached screenshots.

So I do not understand why this error

Attachments

footer_information1531.gif

1.5.3.1 - footer - informations pages = 0 - footer_information1531.gif (2.13 KiB) Viewed 4174 times

footer_information1521.gif

1.5.2.1. footer - Informations pages = 6 - footer_information1521.gif (3.7 KiB) Viewed 4174 times


Sonia
OpenCart: Version 1.5.3.1.


Newbie

Posts

Joined
Wed Mar 21, 2012 11:52 pm

Post by jrotem » Mon Jul 02, 2012 12:59 pm

Did you manage to fix this? I have the same problem. I get the same error message in my error log, but I cannot save Information and none shows (it used to.)

EDIT: I found http://forum.opencart.com/viewtopic.php ... 2&p=297042 that the "show in footer" box needs to be checked and for some reason isn't. But my problem is that my Info pages will not save. When I click "save" I get a blank page and not changes.

User avatar
New member

Posts

Joined
Sun Jun 24, 2012 3:38 pm

Post by straightlight » Mon Jul 02, 2012 6:25 pm

What does your admin - > systems - > error logs regarding this behavior ?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Qphoria » Mon Jul 02, 2012 6:43 pm

The upgrade script should handle this for you. I set the default value for "bottom" to 1 during upgrade so that you don't see this issue. You are sure you ran the upgrade?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by jrotem » Tue Jul 03, 2012 6:05 am

Hello Qphoria ,
Where would I set the value for bottom? TIA!

User avatar
New member

Posts

Joined
Sun Jun 24, 2012 3:38 pm

Post by darbebe » Tue Jul 03, 2012 1:22 pm

I have the same error message when I did the upgrade from 1.5.2 to 1.5.3.

Finding no solution as yet I decided to restore back to 1.5.2 as my online store will go live tomorrow.

Newbie

Posts

Joined
Thu Jun 21, 2012 12:50 pm

Post by Qphoria » Fri Jul 06, 2012 11:33 am

jrotem wrote:Hello Qphoria ,
Where would I set the value for bottom? TIA!
Edit each information item and check the bottom box.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by jrotem » Sat Jul 07, 2012 7:11 am

Thank you, Qphoria, but part of my problem (above) is that I cannot save Information. I get a blank page when I do so. Any further hints would be so much appreciated!

jean

User avatar
New member

Posts

Joined
Sun Jun 24, 2012 3:38 pm

Post by flipsexchange » Mon Jul 09, 2012 10:02 am

jrotem wrote:Thank you, Qphoria, but part of my problem (above) is that I cannot save Information. I get a blank page when I do so. Any further hints would be so much appreciated!

jean

I have this same exact problem on two sites. when I try to save the page displays this error message.

Notice: Error: Unknown column 'bottom' in 'field list'
Error No: 1054
UPDATE oc_information SET sort_order = '1', bottom = '0', status = '1' WHERE information_id = '4' in /home2/moviegoe/public_html/amandawierenga/system/database/mysql.php on line 49

Newbie

Posts

Joined
Mon Jul 09, 2012 9:35 am

Post by sliponera » Wed Aug 08, 2012 5:22 pm

The same problem here:
After upgrade from 1.5.0.1 everything looked fine.
However I have edited some of the information page I deselected "Display in the bottom footer." sort order was -1 ( -1 that option to do not show on the footer did not change that) and saved. Then click on any page of the footer like "account, about us etc." I see blank page.
What is going on any help???

http://www.slippers4you.com - women's mules and sheepskin slippers for men


New member

Posts

Joined
Wed Aug 08, 2012 6:42 am


Post by sliponera » Wed Aug 08, 2012 6:01 pm

I have found it. I have pasted google script without </script> and that was the problem. ;D

http://www.slippers4you.com - women's mules and sheepskin slippers for men


New member

Posts

Joined
Wed Aug 08, 2012 6:42 am


Post by Needhelptoo » Thu Aug 09, 2012 6:16 am

I upgraded and got the following
When people tried to regester they had to list a company and TAX ID
2012-08-08 12:16:20 - PHP Notice: Undefined index: company_id_display in /hermes/bosweb26d/b1245/sl.pamsdrea/public_html/store/catalog/controller/account/register.php on line 384

2012-08-08 12:16:20 - PHP Notice: Undefined index: tax_id_display in /hermes/bosweb26d/b1245/sl.pamsdrea/public_html/store/catalog/controller/account/register.php on line 389

2012-08-08 12:59:57 - PHP Notice: Undefined index: company_id in /hermes/bosweb26d/b1245/sl.pamsdrea/public_html/store/catalog/model/account/address.php on line 59

2012-08-08 12:59:57 - PHP Notice: Undefined index: tax_id in /hermes/bosweb26d/b1245/sl.pamsdrea/public_html/store/catalog/model/account/address.php on line 60

2012-08-08 13:00:14 - PHP Notice: Undefined index: company_id in /hermes/bosweb26d/b1245/sl.pamsdrea/public_html/store/catalog/model/account/address.php on line 1

New member

Posts

Joined
Thu Mar 22, 2012 1:11 am
Who is online

Users browsing this forum: No registered users and 6 guests