Page 2 of 2

Re: Not receiving email when new order is placed

Posted: Sat Sep 26, 2009 12:11 am
by wilmaogando
Yes, my version is 1.2.9 and I don't know how to upgrade without losing all my changes.

I have template modification, I translate my store manually, etc, etc.

Thanks for your help, I will try to look for help for upgrade without losing my changes, thanks!!!

Re: Not receiving email when new order is placed

Posted: Sun Oct 04, 2009 11:35 am
by kdmp
Hi Wilma,

Did you get your site upgraded to 1.3.2?

Re: Not receiving email when new order is placed

Posted: Sun Oct 04, 2009 12:07 pm
by fido-x
kdmp wrote:SMTP - Send Mail Transfer Protocol. How you send your email to your friends (in most cases).
Actually, SMTP stands for Simple Mail Transfer Protocol, as it is used to both send AND receive emails, depending on which end of the chain you're on.

Example: Your email client (Thunderbird, Outlook, Outlook Express, etc) uses SMTP to send emails to the server, while at the server end, SMTP is the protocol used to receive emails. Conversely, POP (Post Office Protocol) is used by the client to receive emails, while the server uses it to send emails.

Re: Not receiving email when new order is placed

Posted: Tue Oct 06, 2009 12:17 am
by wilmaogando
No kmdp I haven't upgrade my site and still without receiving confirmation.

I don't know how to upgrade and I have to many changes in templates, php, tpl that I am afraid of losing them.

I have this site just reading tutorials I since 6 month ago, I have no idea about this topics...

:-[

Re: Not receiving email when new order is placed

Posted: Sat Oct 10, 2009 12:54 am
by jbarrick
I have 1.3.2

I have checked the Alert Mail in the settings.

No one receives an email when new orders are placed. Not the store owner, not the customer.

The SMTP settings are correct, as Order update emails do successfully go to customers.

What can the problem be?

Re: Not receiving email when new order is placed

Posted: Thu Oct 15, 2009 7:19 pm
by mchrisokc
I am having the same issue on 1.3.0. I can receive a email from the 'contact us' page. But from no where else. I have tried the newsletter function, order update, making new orders (yes I have the box checked in admin to receive emails on new orders), none of these functions work, although each says "Your message has been successfully sent!". I have tried mail and smtp settings. IT just confuses me how contact us works but none of the others do. If you find a resolution or if anyone has any ideas please let me know.
Thanks.

Re: Not receiving email when new order is placed

Posted: Thu Oct 15, 2009 7:31 pm
by Daniel
wilmaogando wrote:No kmdp I haven't upgrade my site and still without receiving confirmation.

I don't know how to upgrade and I have to many changes in templates, php, tpl that I am afraid of losing them.

I have this site just reading tutorials I since 6 month ago, I have no idea about this topics...

:-[

1st, Don't use SMTP if you8 can help it! I don;t know why some people who don;t need to use SMTP are using it because I have put the fields in the DB. You server should be configured to send emails via PHP built in mail function and not have to do things via SMTP!.

2nd, have you tried replacing your mail class with the new one i posted in the forums?

Re: Not receiving email when new order is placed

Posted: Thu Oct 15, 2009 8:15 pm
by mchrisokc
Daniel, thanks for the input. I did as your post instructed and replaced the code...no effect. The only mail funstion that is working is contact us...and I recieve it instantly.

Dont know if this has any bearing on anything or not but while snooping around I found this in the main config file:
// DIR
define('DIR_APPLICATION', '/home5/heartld7/public_html/shop/catalog/');
define('DIR_SYSTEM', '/home5/heartld7/public_html/shop/system/');
define('DIR_DATABASE', '/home5/heartld7/public_html/shop/system/database/');
define('DIR_LANGUAGE', '/home5/heartld7/public_html/shop/catalog/language/');
define('DIR_TEMPLATE', '/home5/heartld7/public_html/shop/catalog/view/theme/');
define('DIR_CONFIG', '/home5/heartld7/public_html/shop/system/config/');
define('DIR_IMAGE', '/home5/heartld7/public_html/shop/image/');
define('DIR_CACHE', '/home5/heartld7/public_html/shop/cache/');
define('DIR_DOWNLOAD', '/home5/heartld7/public_html/shop/download/');

I have all of those directories except:
define('DIR_CONFIG', '/home5/heartld7/public_html/shop/system/config/');

This directory does not exist. Could that be the reason?

Re: Not receiving email when new order is placed

Posted: Thu Oct 15, 2009 9:17 pm
by mchrisokc
One additional note, when I set up my website email accounts in outlook express, the set from the hosting company said to change the default port setting from 25 to 26. I tried changing this in the admin, but it had no effects on anything...I even changed it in your main class where you had port 25. Still no effect, still could send a contact us email but nothing else.

Re: Not receiving email when new order is placed

Posted: Thu Jan 07, 2010 3:27 am
by leomazz
Hi everybody.
I had the same problem with alerts mails.
i used a domain email account in the mail settings, (Mail Protocol) and a gmail account in the shop email.
After continuos reviews, I decided to put the same "domain" account in both emails settings and started working.
Now I recibe de alert mail when a order is placed, and the customer recibe his order.
Also the contact form is working too.

bye

Re: Not receiving email when new order is placed

Posted: Sun May 01, 2011 11:44 am
by sml
mchrisokc,
you received a lot of help in this thread.
what the eventual outcome?

Re: Not receiving email when new order is placed

Posted: Sat Apr 21, 2012 1:10 pm
by ankaj_gupta
Guys, I have a peculiar problem - Till some time back whenever a new order was placed, I was getting an email as admin and my customer was also getting an email. Of late I realized that my customers have stopped getting emails, although I am still getting emails as admin. However whenever an order is updated, then the customer gets the mail. Any ideas anyone ? I am using OC 1.5.1.3

Thanks in advance.

Re: Not receiving email when new order is placed

Posted: Wed May 02, 2012 2:40 am
by Pittman
Well, after WEEKS of having my company's IT tech look into server settings, me researching countless sites, and a ton of other things we looked into....this is how I resolved it for us.

In the "Settings" area, under the "Mail" tab.....first select "SMTP", then make sure that the "SMTP Host" is set to the same thing you used when setting up the core install. For example, I used "localhost" when setting up the core install, therefore, it was necessary to put "localhost" in the "SMTP Host" area rather than "incoming.domain.com" or "mail.domain.com"

Everything works fine with my forms/email now. Try that and let us know if that works for you.

See attached screenshot.
Settings.png

Settings Screen Shot - Settings.png (128.76 KiB) Viewed 1738 times