Post by silentcoast » Fri Sep 18, 2009 11:08 am

That makes sense didn't see that section before never had to fill it out. What recommendations do you have for those fields? I will look on the forum also see if anyone else has them up.


Not sure if it makes a difference the images wouldn't show up until I entered in the error log name.

Newbie

Posts

Joined
Fri Jul 24, 2009 3:33 am

Post by Qphoria » Fri Sep 18, 2009 7:47 pm

132 Image defaults

Attachments

v132_image_defaults.jpg

v132_image_defaults.jpg (14.98 KiB) Viewed 5599 times


Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by swc » Mon Sep 21, 2009 5:52 pm

Hi there, I have done the steps above for quite a few times. but I dont really know what I have done wrong.

this is the error that I get from typing my site's url :

Fatal error: Call to undefined method Customer::getCustomerGroupId() in /home/echiccoc/public_html/shop2/catalog/model/catalog/product.php on line 220


and upon doing step 4, I get this error.

Error

SQL query:

--
-- Dumping data for table `customer_group`
--
INSERT INTO `_customer_group` ( `customer_group_id` , `name` )
VALUES ( 8, 'Default' ) , ( 6, 'Wholesale' ) ;

MySQL said: Documentation
#1062 - Duplicate entry '8' for key 1

I have remove the xxx_ to blank since I didnt use any prefix.

Any advise to fix that ?

thanks a bunch

swc
Newbie

Posts

Joined
Wed Jul 29, 2009 12:37 pm

Post by Qphoria » Mon Sep 21, 2009 8:22 pm

well that means you've already run it once and got it in the table...

but also you need to remove the _
remember i said remove the "xxx_" not just "xxx"

The error about
Fatal error: Call to undefined method Customer::getCustomerGroupId() in /home/echiccoc/public_html/shop2/catalog/model/catalog/product.php on line 220

tells me that you didn't upload all the files from the new version.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Gizella » Tue Sep 22, 2009 12:10 am

It's my first post in this forum, so let me first say thank you for this awesome shopping cart system!

I used Bluehost's simplescript install just a few days ago, which installed 1.3.0 for me. I have done LOTS of customization on the site: css, language files, etc. I do not have any php knowledge.

I have just realized, that there is a 1.3.2 version I need to upgrade to. I read the first post in this thread (many times), and downloaded the mentioned file and opencart_v1.3.2.

I have upgraded joomla sites many times without loosing customizations. I am a little worried about doing this upgrade though. Will I loose all my customized files by doing this upgrade?

Please excuse me for this "uneducated" question, but I don't want to loose all the work I have put into the site so far.

Thank you,
Gizella

Newbie

Posts

Joined
Sat Sep 19, 2009 8:36 pm

Post by swc » Tue Sep 22, 2009 8:28 am

Qphoria wrote:well that means you've already run it once and got it in the table...

but also you need to remove the _
remember i said remove the "xxx_" not just "xxx"

The error about
Fatal error: Call to undefined method Customer::getCustomerGroupId() in /home/echiccoc/public_html/shop2/catalog/model/catalog/product.php on line 220

tells me that you didn't upload all the files from the new version.
Thank you Qphoria for your great advises ! I've re-do the steps and removed the xxx_

However, it shows this on my page now

Error: Unknown column 'price' in 'field list'
Error No: 1054
SELECT price FROM product_discount WHERE product_id = '83' AND customer_group_id = '0' AND quantity = '1' AND ((date_start = '0000-00-00' OR date_start < NOW()) AND (date_end = '0000-00-00' OR date_end > NOW())) ORDER BY priority ASC, price ASC LIMIT 1

what does this mean ? is there a way to fix this ?

thanks !

swc
Newbie

Posts

Joined
Wed Jul 29, 2009 12:37 pm

Post by kdmp » Thu Sep 24, 2009 4:09 am

Hi SWC,

What version did you start with?

I mentioned this on another post and I am not sure if it is the case, but did you do the updates in order? Or did you go from say 1.2.9 to 1.3.2 without doing the steps between?

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by swc » Fri Sep 25, 2009 8:36 pm

Hi, thanks for your advises.

I think I start off with 1.29,
I did the steps again and again but always end up with error.

I think I will just stick to v1.29 lol.

swc
Newbie

Posts

Joined
Wed Jul 29, 2009 12:37 pm

Post by kdmp » Fri Sep 25, 2009 9:38 pm

Hi swc,

What errors were you receiving?

Kevin Davidson
Purolator Shipping Module
Canpar Shipping Module
VQMod - Paypal Transaction ID to Payment Details


Active Member

Posts

Joined
Thu Jun 04, 2009 10:40 am
Location - Ontario, Canada

Post by ptal » Wed Sep 30, 2009 12:39 pm

Just checking, but has anyone done this using webmin. I've tried but can't seem to get phpmyadmin to access my server.

Newbie

Posts

Joined
Wed May 28, 2008 2:48 pm

Post by paulsvang » Thu Oct 01, 2009 3:17 am

I've been having problems with this update

Opencart User


Active Member

Posts

Joined
Fri Aug 07, 2009 5:31 am


Post by Qphoria » Thu Oct 01, 2009 3:30 am

Did you use these steps from the original post?
Do you have a custom template?

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by eqbourne » Fri Nov 13, 2009 12:31 am

Ok so I'm looking over the instructions and I'm kinda stuck on step 2. I did a search for xxx_ and nothing came up. What file or files am I looking for? The 1.3.2 files I downloaded off the wiki for the upgrade didn't have any xxx_ in the code. Am I missing something? I got the upgrade from http://code.google.com/p/opencart/downloads/list

Newbie

Posts

Joined
Thu Nov 12, 2009 7:16 am

Post by Qphoria » Fri Nov 13, 2009 12:41 am

step 2? you download the file from
http://forum.opencart.com/viewtopic.php ... 999#p28667

and you open it in notepad and replace xxx_
There are lots of them

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by eqbourne » Fri Nov 13, 2009 1:16 am

Ok after I stopped sniffing glue - I saw that you posted the zip file right in your post. The directions worked like a charm! Thanks!

Newbie

Posts

Joined
Thu Nov 12, 2009 7:16 am

Post by Qphoria » Fri Nov 13, 2009 1:22 am

"Looks like i picked the wrong week to stop sniffing glue"
Image

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by eqbourne » Fri Nov 13, 2009 2:03 am

Haha! I did run into a database error when trying to do a backup in the admin > configuration > backup area. I click the top right backup button and get this error

Error: Access denied for user 'mysite_opn01'@'localhost' to database ''mysite_opn01'
Error No: 1044
SHOW TABLES FROM `'mysite_opn01`

Found it . . .
http://forum.opencart.com/viewtopic.php ... kup#p30749

Newbie

Posts

Joined
Thu Nov 12, 2009 7:16 am

Post by marcusjy6 » Fri Jan 15, 2010 4:00 pm

I am using bluehost and have no idea how to upgrade is there anyone who can help me with this process.

Edit by i2Paq: With the release of OpenCart 1.4.7 there is an upgrade script that will upgrade from version 1.3.0.

Newbie

Posts

Joined
Wed Nov 04, 2009 9:11 am

Post by AlasdairM » Sat Sep 25, 2010 4:08 pm

Hi,

I'm a bit behind the times and still have V 1.3 installed. Been hacked a lot lately so am upgrading to the latest version.

Anyway, I was trying to d/l "oc_upgrade_130_to_132.zip " to upgrade to 1.32 first, but the file is corrupt. Is there another version lurking somewhere else on the site?

Many thanks,

Al

Newbie

Posts

Joined
Tue Sep 01, 2009 9:15 pm

Post by i2Paq » Sat Sep 25, 2010 5:54 pm

With the release of OpenCart 1.4.7 there is an upgrade script inside the current release version zip that will upgrade from version 1.3.0.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands
Who is online

Users browsing this forum: No registered users and 14 guests