Post by Qphoria » Sat Aug 29, 2009 1:52 am

Here is an easier way to update from v1.2.9 to v1.3.0.

Step 1. Download the attached zip file
Step 2. Do a Find/replace to change xxx_ to your prefix. Or if you aren't using a prefix, replace it with a blank.
Step 3. Upload v1.3.0 files to your server EXCEPT FOR config.php and admin/config.php. Overwrite the existing v1.2.9 files (Be sure you backed up any customizations or themes. Do NOT delete the existing files, you don't want to have to reupload your product images again or any custom modules.
Step 4. While uploading the files, execute the attached file via phpmyadmin either by importing the zip file directly or unzip and copy the contents of the sql file and paste it into the sql query window.

Done.

(If upgrading to a later version, be sure to do each upgrade in order.)

Attachments


Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by mikestrepps » Fri Mar 26, 2010 8:59 pm

When You want to upgrade your v1.2.9 to v1.3.0 then try this one: First Unzip and upload the contents to the root directory of your OpenCart installation, preserving directory structure. Then From the admin menu, go to 'Admin->Users->User Groups'. Edit the Top Administrator. Then Find and check the new entries for both modify and access. Save. Then From the admin menu, go to 'Extensions->Payment'. Then Install the module, and click edit to configure.

Raleigh Durham schools


Newbie

Posts

Joined
Fri Mar 26, 2010 1:57 pm

Post by Qphoria » Fri Mar 26, 2010 9:19 pm

you are forgetting the many needed sql steps

With the release of OpenCart 1.4.7 there is an upgrade script that will upgrade from version 1.3.0 and up.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by al3xandr1a » Fri Sep 17, 2010 11:09 am

Is this method also applicable to all version upgrades?

~al3xandr1a
Newbie / Student


User avatar
New member

Posts

Joined
Fri Jul 02, 2010 7:27 pm

Post by Qphoria » Fri Sep 17, 2010 12:02 pm

al3xandr1a wrote:Is this method also applicable to all version upgrades?
The upgrade script that comes with the latest version of opencart should be able to upgrade you as far back as 1.3.2

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by netpastor » Mon Oct 11, 2010 12:50 pm

Qphoria wrote:Here is an easier way to update from v1.2.9 to v1.3.0.

Step 1. Download the attached zip file

(If upgrading to a later version, be sure to do each upgrade in order.)
It seems that the file available here is corrupted. Doe anyone else have a copy? Google does not seem to have any other record of "oc_upgrade_129_to_130.zip" anywhere either
(each time it is unzipped, winrar reports a file corruption and gives up)

seems to have 'null' or 'binary' characters in it

Newbie

Posts

Joined
Mon Oct 11, 2010 12:47 pm

Post by Qphoria » Mon Oct 11, 2010 10:03 pm

I fixed the file attachment above

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by netpastor » Thu Oct 14, 2010 7:57 am

Qphoria wrote:you are forgetting the many needed sql steps

With the release of OpenCart 1.4.7 there is an upgrade script that will upgrade from version 1.3.0 and up.
is this accurate, or should it read 1.3.2?

Newbie

Posts

Joined
Mon Oct 11, 2010 12:47 pm

Post by PETEK » Sun Jun 19, 2011 9:56 pm

Can anyone help me. I am in a mess of trouble. I have given away a product for free and now have to mail 1,500 envelopes. How do I print avery labels from open cart. I do not see any option to do so. Thanks in advance. Pete

Newbie

Posts

Joined
Sun Jun 19, 2011 9:46 pm

Post by Alistair » Wed Jun 22, 2011 4:50 pm

My version is 1.3.2 but the upgrading script is not working properly. Maybe I missed something :-\

SEO Blog Philippines


User avatar
New member

Posts

Joined
Tue May 24, 2011 1:47 pm


Post by Qphoria » Wed Jun 22, 2011 11:48 pm

Alistair wrote:My version is 1.3.2 but the upgrading script is not working properly. Maybe I missed something :-\
Yea, you missed 1st grade.
if you have 1.3.2
then you wouldn't want a script for 1.2.9 to 1.3.0

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Xzoid » Wed Aug 03, 2011 11:49 pm

Hi All
Please help a somewhat novice here. My website has been hacked quite a bit lately. i read in one of the forums that older OC like v1.2.9 etc had some issues.i dont quite know what version i`m using only that the site is more than 2yrs old. i need to upgrade from probably 1.2.9 to 1.5.X.
What do i need to do, to make it as easy as possible.
thanks

Newbie

Posts

Joined
Wed Aug 03, 2011 11:27 pm

Post by sml » Sat Dec 17, 2011 9:51 am

why is this still a sticky?
bit old.

sml
Active Member

Posts

Joined
Sat Apr 02, 2011 6:56 am
Who is online

Users browsing this forum: No registered users and 10 guests