Post by raylus » Fri Nov 11, 2011 3:21 am

Error: Unknown column 'sort_order' in 'order clause'
Error No: 1054
SELECT * FROM product_option WHERE product_id = '47' ORDER BY sort_order


can't get into my store, can't login to admin! help, on the verge of losing my client!!

Newbie

Posts

Joined
Wed Nov 09, 2011 6:02 am

Post by i2Paq » Fri Nov 11, 2011 3:26 am

You are NOT telling us that you upgraded a store and that you did NOT follow the complete upgrade instructions and used the upgrade script!

Used our FREE search on: Unknown column 'sort_order' in 'order clause'?

Used the [BETA2] Upgrade Script - 1.4.x to 1.5.x - NO PRODUCT OPTIONS?

You will only loose a customer because you did not prepare your work and now you want us to save your *ss?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by raylus » Fri Nov 11, 2011 3:54 am

First off, thanks for being so nice to me. Secondly, this is not a store that I upgraded, I upgraded the sister store but the BETA2 script must've somehow changed this database as well, I'm coming into this store as the second designer. I was left with a lot of mess to fix. I'm now trying to upgrade this store and run the script again. I'm hoping that will work, if not I'm hoping at least for some positive help from this forum. thanks!

Newbie

Posts

Joined
Wed Nov 09, 2011 6:02 am

Post by raylus » Fri Nov 11, 2011 4:16 am

the upgrade seemed to work but i still cannot login to admin or see my products, the opencart theme is all i see


any help would be greatly appreciated.

Newbie

Posts

Joined
Wed Nov 09, 2011 6:02 am

Post by i2Paq » Fri Nov 11, 2011 4:48 am

raylus wrote:First off, thanks for being so nice to me. Secondly, this is not a store that I upgraded, I upgraded the sister store but the BETA2 script must've somehow changed this database as well, I'm coming into this store as the second designer. I was left with a lot of mess to fix. I'm now trying to upgrade this store and run the script again. I'm hoping that will work, if not I'm hoping at least for some positive help from this forum. thanks!
It may be your first post here but you know is I know that you always should prepare and use the search before doing an upgrade.
I assume that you work in website related business and then you should know that an upgrade is not just 3 clicks.

We get a lot of posts like yours, screaming their heads of because they did not prepare and now they are "losing" busyness and need a fix a.s.a.p.

An upgrade should always be done on a backup store, never on a live store. Do you fix your tire while driving your car?

Now, to get to your issues:

Sisterstore as in: Multistore?

Did you check if your third-party modules are compatible wit the new version of OC you are using?
Did you check if your theme is compatible wit the new version of OC you are using?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by STN » Fri Nov 11, 2011 6:00 am

Good point there i2Paq. Learned my lesson the hard way. When version 5 of oc came out first, i was really excited and went to upgrade as soon as the upgrade script become available. I didn't like the new design though, was hella confused, lots of issues encountered. Luckily, i had backup'ed everything so i just reverted back to old version. Never try an upgrade on a live site. I will probably only upgrade when the v5 becomes more stable and i familiarize with it.

Seems like you're still using old version files or the database hasn't been upgraded.

Game Trainers


STN
New member

Posts

Joined
Fri Jul 01, 2011 6:45 am

Who is online

Users browsing this forum: No registered users and 13 guests