Post by dante » Tue Jun 16, 2009 8:50 am

Hi... I`m new here and with PHP.

I downloaded the opencart and installed on my website , the installation was successful but i still get this error

Warning: require_once(/system/startup.php) [function.require-once]: failed to open stream: No such file or directory in C:\HostingSpaces\xxxxxxxxxxxx\wwwroot\index.php on line 12

Fatal error: require_once() [function.require]: Failed opening required '/system/startup.php' (include_path='.;C:\php5\pear') in C:\HostingSpaces\xxxxxxxxxxxx\wwwroot\index.php on line 12

Also i seem to have a problem on the Step 1 - Preinstallation with Magic Quotes GPC giving me error as it is required to be off but it is in fact on.
screen.jpg

screen.jpg (45.8 KiB) Viewed 7384 times

I've contacted the customer service at my host and they told me that from my php.ini file the Magic Quotes GPC off but it still shows as On from the preinstallation page.

I'd love to be able to use this cart .
Thanks
Dante

Newbie

Posts

Joined
Tue Jun 16, 2009 8:27 am

Post by phpuk » Tue Jun 16, 2009 7:55 pm

You can safely ignore this as OpenCart has now been built to handle this.

Phil.

Global Moderator

Posts

Joined
Wed Mar 25, 2009 10:57 am

Post by dante » Tue Jun 16, 2009 8:36 pm

phpuk wrote:You can safely ignore this as OpenCart has now been built to handle this.

Phil.
HI, thanks for your reply.

Ok about the magic quote, but i still don't understand the error that i get:

Warning: require_once(/system/startup.php) [function.require-once]: failed to open stream: No such file or directory in C:\HostingSpaces\xxxxxxxxxxxx\wwwroot\index.php on line 12

Fatal error: require_once() [function.require]: Failed opening required '/system/startup.php' (include_path='.;C:\php5\pear') in C:\HostingSpaces\xxxxxxxxxxxx\wwwroot\index.php on line 12

If it's not related to the magic quote, how can i fix this error and what it is ?
Thanks
Dante

Newbie

Posts

Joined
Tue Jun 16, 2009 8:27 am

Post by dante » Wed Jun 17, 2009 4:51 am

Hi,
My hosting finally got back to me saying that magic quote is now Off.

Unfortunately my error is still there,therefore it was the magic quote after all.

Line 12 of index.php is

Code: Select all

require_once(DIR_SYSTEM . 'startup.php');
it seems that index.php can't find the file startup.php in the system folder.



I've downloaded config.php from my web and this is the definition if DIR SYSTEM

Code: Select all

define('HTTP_SERVER', 'http://shoppe.xxxxx.au/');
define('HTTP_IMAGE', 'http://shoppe.xxxxx.com.au/image/');

// HTTPS
define('HTTPS_SERVER', '');
define('HTTPS_IMAGE', '');

// DIR
define('DIR_APPLICATION', '/catalog/');
define('DIR_SYSTEM', '/system/');
finally this is the website where I'm testing the cart


from what I can understand of PHP the link to startup .php is correct ( DIR SYstem properly declared) .
If anybody can help me it would be really appreciated.
thanks
Dante
Last edited by dante on Thu May 14, 2015 7:16 pm, edited 1 time in total.

Newbie

Posts

Joined
Tue Jun 16, 2009 8:27 am

Post by JNeuhoff » Wed Jun 17, 2009 5:43 am

Do you have the following file on your server:

C:\HostingSpaces\etrusco\shoppe.leathershop.com.au\wwwroot\system\startup.php ?

Also, put your php.ini with the magic quote directive into the following places:

C:\HostingSpaces\etrusco\shoppe.leathershop.com.au\wwwroot\
C:\HostingSpaces\etrusco\shoppe.leathershop.com.au\wwwroot\admin\
C:\HostingSpaces\etrusco\shoppe.leathershop.com.au\wwwroot\install\

I have never tried it on a IIS on Windows, only on Apache on Unix or Linux.
Try using '\\' instaed of '/' in your config.php and see whether it makes a difference.

MHC Web Design
Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * TrustPilot Reviews * Google Rich Snippets * Google Tag Manager * Export/Import Tool * Template Switcher PHP/Twig


User avatar
Expert Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by dante » Wed Jun 17, 2009 6:01 am

JNeuhoff wrote:I have never tried it on a IIS on Windows, only on Apache on Unix or Linux.
Oh NO !
Does this mean that is not possible to install OPENCART on a IIS on Windows ?

JNeuhoff wrote:Try using '\\' instaed of '/' in your config.php and see whether it makes a difference.
I've changed this

Code: Select all

define('DIR_SYSTEM', '/system/');
to

Code: Select all

define('DIR_SYSTEM', '\\system\\');
but I still get the same error.

Thanks
Dante

Newbie

Posts

Joined
Tue Jun 16, 2009 8:27 am

Post by phpuk » Wed Jun 17, 2009 8:23 am

OpenCart requirements:
Requirements

* Apache
* PHP (at least 5)
* MySQL

Global Moderator

Posts

Joined
Wed Mar 25, 2009 10:57 am

Post by dante » Wed Jun 17, 2009 9:17 am

phpuk wrote:OpenCart requirements:
Requirements

* Apache
* PHP (at least 5)
* MySQL
Now I'm confused. Are you saying that I have not the right requirements to install Opencart?

I've followed the installation steps and the installation was successful. I seem to have only a problem related to link, slashes or similar.

Should i really abandon this installation ? Please help.

thanks
Dante

Newbie

Posts

Joined
Tue Jun 16, 2009 8:27 am

Post by readyman » Wed Jun 24, 2009 9:08 am

You can use it on windows, but you need the full path to your files in your config file.
Use C:\HostingSpaces\xxxxxxxxxxxx\wwwroot\catalog/ instead of just /catalog/
You can play around with the forward/backward slashes, but I don't think this is your issue.

Hope this helps,

http://www.alreadymade.com
Follow me on twitter.com/alreadymade


User avatar
Global Moderator

Posts

Joined
Wed May 20, 2009 5:16 am
Location - Sydney

Post by d0tb0t » Wed Jun 24, 2009 1:20 pm

I've contacted the customer service at my host and they told me that from my php.ini file the Magic Quotes GPC off but it still shows as On from the preinstallation page.

You need to add a string in .htaccess file at the root of the site!

Code: Select all

php_flag magic_quotes_gpc off

Newbie

Posts

Joined
Wed Jun 24, 2009 2:50 am

Post by readyman » Thu Jun 25, 2009 4:29 pm

You need to add a string in .htaccess file at the root of the site!
Possibly may be the solution here, but not for all hosts... I've got hosting accounts that won't allow .htaccess but will take the php.ini settings.

If you are having ANY php issues, please ask your host how to set PHP settings on your hosting account, as it will save you heaps of time, rather than trying the different ways that people are telling you on this forum by trial and error.
There are many ways to do the same thing on different hosts depending on their server, php, & security settings. - My 2c -

http://www.alreadymade.com
Follow me on twitter.com/alreadymade


User avatar
Global Moderator

Posts

Joined
Wed May 20, 2009 5:16 am
Location - Sydney

Post by Daniel » Thu Jun 25, 2009 6:03 pm

try re uploading and installing again. maybe a file is missing.

User avatar
Administrator

Posts

Joined
Fri Nov 03, 2006 6:57 pm
Who is online

Users browsing this forum: No registered users and 20 guests