Post by nightvision04 » Sat Oct 15, 2011 1:23 pm

Hi there,


I am having a problem with my admin dashboard being loaded correctly. Every link such as "Save", "Insert", "Delete", etc. that is used either has turned white (against the white background) or lost its functionality.

Another symptom to the problem is that "autocomplete" has apparently stopped working in the "Featured module". I require autocomplete to add products to the features module, so it is an obstacle I cannot afford to overlook.


my error message is "2011-10-15 5:05:29 - PHP Notice: Error: Could not load library json! in /home/dwai/public_html/store/system/engine/loader.php on line 23"

Any help would be appreciated.

Thanks,
Dan

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by nightvision04 » Sat Oct 15, 2011 1:24 pm

I am using OpenCart Version 1.5.1.3

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by uksitebuilder » Sat Oct 15, 2011 5:33 pm

It appears you have updated from a previous version ?

In 1.5.1.3 the <span> attribute was removed from buttons

A new implementation of json was added

You need to upload the admin files again (apart from config.php).

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by nightvision04 » Sun Oct 16, 2011 12:59 am

Alright, but I had installed the import export module, it will break that module if I do that..

Is there a specific file I could change instead.

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by uksitebuilder » Sun Oct 16, 2011 1:21 am

You cant partially upgrade to 1.5.1.3

It will cause no end of problems.

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by mstone » Sat Oct 22, 2011 3:26 am

There was an issue with the button css. The button background jpg used an underscore and the image file name used a dash. Or visa versa can't remember but it may now be fixed with 1.5.3.1 don't know since I fixed it myself by uploading another copy of the jpg with the correct name.

Newbie

Posts

Joined
Sat Oct 22, 2011 3:22 am

Post by nightvision04 » Sat Oct 29, 2011 12:24 am

where can I go to figure out exactly what picture needs its name changed?

Thanks

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by robbamacco » Mon Oct 31, 2011 8:22 pm

If you want to fix temporarly this problem, you can copy the file ./system/library/json.php from a previous version of opencart (e.g. form v.1.5.1.2)

Newbie

Posts

Joined
Thu Jul 07, 2011 10:00 pm

Post by nightvision04 » Wed Dec 21, 2011 10:06 am

Alright i'll do that.

Is that decision potentially to affect my store's stability? Or is it going to cause fundamental functions to not work?

Thanks.

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by nightvision04 » Wed Dec 21, 2011 11:54 am

I uploaded json.php from 1.5.1.2 to my current, 1.5.1.3 setup and it did not fix my issue


Here's what it looks like.

Attachments

whitefonts.jpg

whitefonts.jpg (22.52 KiB) Viewed 3750 times


New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by nightvision04 » Wed Dec 21, 2011 11:55 am

By the way, no I did not do any upgrading of any kind. I started with a vanilla 1.5.1.3 install mid - October.

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by fido-x » Wed Dec 21, 2011 12:08 pm

The error message you provided in your first post, suggests that you may have upgraded.
nightvision04 wrote:my error message is "2011-10-15 5:05:29 - PHP Notice: Error: Could not load library json! in /home/dwai/public_html/store/system/engine/loader.php on line 23"
So, if you didn't upgrade, you have an incompatible 3rd party module that is causing your problem. The json functions were changed in 1.5.1.3, which broke any module that was built on (or for) an earlier version that used json.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by nightvision04 » Wed Dec 21, 2011 12:26 pm

I see. Well. I have two mods.

1. Import/Export (JNeuhoff)
2. Restricted Access (Qphoria)

Both plugins were specifically made for the 1.5.1.3 release. Any suggestions?

p.s. - If anything, my guess is that between to the two possibilities, it wasn't a Qphoria issue.

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by fido-x » Wed Dec 21, 2011 12:39 pm

nightvision04 wrote:I see. Well. I have two mods.

1. Import/Export (JNeuhoff)
2. Restricted Access (Qphoria)

Both plugins were specifically made for the 1.5.1.3 release. Any suggestions?

p.s. - If anything, my guess is that between to the two possibilities, it wasn't a Qphoria issue.
Well, I wouldn't come to that conclusion without any evidence. Compared to JNeuhoff, Qphoria is a noob!

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by jty » Wed Dec 21, 2011 1:25 pm

fido-x wrote:Well, I wouldn't come to that conclusion without any evidence.
yer, JNeuhoff is a Senior around here and has been giving us the Import/Export module since version 0.7. That was a long time ago, before most people knew about OpenCart, even before Adam and Eve were born :laugh:
Fido-X is also a Senior around here

Try removing the mods one by one to isolate you problem

jty
Active Member

Posts

Joined
Sat Aug 30, 2008 8:19 am

Post by nightvision04 » Wed Dec 21, 2011 2:51 pm

After I take my foot out of my mouth, i'll get right on that. :)

Sorry Fido-X

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by fido-x » Wed Dec 21, 2011 3:07 pm

jty wrote:... Fido-X is also a Senior ...
Now I'm feeling old! ;D :laugh: :joker:
nightvision04 wrote:After I take my foot out of my mouth, i'll get right on that. :)

Sorry Fido-X
No worries.

It might also be an idea to check any vQmod file that may have come with either of those packages, to see if the cause of your problem lies there.

To disable a vQmod (or to hide a controller), just add an underscore to the end of the filename's extension (eg., .xml_ or .php_), or change the extension from .xml (or .php) to .bak.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by nightvision04 » Wed Dec 21, 2011 3:43 pm

Okay.

I have disabled both mods (vqmod scripts), and confirmed that they are no longer working.

I still however get the font issues. Below is another example of the problem. There should be dark Login text, but instead it is white.

Last picture example shows a missing autocomplete, necessary for adding coupon products and other things wonderful...

Is this as easy as re-uploading the open cart 1.5.1.3 version directly in ftp?

Attachments

missing autocomplete.jpg

missing autocomplete.jpg (37.55 KiB) Viewed 3735 times

nobutton.jpg

nobutton.jpg (35.9 KiB) Viewed 3735 times


New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by nightvision04 » Thu Dec 22, 2011 6:04 am

I forgot to mention, I also replaced the json.php file to its original 1.5.1.3 version. (I had tried using a 1.5.1.2 version by request on this thread).

New member

Posts

Joined
Sat Oct 15, 2011 1:17 pm

Post by fido-x » Thu Dec 22, 2011 10:07 am

nightvision04 wrote:I forgot to mention, I also replaced the json.php file to its original 1.5.1.3 version. (I had tried using a 1.5.1.2 version by request on this thread).
OK. Get rid of "system/library/json.php" (that's the old one). Make sure that you have a "sytem/helper/json.php" (from the 1.5.1.3 package).

Now, you stated earlier that you have 2 mods/extensions:
nightvision04 wrote:... I have two mods.

1. Import/Export (JNeuhoff)
2. Restricted Access (Qphoria)
(a) Of these, JNeuhoff's Import/Export mod is a tool which allows you to backup/restore your database to/from an Excel spreadsheet. This has no impact on products and doesn't use json.

(b) On the other hand, Qphoria's Restricted Access mod does have an impact on products, as its purpose is to "restrict access".

Using the basic principle of logic that "a + b therefore c", the conclusion is that your problem is in Qphoria's Restricted Access mod.

Disable this mod by renaming the controller (add ".bak" to the end of the filename or change the extension to ".php_"). If this is a "module", the controller will be found in "admin/controller/module" folder. If it is a "tool" the controller should be found in the "admin/controller/tool" folder. This will confirm whether this module is the cause of your problem, or not.

The error message you included in your first post:
nightvision04 wrote:"2011-10-15 5:05:29 - PHP Notice: Error: Could not load library json! in /home/dwai/public_html/store/system/engine/loader.php on line 23"
This suggests that something is trying to load the json "library" (doesn't exist in 1.5.1.3), so you are getting an error. If I'm right about which mod is causing your problem, have a look in the controller for Qphoria's Restricted Access mod, and look for something like:

Code: Select all

$this->load->library('json');

$this->response->setOutput(Json::encode($product_data)); 
Delete:

Code: Select all

$this->load->library('json'); 
and replace the second line with:

Code: Select all

$this->response->setOutput(json_encode($product_data)); 

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia
Who is online

Users browsing this forum: No registered users and 7 guests