Page 1 of 1

Upgraded from V1.5.0 to V1.5.1.3

Posted: Mon Oct 03, 2011 7:03 pm
by Jacob
Hello,

Not sure if this is a bug, as I do not know what the term 'bug' means.

Upgraded from V1.5.0 to V1.5.1.3

I am getting this error:
Notice: Undefined index: points in /home/londont/public_html/catalog/view/theme/mysite/template/checkout/cart.tpl on line 47
And:
Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_left.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/column_right.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_top.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_bottom.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_bottom.php on line 49Warning: Invalid argument supplied for foreach() in /home/londont/public_html/catalog/controller/common/content_bottom.php on line 49
Thanks

Re: OpenCart 1.5.1.3 Bug Thread

Posted: Mon Oct 03, 2011 11:10 pm
by Qphoria
Jacob wrote: Notice: Undefined index: points in /home/londont/public_html/catalog/view/theme/mysite/template/checkout/cart.tpl on line 47
This means you need to update the catalog/view/theme/mysite/template/checkout/cart.tpl file in your theme with the changes that came with catalog/view/theme/default/template/checkout/cart.tpl. Note that if that file hasn't been customized for your theme, you should not be including it as part of your theme and you can just delete it to let it fallback to the default folder.

Warning: Invalid argument supplied for foreach() in
This just means you need to uninstall/reinstall all modules due to the 1.5.0 to 1.5.1 change

Re: Upgraded from V1.5.0 to V1.5.1.3

Posted: Tue Oct 04, 2011 6:19 pm
by Jacob
Thanks Q
Note that if that file hasn't been customized for your theme, you should not be including it as part of your theme and you can just delete it to let it fallback to the default folder.
Understood, I have made minor edits to this file.

I crossed checked the new file with an untouched V1.5.0 version cart.tpl file which is saved as back-up on my PC, this way I could easily compare the two.

This just means you need to uninstall/reinstall all modules due to the 1.5.0 to 1.5.1 change
That got rid of the Warnings, but now my Accordion Module which is my menu for categories has disappeared. I was using Accordion Category menu Version: 1.0. Version compatibility was up to 1.5.0 but now only shows to be up to V1.4.9?
http://opencart.webshopworks.com/accord ... ncart.html

Any suggestions as to what I can do?

Thanks

Re: Upgraded from V1.5.0 to V1.5.1.3

Posted: Tue Oct 04, 2011 8:11 pm
by Jacob
Accordion Module has disappeared.
The changes to catalog/controller/common/column_left.php caused this (that is where the module is). I am not sure what to do?