Post by gergovprint » Fri Sep 16, 2011 4:53 pm

Help me!!!!

Opencart version: 1.4.9.4

An error occurred during a connection
SSL received a record that exceeded the maximum permissible length.
(Error code: ssl_error_rx_record_too_long)
Last edited by gergovprint on Fri Sep 23, 2011 4:34 am, edited 4 times in total.

метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by uksitebuilder » Fri Sep 16, 2011 6:03 pm

This usually means the implementation of SSL on your server is not correct. The error is usually caused by a server side problem which the server administrator will need to investigate.

Below are some things we recommend trying.

Ensure that port 443 is open and enabled on your server. This is the standard port for https communications.

If SSL is using a non-standard port then FireFox can sometimes give this error. Ensure SSL is running on port 443.

If using Apache2 check that you are using port 443 for SSL. This can be done by setting the ports.conf file as follows

Listen 80
Listen 443 https

Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.

If using Apache2 check your vhost config. Sometiems changing <VirtualHost> to _default_ resolves the error.

Make sure that your SSL certificate is not expired

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by gergovprint » Fri Sep 16, 2011 6:39 pm

uksitebuilder wrote:This usually means the implementation of SSL on your server is not correct. The error is usually caused by a server side problem which the server administrator will need to investigate.

Below are some things we recommend trying.

Ensure that port 443 is open and enabled on your server. This is the standard port for https communications.

If SSL is using a non-standard port then FireFox can sometimes give this error. Ensure SSL is running on port 443.

If using Apache2 check that you are using port 443 for SSL. This can be done by setting the ports.conf file as follows

Listen 80
Listen 443 https

Make sure you do not have more than one SSL certificate sharing the same IP. Please ensure that all SSL certificates utilise their own dedicated IP.

If using Apache2 check your vhost config. Sometiems changing <VirtualHost> to _default_ resolves the error.

Make sure that your SSL certificate is not expired

Where can I check whether port 443
... Certificate has not expired, now purchased ...

/sorry for bad English/

метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by uksitebuilder » Fri Sep 16, 2011 7:41 pm

looking at your config.php in your original pst you have http:// instead of https:// for your HTTPS defines

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by gergovprint » Fri Sep 16, 2011 8:01 pm

uksitebuilder wrote:looking at your config.php in your original pst you have http:// instead of https:// for your HTTPS defines

// HTTP
define('HTTP_SERVER', 'http://mywebsite.com/admin/');
define('HTTP_CATALOG', 'http://mywebsite.com/');
define('HTTP_IMAGE', 'http://mywebsite.com/image/');

// HTTPS
define('HTTPS_SERVER', 'https://mywebsite.com/admin/');
define('HTTPS_IMAGE', 'https://mywebsite.com/image/');

I tried so but still gives error
Last edited by gergovprint on Fri Sep 23, 2011 4:35 am, edited 1 time in total.

метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by gergovprint » Fri Sep 16, 2011 8:04 pm

I saw these lines in config.php direcrory ADMIN them there and in the root directory will put them


// HTTP
define('HTTP_SERVER', 'http://mywebsite.com/admin/');
define('HTTP_CATALOG', 'http://mywebsite.com/');
define('HTTP_IMAGE', 'http://mywebsite.com/image/');

// HTTPS
define('HTTPS_SERVER', 'http://mywebsite.com/admin/');
define('HTTPS_IMAGE', 'http://mywebsite.com/image/');
Last edited by gergovprint on Fri Sep 23, 2011 4:36 am, edited 2 times in total.

метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by gergovprint » Fri Sep 16, 2011 9:05 pm

Now I realized that the SSL certificate must be installed on the server ... it will install (I forgot) ... did not know the way it should be installed .. I will take it from the client and install it


е-mail message:

Code: Select all

Attached to this email you should find a .zip file containing: 

Your PremiumSSL Certificate - mywebsite.com.crt
Your Apache "bundle" file - mywebsite.com.ca-bundle
You can also find your PremiumSSL Certificate for www.mywebsite.com in text format at the bottom of this email. 
Last edited by gergovprint on Fri Sep 23, 2011 4:36 am, edited 1 time in total.

метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by gergovprint » Tue Sep 20, 2011 2:38 am

SSL certificate installed, but when I open the site with Internet Explorer, ... displays the following error (attach image)

... and I see so far appears HTTPS: / / ..., but does not go padlock icon that has a secure connection

Attachments

1.jpg

1.jpg (76.74 KiB) Viewed 8046 times


метални табели отпечатване на флаери отпечатване на винил отпечатване на плакати


New member

Posts

Joined
Wed Apr 28, 2010 10:03 pm


Post by uksitebuilder » Tue Sep 20, 2011 2:57 am

You need to edit this link which relates to your categories in the left column

Code: Select all

http://mybgshop.co.nz//catalog/view/javascript/jquery/superfish/css/superfish.css
you should just have

Code: Select all

 catalog/view/javascript/jquery/superfish/css/superfish.css

ImageImageImageImageImage

For Friendly Professional Support - Click Here


User avatar
Guru Member

Posts

Joined
Thu Jun 09, 2011 11:37 pm
Location - United Kindgom

Post by comparecheapssl » Sat Aug 31, 2019 2:07 am

How to fix ssl_error_rx_record_too_long in Firefox? Attempt HTTP: No proxy setting

* Update Firefox
* Disable Antivirus
* Open Firefox in safe mode
* Turn Off Firefox Add-ons
* Refresh the Browser
* Set security.tls.version.max to 0
* Use a VPN

I found a few explainations and fixes:
https://support.mozilla.org/en-US/questions/1222739
https://stackoverflow.com/questions/119 ... apache-ssl
https://www.thesslstore.com/blog/ssl_er ... _too_long/


Posts

Joined
Sat Aug 31, 2019 2:04 am
Who is online

Users browsing this forum: No registered users and 25 guests