Post by salesonline » Wed Mar 04, 2009 6:43 pm

Hello,

i'm trying to install OpenCart on Strato (Basic Web XL). The installation routine can be completed without any problems, but if I open mydomain.com/shop/index.php the following PHP error messag is printed out:
Warning: set_time_limit() [function.set-time-limit]: Cannot set time limit in safe mode in /mnt/web2/31/68/52043068/htdocs/shop/system/startup.php on line 11
Strato does not offer to turn safemode off (i already contacted the support)- so - is there any workaround for the problem?

Thanks so far, salesonline

Newbie

Posts

Joined
Wed Mar 04, 2009 6:38 pm

Post by nde » Wed Mar 04, 2009 7:28 pm

You can only switch it off on their premium packages (dedicated servers).

But my advice is to find a better quality host. Many of them support safemode off nowadays, at least via some .htaccess flag.

nde
New member

Posts

Joined
Sat Jun 30, 2007 7:32 am

Post by fido-x » Wed Mar 04, 2009 7:40 pm

Have you tried adding --

Code: Select all

safe_mode = off
to the "php.ini" files -- there are 2 of them one in your store's top level directory, the other in the "admin" directory.

User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by salesonline » Wed Mar 04, 2009 8:53 pm

Wow fido-x -your workaround worked around. ;-) Everythings fine. Thank you!

Newbie

Posts

Joined
Wed Mar 04, 2009 6:38 pm

Post by fido-x » Wed Mar 04, 2009 8:57 pm

You're welcome.

User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia
Who is online

Users browsing this forum: Bing [Bot] and 8 guests