Page 1 of 1

Error: E-Mail sender required!

Posted: Sun Feb 08, 2009 4:48 pm
by csleepg
I keep getting error Error: E-Mail sender required! when register new user / forgotten option. This never happend in 0.7.9 version.Hope to get some solution soon.

Re: Error: E-Mail sender required!

Posted: Sun Feb 08, 2009 7:32 pm
by roiy
hey ,

i am getting also the same error as described here :

"Error: E-Mail sender required!"  :-\

i am getting this error for registering a new user.

i my php.ini i have putted this details:

SMTP = x.x.x.x
smtp_port = 25
sendmail_from = user@mydomain.com

any other configuration needed for sending mail through the store ? where ?

thanks for the help ,

Roiy N

Re: Error: E-Mail sender required!

Posted: Mon Feb 09, 2009 6:07 am
by Daniel
I've just spotted this problem as well. I'm going to fix it and release another version tonight.

Re: Error: E-Mail sender required!

Posted: Wed Feb 11, 2009 7:48 am
by sp8cemonkey
How do I upgrade from 1.0 to 1.1?

Re: Error: E-Mail sender required!

Posted: Wed Feb 11, 2009 8:36 am
by Daniel
1. First off backup your site.
2. Download a backup of your database.
3. Delete the files in your hosting directory
4. upload the files from the download.
5. go through the install as normal.
6. once the install is finished import the database you backed up. (make sure you don't delete the product_option tables I have added in the v1.1 release.
7. goto the image directory from the backup and copy all the image and upload to the image directory on your hosting.
8. Goto the admin and go through all your products and re-add and options you had.

Re: Error: E-Mail sender required!

Posted: Wed Feb 11, 2009 8:00 pm
by sp8cemonkey
I'm still having the same error with the 1.1 ver.

There's also this error when i try to send any e-mail to a client.

"Error: E-Mail sender required!"

Re: Error: E-Mail sender required!

Posted: Wed Feb 11, 2009 8:42 pm
by sp8cemonkey
Found the reason for the error.
Had inicialy used a hotmail e-mail address on store contacts/settings. After changing it for a normal website e-mail, it runs ok!

Sorry for the trouble, and thanks for the help.

Re: Error: E-Mail sender required!

Posted: Sat Feb 14, 2009 2:10 am
by daelsta
i still have this problem (version 1.1.6)

umpf sry, problem fixed. forgot to add email text after switching language  ::)

Re: Error: E-Mail sender required!

Posted: Sat Feb 14, 2009 2:35 am
by Daniel
checko if your host allows email address from hotmail accounts. They might have a security to stop fraud.