Post by Cyberdude » Sat Nov 13, 2010 7:15 am

I have a BIG problem.

I tried to upgrade 1.4.0 to 1.4.8 for a customer.

But, by mistake i deleted all root files, including the backup file, of Database.

Is their a way to recover or what can i change in DB so that site works again?

now i recieve this error :

Code: Select all

Notice: Undefined index: language_id in /home/puttybab/public_html/index.php on line 109Notice: Undefined index: language_id in /home/puttybab/public_html/index.php on line 109Error: Unknown column 'language_id' in 'where clause'
Error No: 1054
SELECT * FROM weight_class WHERE language_id = '0'
Please help, site is down now.
Last edited by i2Paq on Sat Nov 13, 2010 9:16 pm, edited 1 time in total.
Reason: Title adjusted

User avatar
Active Member

Posts

Joined
Wed Feb 03, 2010 10:39 pm
Location - Belgium

Post by Qphoria » Sat Nov 13, 2010 7:59 am

Contact his host and hope they have a backup.

If the database is still ok then you can upload all the files and then run the upgrade script and you should be ok but you will need the config.php and admin/config.php files for the upgrade to work right

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Cyberdude » Sat Nov 13, 2010 8:01 am

problem is.

I did this.

but, the site had some changes, in template files, modules, payment modules, and language files.

So, i want to upgrade again, but, i will get in trouble.

already mailed, host, i hope they have a backup

User avatar
Active Member

Posts

Joined
Wed Feb 03, 2010 10:39 pm
Location - Belgium

Post by imaginetech » Sat Nov 13, 2010 9:23 am

This thread should be made sticky.

A cautionary tale for those that don't back everything up fully before making major changes.

Good luck, as Q has said your host seems to be your only chance.

Image
www.opencartstore.com
Get OpenCart Templates and OpenCart Modules.


User avatar
Active Member

Posts

Joined
Fri Sep 04, 2009 12:25 pm
Location - Darwin, Australia

Post by i2Paq » Sat Nov 13, 2010 5:47 pm

That is why i always say NEVER to perform an upgrade on a live store but on a copy!

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Cyberdude » Sat Nov 13, 2010 8:32 pm

i have a copy of store, but deleted database backup by mistake.

It whas in root of server, and i deleted it when i whas selecting folders and files...

Still waiting for Host to reply...

User avatar
Active Member

Posts

Joined
Wed Feb 03, 2010 10:39 pm
Location - Belgium

Post by Cyberdude » Sun Nov 14, 2010 1:54 am

ok

hos could recover a backup. Damn i'm lucky.

now i have a issue in admin.

when i go to payment modules it gives me this error:

Error: Could not load language payment/free_checkout!

any idea?

User avatar
Active Member

Posts

Joined
Wed Feb 03, 2010 10:39 pm
Location - Belgium
Who is online

Users browsing this forum: No registered users and 14 guests