Post by Meeker » Thu Nov 04, 2010 11:05 pm

Let me start by saying what a fantastic product opencart is. Its easier to configure than others I tried & failed with!

For some reason this admin panel option does not work. I am developing using v1.4.9.2 on Linux Fasthosts platform. I simply get "Oops! This link appears to be broken" in Firefox if I try to use an SEO keyword against a product.

Sure this should work by default without having to use a .htaccess file? Even if I do use the one supplied in the default template, it just causes Internal Server error 500 issues. I know there have been several other threads about similar issues, but non I could find answered my question.

To repeat, how do I get the SEO URL in the admin panel to work so that I get:
http://www.example.com/product123
instead of
http://www.example.com/index.php?route= ... duct_id=48

User avatar
Active Member

Posts

Joined
Thu Sep 16, 2010 5:45 am

Post by Qphoria » Thu Nov 04, 2010 11:12 pm

Meeker wrote: Sure this should work by default without having to use a .htaccess file? Even if I do use the one supplied in the default template, it just causes Internal Server error 500 issues. I know there have been several other threads about similar issues, but non I could find answered my question.
No it shouldn't since it required mod_rewrite stuff in the htaccess file.
If getting ISE 500 then remove the options +followsymlinks and see if that fixes it

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Meeker » Fri Nov 05, 2010 6:41 pm

Hi Qphoria,

Thanks for your reply. I tried using the default .htaccess.txt and renaming it to .htaccess. Both gave Internal Server 500 errors. I have checked with Fasthosts and mod_rewrite is switched on.

What do you suggest putting in the .htaccess file to get the SEO URLs to work? Surely the default file that came with the base template should work?

User avatar
Active Member

Posts

Joined
Thu Sep 16, 2010 5:45 am

Post by Meeker » Fri Nov 05, 2010 7:01 pm

Actually, I just found a solution. Thanks for your help. I put this in the file based on an earlier post:

Code: Select all

<IfModule mod_rewrite.c>

RewriteEngine on

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

RewriteRule ^(.*)\?*$ index.php?_route_=$1 [L,QSA]
</IfModule>

RewriteBase /

User avatar
Active Member

Posts

Joined
Thu Sep 16, 2010 5:45 am

Post by johans » Mon Nov 14, 2011 9:13 am

I have read a lot of post regarding .htaccess but i have no luck to find the correct solution.

I hope someone can post with there .htaccess that works.

I always get error 500 internal server error. my files and folder are with 777 permission; I guess there is something wrong on .htaccess configuration.

i am using OpenCart 1.5.1.3

Thanks,
Mr. J


New member

Posts

Joined
Mon Oct 17, 2011 5:08 pm

Post by iamskyemedia » Tue Nov 15, 2011 12:08 am

This will definitively make your URLs SEO friendly:
http://www.askabouthugo.com/all-about-p ... -htaccess/

Follow it to the letter. You do not need an extension or anything else. It works.

Newbie

Posts

Joined
Fri Sep 30, 2011 12:10 am
Who is online

Users browsing this forum: No registered users and 11 guests