Page 1 of 1

SEO URLs don't work properly after OC 1.5.4 store migration to a new server

Posted: Thu Mar 22, 2018 2:45 am
by maybeweb
Hello, I just migrated my OpenCart 1.5.4. store to www.liturgix.org/lit154 (new hosting).
Unfortunately, I figured out that all pages using SEO URLs don't load properly and I receive the following error message :
"Not Found
The requested URL /index.php was not found on this server.
Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."
I use the .htaccess file as follows (the same is used on my current hosting):
=========================================================
# Prevent Directoy listing
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
Order deny,allow
Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/

# RewriteBase /
# RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
# RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
# RewriteCond %{REQUEST_FILENAME} !-f
# RewriteCond %{REQUEST_FILENAME} !-d
# RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
# RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

RewriteBase /
RewriteRule sitemap.xml /index.php?route=feed/google_sitemap
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
============================================
Note that the original OpenCart store (identical files) which I am trying to migrate is currently located at www.liturgix.org and it works properly.
Also, the front page as well as the pages that doesn't use SEO URLs load properly (see: http://liturgix.wwwmi3-ss14.a2hosted.co ... on/contact)

For example, following pages experience the issue:
http://liturgix.wwwmi3-ss14.a2hosted.com/lit154/payment [the footer menu, the first column]
http://liturgix.wwwmi3-ss14.a2hosted.co ... 4/delivery [the footer menu, the first column]
as well as the products and categories pages:
http://liturgix.wwwmi3-ss14.a2hosted.co ... nts/priest [the category in the product's menu]
http://liturgix.wwwmi3-ss14.a2hosted.com/lit154/n0039 [a product's page]

Please, advise what to do to resolve the problem.
Your help and time are appreciated!

Re: SEO URLs don't work properly after OC 1.5.4 store migration to a new server

Posted: Thu Mar 22, 2018 3:45 am
by IP_CAM
Well, if your shop is located here:
http:// www. liturgix. org /index.php?route=common/home
OC .HTACCESS Setting looks like this:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
# RewriteBase /
But if your Shop is placed like this:
http:// www. liturgix. org /lit154/index.php?route=common/home
OC .HTACCESS Setting looks like this:

Code: Select all

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/
# RewriteBase /lit154/
Ernie
---

Re: SEO URLs don't work properly after OC 1.5.4 store migration to a new server

Posted: Thu Mar 22, 2018 6:54 pm
by maybeweb
Thanks a lot for your prompt reply and help! All is fine now. ;D
Milka