Post by raymanj » Fri Jul 09, 2010 10:52 am

I am new to OpenCart. I have been using it for 1 1/2 months now. Just recently I upgraded the site from 1.4.7 to 1.4.8b. The site seemed fine once the upgrade was completed. Done little over a week ago.

In the last few days (3 or 4) I have been getting some complaints from customers about being charged multiple times on there credit cards or getting multiple orders when they only placed one. Let me explain a bit more:

Example 1:
Customer places an order with credit card: When they confirm the order they receive the email confirmation for the order. A problem arises when they get 3 email confirmations with 3 different order numbers but look exactly the same. It gets worse when they have 3 charges on their credit card of equal value.

I check the admin section for the orders and they are there, 3 of them. Check credit card settlements with Authorize.net and there are 3 transactions.


Example 2:
Customer places an order with credit card: When they confirm the order they receive the email confirmation for 1 order. Suddenly the customer gets charged twice (same amount).

I check the admin section for the 2nd order, but no other order. I do see in the order list a skipped order number between the customers order and the next order after theirs. I check credit card settlements with Authorize.net and and indeed there are 2 transaction charges for the same amount. Now how can this be if there is no order in the Opencart admin section. Missing order.

Example 3:
Customer places an order with credit card: When they confirm the order they receive the email confirmation for 1 order. Suddenly the customer gets charged twice (same amount).

I check the admin section for the 2nd order, but no other order. I do see in the order list a skipped order number between the customers order and the next order after theirs. I check credit card settlements with Authorize.net and and indeed there are are 2 transaction charges for the same amount, BUT THIS TIME ONE OF THE TRANSACTIONS IS MARKED "DECLINED". So one passed while the other was declined and they occured just a few minutes or seconds apart from each other.


This is giving me some headaches. I hope the site or database is not corrupted.

Any help is much appreciated.

-
Raymanj
Last edited by i2Paq on Fri Jul 09, 2010 1:45 pm, edited 1 time in total.
Reason: Title changed, topic moved

New member

Posts

Joined
Thu May 13, 2010 9:33 am

Post by i2Paq » Fri Jul 09, 2010 1:44 pm

So it only happens when using Credit card?

What happens if you install, just to test, another payment option?

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Karen » Fri Jul 09, 2010 2:50 pm

That last example happens anytime a customer uses a credit card and their first attempt is declined, with any cart. They aren't actually being charged twice. It's stupid, but after declining a charge, the bank still places a reserve on the funds. The declined reserve will drop off their card after 3-5 days. (I once had a customer try 47 TIMES to get his card to go through. Every single one of those declines resulted in a temporary hold against his account.)

Whenever a customer calls for help because their charge was declined, I always take the preemptive step of warning them what they will see on their account, and assuring them that only 1 of those holds will result in an actual charge. Keeps them from panicking or feeling like I'm ripping them off.

Using OC version 1.4.8b
http://catandcaboodle.com/


User avatar
Active Member

Posts

Joined
Thu Jun 10, 2010 2:51 pm
Location - WA State, USA

Post by raymanj » Sat Jul 10, 2010 9:56 am

i2Paq wrote:So it only happens when using Credit card?

What happens if you install, just to test, another payment option?

I am not sure, I have only used credit card (Authorize.net) on the web site. If I did use another payment method what would I use and how would I test it?

I would like to say these errors don't occur on all transactions. Just around half I have noticed in the last few days.


In regards to the declined charge, I suspected something like this was happening. Banks seem to take peoples money and use it for a few days and then give it back. Happens on VOIDS, DECLINES, etc.

Well any other options?

-
Raymanj

New member

Posts

Joined
Thu May 13, 2010 9:33 am

Post by richdtt » Tue Jun 04, 2013 2:22 am

I am having the same problem as example 2. I've been using authorize.net with OpenCart for about a month now and beginning 3 days ago, I started seeing duplicated transactions in my authorize.net account as well (they have the same invoice and charges). I tried contacting authorize.net but they can only guess that OpenCart or the customer is submitting the order twice by clicking confirm more than once. I tried duplicating that myself by double (and triple) clicking the confirm order button while it was processing the charge with authorize.net, but unfortunately, was not able to reproduce that issue that way.

I also tried refreshing after the order was confirm as well as refreshing while the charge was taking place to see if that would work. But that didn't cause the charge to go in twice either.

Any luck anybody else?

Newbie

Posts

Joined
Wed Mar 21, 2012 9:26 am
Who is online

Users browsing this forum: No registered users and 15 guests