Post by Topsecret » Thu Oct 20, 2016 6:12 pm

Beste medegebruikers,

Ik heb het volgende probleem bij de host van een klant.
De Extension Settings for ZIP staan uit.
Deze worden om veiligheidsredenen ook niet aangezet, kreeg ik te horen. Zelf wil de klant ook niet verhuizen naar een andere host.

Hoe kan ik dit bij de installatie omzeilen?
Ik weet wel dat ik een reeds geïnstalleerde OpenCart versie kan kopieren en dan de config.php in de root en admin moet aanpassen. Maar dit is niet echt een oplossing want ik moet dan ook handmatig de database uploaden.
pre-instal.jpg

pre-instal.jpg (63.54 KiB) Viewed 4948 times

Last edited by Topsecret on Thu Oct 20, 2016 6:22 pm, edited 1 time in total.

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am


Post by fido-x » Thu Oct 20, 2016 6:14 pm

This is not an OpenCart issue, this is a server issue. Contact your host and get them to provide zip support in the server.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Topsecret » Thu Oct 20, 2016 6:17 pm

Dear Fido-x,

The host doesn't want to change the PHP extension settings due to security reasons, what they told me.

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am


Post by fido-x » Thu Oct 20, 2016 6:29 pm

Then, I suggest you change hosts. As stated, this is not an OpenCart issue, but a hosting issue.

I know this isn't much help, but anybody else will tell you the same thing.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by fido-x » Thu Oct 20, 2016 6:56 pm

Just had a thought. The installation process could be modified so that it doesn't check for the zip extension on the server. This would then allow the installation to proceed.

Which version of OpenCart are you using?

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Topsecret » Thu Oct 20, 2016 7:49 pm

Hi Fido-x

I know that you can manipulate the installation as the zip extension is not really needed. I just wonder which file I have to adjust. Using OC 2.3.0.2.

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am


Post by fido-x » Thu Oct 20, 2016 8:02 pm

The validation code is in install/controller/install/step_2.php, lines 146 to 148:

Code: Select all

if (!extension_loaded('zip')) {
	$this->error['warning'] = $this->language->get('error_zip');
}
Just comment these lines, like so:

Code: Select all

//if (!extension_loaded('zip')) {
//	$this->error['warning'] = $this->language->get('error_zip');
//}
or remove them. Your choice. That should resolve your issue.

Image
Modules for OpenCart 2.3.0.2
Homepage Module [Free - since OpenCart 0.7.7]
Multistore Extensions
Store Manager Multi-Vendor/Multi-Store management tool

If you're not living on the edge ... you're taking up too much space!


User avatar
Expert Member

Posts

Joined
Sat Jun 28, 2008 1:09 am
Location - Tasmania, Australia

Post by Johnathan » Thu Oct 20, 2016 10:33 pm

There's also a quick fix mod that allows you to use local filecopy, so it doesn't need FTP. That might work for you:

https://www.opencart.com/index.php?rout ... n_id=18892

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by Topsecret » Fri Oct 21, 2016 1:14 am

All you guys.
Thanks for your support.
I'll give it a try tomorrow. Right now it's way past bed time (midnight) in Bangkok.

For Fido-x: I must have overlooked: install/controller/install/step_2.php, lines 146 to 148:


For you all: Keep on the good work...

Kind regards,
Fred

Image


User avatar
Active Member

Posts

Joined
Fri Apr 26, 2013 11:25 am

Who is online

Users browsing this forum: No registered users and 10 guests