Post by adventurebikeshop » Wed Sep 28, 2016 9:55 pm

admin error.png

admin error.png (101.54 KiB) Viewed 974 times

Hi

I have installed a new copy of Opencart 1.5.6.4 on our server with a new domain name. The idea is to tweek this to mini our old site that is outdated. I have uploaded the database from the old site and all seems OK. BUT I cannot access the admin side of the site to make further changes. I have tried using recommended password cracking files AND altered the database directly in myphp to "password" but nothing works. The error script I get is
Warning: mysql_connect() [function.mysql-connect]: Access denied for user 'adventur_batley'@'server.abodehosting.org' (using password: YES) in /home/adventurebikesho/public_html/system/database/mysql.php on line 6

Notice: Error: Could not make a database link using adventur_batley@www.adventurebikeshop.online in /home/adventurebikesho/public_html/system/database/mysql.php on line 7

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /home/adventurebikesho/public_html/system/database/mysql.php on line 10

Notice: Error: Could not connect to database adventur_advent_abs in /home/adventurebikesho/public_html/system/database/mysql.php on line 11

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/adventurebikesho/public_html/system/database/mysql.php on line 14

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/adventurebikesho/public_html/system/database/mysql.php on line 15

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/adventurebikesho/public_html/system/database/mysql.php on line 16

Warning: mysql_query(): supplied argument is not a valid MySQL-Link resource in /home/adventurebikesho/public_html/system/database/mysql.php on line 17

Notice: Trying to get property of non-object in /home/adventurebikesho/public_html/admin/index.php on line 47

Warning: Invalid argument supplied for foreach() in /home/adventurebikesho/public_html/admin/index.php on line 47

Attached is a screenshot also of the page when trying to access admin

Read loads of posts and tried the suggestions but nothing is working for me.

Help please - PS I am self taught so simple answers please................. ;-)

Thanks

Jenny

New member

Posts

Joined
Thu Feb 23, 2012 7:55 pm

Post by IP_CAM » Thu Sep 29, 2016 3:18 am

a simple answer, change your both CONFIG.PHP files

from:
define('DB_DRIVER', 'mysql');
to:
define('DB_DRIVER', 'mysqli');

and if it still does not work, then, you did NOT use valid Data, in your config.php files
as set, when you created your Database on the Server.

Ernie

Contact: jti@jacob.ch
---
Demos:
OpenCart LIGHT 1.5.6.5: http://www.openshop.li/light/
OpenCart V-PRO 1.5.6.5: http://www.velomech.ch/shop/
V-PRO Multi Theme View: http://www.openshop.li/shop/
---
Downloads:
Free Github OC Downloads: https://github.com/IP-CAM
1'900+ FREE OC Extensions from the world's largest Github OC Archive.
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by victorj » Thu Sep 29, 2016 3:22 am

databse user and or password is not correct difined in config.php located in admin, if front of your shop is functioning correct, copy databaseuser and password from there to config file located in admin folder

Koeltechnische deurrubbers eenvoudig online op maat bestellen.
Alle niet stekplichtige onderdelen zoals scharnieren, sloten, randverwarming en verlichting voor alle typen koelingen en vriezers.
https://koelcel-onderdelen.com


User avatar
Expert Member

Posts

Joined
Sat Jun 25, 2011 4:09 am
Location - Alkmaar Holland

Post by adventurebikeshop » Thu Sep 29, 2016 6:01 pm

THANK YOU XX All seems to be working OK - copied the DB stuff from front shop config to admin config - could have sworn they were the same but hey ho it works.................

New member

Posts

Joined
Thu Feb 23, 2012 7:55 pm
Who is online

Users browsing this forum: No registered users and 15 guests