Page 1 of 1

upgrade problems

Posted: Tue Jun 29, 2010 4:26 am
by barells
I just upgraded from 1.46 to 1.48b, and my store front template is destroyed:

http://www.swellinfo.com/store

The Admin page is loading fine.

I followed the directions, and have gone back through several times. Help please!

Re: upgrade problems

Posted: Tue Jun 29, 2010 5:00 am
by Qphoria
It is showing a blank for your theme name. Be sure something is selected in the admin settings for theme

Re: upgrade problems

Posted: Tue Jun 29, 2010 5:41 am
by barells
neither "default" or "mycustom" template are showing up under the drop down menu. There are no choices there.

I had a problem on a previous upgrade in selecting mycustom template as well, but I cant recall how I got around it.

Any ideas, why I can't choose the templates.

Under, catalog->view->theme-> i have both directories... Thank you for your assistance, my store is currently unusable.

Re: upgrade problems

Posted: Tue Jun 29, 2010 6:03 pm
by niron
same problem here, blank screen on my "frontpage" after upgrade, http://www.flakmoped.com

Re: upgrade problems

Posted: Tue Jun 29, 2010 6:13 pm
by JAY6390
Check your error logs in the back of the cart under SETTINGS > ERROR LOG and paste the output of that (no more than the last 10 entries)

Re: upgrade problems

Posted: Tue Jun 29, 2010 6:23 pm
by niron
here is todays log, right after install.

Code: Select all

2010-06-29 9:19:31 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:09 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:11 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:13 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:14 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:15 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:15 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:15 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
2010-06-29 9:20:16 - PHP Warning:  Invalid argument supplied for foreach() in /customers/flakmoped.com/flakmoped.com/httpd.www/admin/controller/common/filemanager.php on line 108
i can put site to Maintenance mode and see header and massage. and if i take
Maintenance OFF , blank screen ?

Re: upgrade problems

Posted: Tue Jun 29, 2010 6:29 pm
by niron
nwm. it works like charm now. donĀ“t know what happend but it works now. ty

Re: upgrade problems

Posted: Tue Jun 29, 2010 6:41 pm
by JAY6390
Weird. As long as it works,thats the main thing :)

Re: upgrade problems

Posted: Tue Jun 29, 2010 9:07 pm
by barells
there is nothing in my error log...

Still looking for help, on how I can select my templates here, since there is no options on my system->theme drop down menu, but the folders are all there.

I haven't dug into the code, but I was thinking maybe it is a PHP setting that is not allowing opencart to figure out which folders exist.

Re: upgrade problems

Posted: Tue Jun 29, 2010 9:17 pm
by Qphoria
be sure your admin/config.php file has an entry for DIR_CATALOG

Re: upgrade problems

Posted: Tue Jun 29, 2010 9:23 pm
by barells
Qphoria wrote:be sure your admin/config.php file has an entry for DIR_CATALOG
It does indeed... I"m looking at the code now to see if there is something not working with my system.

Is there a way to set the template manually in the files?

Re: upgrade problems

Posted: Tue Jun 29, 2010 9:25 pm
by barells
i just confirmed that this line of code is returning nothing:

$directories = glob(DIR_CATALOG . 'view/theme/*', GLOB_ONLYDIR);

in controller/setting/setting.php

Re: upgrade problems

Posted: Tue Jun 29, 2010 9:29 pm
by barells
ok, i fixed it...

The problem was that DIR_CATALOG looked like this:
/public_html/store/catalog

without the trailing backslash, and should have looked like this:
/public_html/store/catalog/

I'm not sure if this was my doing, or something that opencart had influence on during my upgrades along the way...