Post by dupfold » Wed Oct 21, 2015 3:59 am

Hello

I currently have OC installed which I done previously before I opted for easier option of 'plug 'n' play' eCommerce site. In order for that site to display my domain name I had to use CNAME. I've now outgrown my current eCommerce platform due to it's limitations, and therefore would like to return to setting up OC. The problem is with CNAME active, I cannot work out how to access OC admin, if at all possible?

I hope the above make sense? For example with my current eCommerce platform you can buy a domain name from them, or forward if you already have one (which I did). So I therefore used CNAME to forward as such...

www.eCommerce.com forwards (via CNAME) to www.mydomainname.com

In summary I'd like to keep my current eCommerce site live and active using my domain (so CNAME has to remain in place), but at the same time I'd like to be able to set up OC. It would then be ready to go live once I terminate my current eCommerce platform, and remove CNAME. Is this possible please?

Thank you

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by IP_CAM » Thu Oct 22, 2015 4:35 am

Opencart needs it's hardcode-defined HTTP Address, to function:

Code: Select all

define('HTTP_SERVER', 'http://www.jti.li/shop/');
define('HTTP_IMAGE', 'http://openshop.li/shop/image/');
// HTTPS
define('HTTPS_SERVER', 'http://www.jti.li/shop/');
define('HTTPS_IMAGE', 'http://openshop.li/shop/image/');
and it also needs it server Path-Routing, in a DIRECT way:

Code: Select all

// DIR
define('DIR_APPLICATION', '/home/jacobch/www/jti_li/shop/catalog/');
define('DIR_SYSTEM', '/home/jacobch/www/jti_li/shop/system/');
You could therefore 'reroute' a SHOP URL, but the 'following' action would
change the Shop Link to it's DEFAULT Configuration Settings, displaying the
DEFAULT SHOP URL in the Browser URL Address Field.

understud? 8)

Ernie
bigmax.ch/shop/

I am no longer active at this Forum.
Please don't send Personal Messages, contact: jti@jacob.ch
---
Github OC Downloads: https://github.com/IP-CAM
2'000+ FREE OC Extensions from the World's largest Github OC Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by dupfold » Tue Jul 26, 2016 1:45 am

Hi IP_CAM

Many thanks for your reply. Sorry for delay, but this switch to OpenCart took a back seat due to lack of time etc, but here I am again to hopefully get it done this time!

Erm... I think I get what you are saying, but not having much joy implementing it as I'm getting warnings when trying to access admin....
Warning: require_once(/home/myusername/www/mydomain_com/shop/system/startup.php) [function.require-once]: failed to open stream: No such file or directory in /home/myusername/public_html/admin/index.php on line 17
Any ideas where I'm going wrong please?

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by IP_CAM » Tue Jul 26, 2016 1:59 am

/home/myusername/www/mydomain_com/shop/system/startup.php
No such file or directory in:
/home/myusername/public_html/admin/index.php on line 17

thats because you once use /SiTE ROOT/SHOP/... as Subdirectory, and otherwise, you try to
access the ADMIN Section out of the /SITE ROOT/... Main Directory. Despite of the Fact, that
you use two entirely different Server Paths, in the first Place.
/home/myusername/www/mydomain_com/
/home/myusername/public_html/

Ernie

I am no longer active at this Forum.
Please don't send Personal Messages, contact: jti@jacob.ch
---
Github OC Downloads: https://github.com/IP-CAM
2'000+ FREE OC Extensions from the World's largest Github OC Archive.


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by dupfold » Wed Aug 03, 2016 1:14 am

Thanks IP_CAM, but this is a fresh install after deleting old one. I installed to site root.

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am
Who is online

Users browsing this forum: No registered users and 9 guests