Post by MarkIce » Tue Sep 30, 2014 7:53 pm

hi,

the admin v1.5.6.4 side only has 1 email address to input.. which seems to be the same email address that gets sent out for everything from the website.

i would like it that when a customer signs up the "from" email address that shows
in their received email has something like: No-reply@xxx.com

really only on important email sent out like "orders placed" would i like a real reply email address to show up.

any ideas?

New member

Posts

Joined
Sat Mar 01, 2014 5:58 am

Post by k2tec » Wed Oct 01, 2014 6:19 pm

Ithink this will do
in your catalog->model->account->customer.php

Code: Select all

$mail->setFrom($this->config->get('config_email'));
to

Code: Select all

$mail->setFrom('noreply@yourdomain.com');

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by MarkIce » Thu Oct 02, 2014 3:27 am

thanks k2tec

yes it does seem to show the email address: noreply@yourdomain.com on the received email to the customer.
but the problem is i think it's still using the opencart admin real email address and SMTP detail to send the email out.

and now being picked up as a spam email, because i think your code is only really cloaking over the email noreply@ over the websites admin main email address..

because i can still see the websites main admin email address within the " noreply's" emails source header code.

but thank you for your reply...

New member

Posts

Joined
Sat Mar 01, 2014 5:58 am

Post by k2tec » Thu Oct 02, 2014 2:21 pm

I think you have to setup a noreply email account.
Than look at this:
http://phpmailer.worxware.com/index.php?pg=exampleamail
and change your settings in the customer mail function.

Code: Select all

$mail = new Mail();
		$mail->protocol = $this->config->get('config_mail_protocol');
		$mail->parameter = $this->config->get('config_mail_parameter');
		$mail->hostname = $this->config->get('config_smtp_host');
		$mail->username = $this->config->get('config_smtp_username');
		$mail->password = $this->config->get('config_smtp_password');
		$mail->port = $this->config->get('config_smtp_port');
		$mail->timeout = $this->config->get('config_smtp_timeout');				
		$mail->setTo($data['email']);
		$mail->setFrom($this->config->get('config_email'));
to

Code: Select all

$mail = new Mail();
		$mail->protocol =('SMTP');
		$mail->parameter = ('noreply@yourdomain.com');
		$mail->hostname =('mail.yourdomain.com');
		$mail->username = ('noreply@yourdomain.com');
		$mail->password = ('yourpassword');
		$mail->port = ('yoursmtpport');
		$mail->timeout = $this->config->get('config_smtp_timeout');				
		$mail->setTo($data['email']);
		$mail->setFrom($this->config->get('config_email'));

User avatar
Active Member

Posts

Joined
Mon Apr 12, 2010 8:06 pm

Post by MarkIce » Thu Oct 02, 2014 8:31 pm

hi,

i set-up a new email account on my hosting,: noreply@mydomain.com and this is sending and receiving ok . checked in horde on-line hosting mail program..

also updated the new code in: catalog/ model/ account = customer.php

it seem to make a new account on the website side ok, but the costumer isn't receiving any emails.. not even in their spam bin..


old code updated with...

$mail = new Mail();
$mail->protocol =('SMTP');
$mail->parameter =('noreply@mydomain.com');
$mail->hostname =('mail.mydomain.com');
$mail->username =('noreply@mydomain.com');
$mail->password =('xxxxxxx');
$mail->port =('587');
$mail->timeout = $this->config->get('config_smtp_timeout');
$mail->setTo($data['email']);
$mail->setFrom($this->config->get('config_email'));
$mail->setSender($this->config->get('config_name'));
$mail->setSubject(html_entity_decode($subject, ENT_QUOTES, 'UTF-8'));
$mail->setText(html_entity_decode($message, ENT_QUOTES, 'UTF-8'));
$mail->send();

New member

Posts

Joined
Sat Mar 01, 2014 5:58 am
Who is online

Users browsing this forum: No registered users and 6 guests