Post by dentheOC » Wed Sep 17, 2014 6:20 pm

Hello everybody!
I have some issue with opencart. English is not my native language, but I'll try to describe situation the best.
I have a backup content of the web-site and database from my client. Backup files already had problems with configuration, and I need to fix it.

The thing is, that when I try to open the site just typing " http://sitename.tk/ " it turns the link to " http://sitename.tkindex.php/?route= " (exactly like this, even without "/").

How do I fix it?

Newbie

Posts

Joined
Wed Sep 17, 2014 6:04 pm

Post by cwswebdesign » Thu Sep 18, 2014 1:03 am

Sounds like you have a small typo in your config file. Look in the HTTP and HTTPS sections of both config files.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by dentheOC » Thu Sep 18, 2014 1:13 pm

I guess HTTP and HTTPS sections looks fine:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://mysite.tk');
define('HTTP_IMAGE', 'http://mysite.tk/image/');
define('HTTP_ADMIN', 'http://mysite.tk/admin/');
// HTTPS
define('HTTPS_SERVER', 'http://mysite.tk/');
define('HTTPS_IMAGE', 'http://mysite.tk/image/');

Newbie

Posts

Joined
Wed Sep 17, 2014 6:04 pm

Post by cwswebdesign » Thu Sep 18, 2014 8:16 pm

dentheOC wrote:I guess HTTP and HTTPS sections looks fine:

Code: Select all

// HTTP
define('HTTP_SERVER', 'http://mysite.tk');
define('HTTP_IMAGE', 'http://mysite.tk/image/');
define('HTTP_ADMIN', 'http://mysite.tk/admin/');
// HTTPS
define('HTTPS_SERVER', 'http://mysite.tk/');
define('HTTPS_IMAGE', 'http://mysite.tk/image/');
How about the other config file and it looks like you're hiding your domain name here. You're most likely missing a / somewhere.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by dentheOC » Thu Sep 18, 2014 10:04 pm

What another config file? That is the only one which already lies in the "public_html" folder on hosting.
And yes, I'm hiding my domain name, but only for this topic)
There is no mistake there, website logs points to seo_pro.php file:

Code: Select all

2014-09-18 13:54:44 - PHP Notice:  Undefined index: query in pathtowebsite/domains/mysite.tk/html/catalog/controller/common/seo_pro.php on line 103
2014-09-18 13:54:44 - PHP Notice:  Undefined index: route in pathtowebsite/domains/mysite.tk/html/catalog/controller/common/seo_pro.php on line 105

Newbie

Posts

Joined
Wed Sep 17, 2014 6:04 pm

Post by cwswebdesign » Thu Sep 18, 2014 10:53 pm

dentheOC wrote:What another config file? That is the only one which already lies in the "public_html" folder on hosting.
And yes, I'm hiding my domain name, but only for this topic)
There is no mistake there, website logs points to seo_pro.php file:

Code: Select all

2014-09-18 13:54:44 - PHP Notice:  Undefined index: query in pathtowebsite/domains/mysite.tk/html/catalog/controller/common/seo_pro.php on line 103
2014-09-18 13:54:44 - PHP Notice:  Undefined index: route in pathtowebsite/domains/mysite.tk/html/catalog/controller/common/seo_pro.php on line 105
There's a config file in the admin folder too. Don't know what else to tell you when I can't see the site in order to gather more details.

DL

This account is inactive. Look for us under the name 'EvolveWebHosting' and contact us under that username.

Thanks!


User avatar
Active Member

Posts

Joined
Sun Dec 11, 2011 12:26 am
Location - USA

Post by Antoni4 » Fri Sep 19, 2014 2:47 am

Your HTTP setting does have a typo:

It says define('HTTP_SERVER', 'http://mysite.tk'); and it should be define('HTTP_SERVER', 'http://mysite.tk/');

User avatar
New member

Posts

Joined
Sat Sep 29, 2012 7:03 am

Post by dentheOC » Fri Sep 19, 2014 1:20 pm

Antoni4 wrote:Your HTTP setting does have a typo:

It says define('HTTP_SERVER', 'http://mysite.tk'); and it should be define('HTTP_SERVER', 'http://mysite.tk/');
You are right! There was a mistake. Thank you!

Newbie

Posts

Joined
Wed Sep 17, 2014 6:04 pm
Who is online

Users browsing this forum: No registered users and 3 guests