Post by MattWest » Fri Mar 21, 2014 6:20 am

I switched to OpenCart a month ago and managed to set up the whole shop in three days. These forums were a huge help and I managed to find the answers to all my problems here by searching.

But I now have a problem which I can't find a solution for but which seems fairly common.

We had a problem in that we have a store: www.miwk.com which is hosted on www.miwkpublishing.com/store/

If people entered via 'www.miwk.com' then they couldn't click 'add to basket' from the home page.

So searching here I found the .htaccess fix and applied it. I also tweaked both config files in the root and in admin.

I got home this evening to find I can't log into the admin panel. When I login it clears the fields and the url changes to http://www.miwkpublishing.com/store/adm ... mmon/login

The help here advises adding www. to the URLs in the config files.

I've done this, but it still won't let me log in as an admin.

The rest of the shop seems to be working fine, but I'm getting quite panicky now as I just can't get into the thing.

The .htaccess now reads as:

Code: Select all

# 1.To use URL Alias you need to be running apache with mod_rewrite enabled. 

# 2. In your opencart directory rename htaccess.txt to .htaccess.

# For any support issues please visit: http://www.opencart.com

Options +FollowSymlinks

# Prevent Directoy listing 
Options -Indexes

# Prevent Direct Access to files
<FilesMatch "\.(tpl|ini|log)">
 Order deny,allow
 Deny from all
</FilesMatch>

# SEO URL Settings
RewriteEngine On
# If your opencart installation does not run on the main web folder make sure you folder it does run in ie. / becomes /shop/ 


Options +FollowSymlinks
Options -Indexes
RewriteEngine On
RewriteCond %{HTTP_HOST} ^miwkpublishing.com [NC]
RewriteRule ^(.*)$ http://www.miwkpublishing.com/store/$1 [L,R=301]

RewriteBase /
RewriteRule ^sitemap.xml$ index.php?route=feed/google_sitemap [L]
RewriteRule ^googlebase.xml$ index.php?route=feed/google_base [L]
RewriteRule ^download/(.*) /index.php?route=error/not_found [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_URI} !.*\.(ico|gif|jpg|jpeg|png|js|css)
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

### Additional Settings that may need to be enabled for some servers 
### Uncomment the commands by removing the # sign in front of it.
### If you get an "Internal Server Error 500" after enabling any of the following settings, restore the # as this means your host doesn't allow that.

# 1. If your cart only allows you to add one item at a time, it is possible register_globals is on. This may work to disable it:
# php_flag register_globals off

# 2. If your cart has magic quotes enabled, This may work to disable it:
# php_flag magic_quotes_gpc Off

# 3. Set max upload file size. Most hosts will limit this and not allow it to be overridden but you can try
# php_value upload_max_filesize 999M

# 4. set max post size. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value post_max_size 999M

# 5. set max time script can take. uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_execution_time 200

# 6. set max time for input to be recieved. Uncomment this line if you have a lot of product options or are getting errors where forms are not saving all fields
# php_value max_input_time 200

# 7. disable open_basedir limitations
# php_admin_value open_basedir none
The admin config.php currently reads as:

Code: Select all

<?php
// HTTP
define('HTTP_SERVER', 'http://www.miwkpublishing.com/store/admin/');
define('HTTP_CATALOG', 'http://www.miwkpublishing.com/store/');

// HTTPS
define('HTTPS_SERVER', 'http://www.miwkpublishing.com/store/admin/');
define('HTTPS_CATALOG', 'http://www.miwkpublishing.com/store/');

// DIR
define('DIR_APPLICATION', '/home/users/uks/html/miwkpublishing.com/store/admin/');
define('DIR_SYSTEM', '/home/users/uks/html/miwkpublishing.com/store/system/');
define('DIR_DATABASE', '/home/users/uks/html/miwkpublishing.com/store/system/database/');
define('DIR_LANGUAGE', '/home/users/uks/html/miwkpublishing.com/store/admin/language/');
define('DIR_TEMPLATE', '/home/users/uks/html/miwkpublishing.com/store/admin/view/template/');
define('DIR_CONFIG', '/home/users/uks/html/miwkpublishing.com/store/system/config/');
define('DIR_IMAGE', '/home/users/uks/html/miwkpublishing.com/store/image/');
define('DIR_CACHE', '/home/users/uks/html/miwkpublishing.com/store/system/cache/');
define('DIR_DOWNLOAD', '/home/users/uks/html/miwkpublishing.com/store/download/');
define('DIR_LOGS', '/home/users/uks/html/miwkpublishing.com/store/system/logs/');
define('DIR_CATALOG', '/home/users/uks/html/miwkpublishing.com/store/catalog/');
(I've snipped the SQL login details)

Can anyone identify anything obvious here? It's so frustrating that I got this far without having to ask!

Newbie

Posts

Joined
Fri Mar 21, 2014 6:13 am

Post by melbagnato » Sat Mar 22, 2014 11:04 pm

Hi MattWest,

Happy to help. Send me your site's cpanel details via a PM and I'll take a look and fix it for you. What version of OpenCart are you using? Also, are you using vqmod?

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by melbagnato » Fri Mar 28, 2014 8:26 pm

Hi MattWest,

just following up, did you solve your problem ?

- Me

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by tomar99262 » Wed Apr 02, 2014 8:30 pm

Please help me.

My site also not login in admin panel, I also installed new fresh opencart to another directory but still i am not able to login admin.

url

www.solid4you.co.in


Thanks

Newbie

Posts

Joined
Tue Apr 01, 2014 2:11 pm

Post by melbagnato » Thu Apr 03, 2014 11:19 am

Hi tomar99262,

try this extension and see if it solves your problem: http://www.opencart.com/index.php?route ... n_id=13800

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by urbannomadfilmfest » Fri Apr 04, 2014 4:30 am

Hi,

I have the same problem. I did a fresh install of OpenCart. But the admin login fails. I have tried the pwreset.php, which seems to work. But even with that, the login still fails. This is the message:

"No match for Username and/or Password"

Also, I get a message at the top of the admin login screen as follows:

Notice: Trying to get property of non-object in /home/content/12/7717412/html/2014/admin/index.php on line 43

Warning: Invalid argument supplied for foreach() in /home/content/12/7717412/html/2014/admin/index.php on line 43

my site's url: http://2014.urbannomad.tw

Thanks for your help.


Posts

Joined
Fri Apr 04, 2014 4:24 am

Post by Vicky1 » Mon Apr 07, 2014 7:30 am

Pls I have similar problem right now. I can access my admin panel url.
Pls would appreciate to get any help...

Newbie

Posts

Joined
Mon Apr 07, 2014 7:16 am

Post by melbagnato » Tue Apr 08, 2014 6:45 pm

Hi all,

Can you see which version of php your sever is using? I'm guessing you are on php 5.2.

Try to change your version to at least 5.3 and that should fix it.

- Mel

http://online.enterpriseconsulting.com.au

Site with OpenCart extensions & code downloads, many new extensions coming soon!
Follow us on twitter for more updates

Image


User avatar
Active Member

Posts

Joined
Wed Jan 13, 2010 1:39 pm
Location - Melbourne

Post by xander » Sun Apr 27, 2014 9:13 pm

I experienced the same issue for the last 2 days with 1.5.6.1 and 1.5.6.4.

I was 100% sure I am doing no mistake within installation Process (I install it before hundreds of times)

WRONG

Step 3: Line 1 DataBase Driver (never modify it before, never touch it) last 2 day the preset value: MySQLi ,

... you can barely notice

I change it to MySQL and everything work fine as before.


Regards from Romania,
xander

Newbie

Posts

Joined
Sun Apr 27, 2014 4:13 pm

Post by Rharris » Mon Apr 28, 2014 5:07 pm

morning all
I have just upgraded my site to V1.5.4
cannot access the admin panel now all i get is
Notice: Undefined index: token in /home/sites/pioneervet.co.uk/public_html/admin/controller/error/not_found.php on line 16Notice: Undefined index: token in /home/sites/pioneervet.co.uk/public_html/admin/controller/error/not_found.php on line 22
Im stumped. Any help would be appreciated!
Thanks
Ricky

Newbie

Posts

Joined
Thu Nov 07, 2013 1:18 am

Post by Rharris » Tue Apr 29, 2014 8:06 pm

RE RE RE Reinstalled and everything works fine now!

Newbie

Posts

Joined
Thu Nov 07, 2013 1:18 am

Post by MattWest » Fri Oct 03, 2014 12:54 am

Gah - sorry for ignoring the help. I did get it solved in the end after a lot of trouble.

I didn't know anyone had replied to this thread!

Newbie

Posts

Joined
Fri Mar 21, 2014 6:13 am

Post by FlowersInHell » Sun Nov 23, 2014 7:02 am

MattWest wrote:Gah - sorry for ignoring the help. I did get it solved in the end after a lot of trouble.

I didn't know anyone had replied to this thread!

how did you solved the problem, i have the same problem please help!!

User avatar
Newbie

Posts

Joined
Sun Nov 23, 2014 4:38 am

Post by raidgamal2013 » Thu Aug 22, 2019 3:53 pm

Hello I am having trouble accessing the store's control panel so the password and username don't work properly
I tried to enter more than 4 times and do not enter the store :'( :'( :'( :'(

Newbie

Posts

Joined
Tue Aug 20, 2019 3:37 pm

Post by johnp » Thu Aug 22, 2019 4:53 pm

Have you made any changes that could have caused the problem? Added SSL, extensions, scripts etc.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Fast Service for Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
https://www.asandwhenbusinessservices.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK
Who is online

Users browsing this forum: No registered users and 6 guests