Post by PCwhoop » Thu Mar 25, 2010 6:16 am

carlos001 wrote:I install the default Store 1.4.0 and upgrade with the upgrade script( in my lab). I get successful upgrade i can enter perfect in the backof the store( work perfect) But the front of the store i get a blank site and i no have errors in the log error any one can help me!
thanks
When I just did, I had the same problem. but after doing sth with admin, everything came out.
1. go to admin, system->user groups
2. select top administrator, then check every permission
3. system->manager store
4. saw the store URL http://www.PCwhoop.ca/store// , the end of the URL has two slash. delete one.
then everything is ok.

Newbie

Posts

Joined
Thu Mar 25, 2010 5:19 am

Post by srunyon1 » Sat Mar 27, 2010 2:42 pm

will this do 1.4.4?

Active Member

Posts

Joined
Thu Jan 28, 2010 3:03 pm

Post by allenshea » Sun Mar 28, 2010 10:51 am

Qphoria wrote:I am working on a way to make it a bit easier to automate the differences and pass that diff script into an upgrade template for future upgrades.

Hi, Q, can you kindly update this Script? Since Daniel released new version, 1.4.5. he changed Database again.

Thanks!

Allen

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by basics » Mon Mar 29, 2010 9:17 pm

allenshea wrote:
Qphoria wrote:I am working on a way to make it a bit easier to automate the differences and pass that diff script into an upgrade template for future upgrades.

Hi, Q, can you kindly update this Script? Since Daniel released new version, 1.4.5. he changed Database again.

Thanks!

Allen
This would be great if you could do it, I have just had to restore my shop after making a right old hash of the upgrade ::)

........................................................................
http://www.basicsdesignerclothing.co.uk
........................................................................


User avatar
Newbie

Posts

Joined
Fri Mar 26, 2010 4:44 pm

Post by allenshea » Thu Apr 01, 2010 10:37 am

I've successfully use this script with some modification upgrade from 1.4.0 to 1.4.6,

Add below into the script, I also have changed store_id from 1 to 0

Code: Select all

// Add "invoice_id" to order table
$sql = "DESC `" . DB_PREFIX . "order` invoice_id";
$query = $db->query($sql);
if (!$query->num_rows) {
	$sql = "
	ALTER TABLE `" . DB_PREFIX . "order` ADD COLUMN `invoice_id` int(11) collate utf8_unicode_ci NOT NULL Default '0';
	";
}
$db->query($sql);

// Add "invoice_prefix" to order table
$sql = "DESC `" . DB_PREFIX . "order` invoice_prefix";
$query = $db->query($sql);
if (!$query->num_rows) {
	$sql = "
	ALTER TABLE `" . DB_PREFIX . "order` ADD COLUMN `invoice_prefix` varchar(10) collate utf8_bin NOT NULL;
	";
}
$db->query($sql);
I'm not sure if this help others to upgrade your store.

Q, if you can make modification with your script for us would be greatly appreciated.

Allen

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by Mouka » Thu Apr 01, 2010 6:20 pm

Worked like a charm with the additional edit on adminrights and url slash, thanks a lot for making this script!

User avatar
Newbie

Posts

Joined
Tue Feb 16, 2010 7:22 pm
Location - The NWetherlands

Post by allenshea » Thu Apr 01, 2010 7:16 pm

It may still have some problems with this Script, It works fine in English, but in multi-Language I can not add products into cart, after switch from english. The cart is blank.

Fresh new install 1.4.6 in my host is working fine with Multi-Language.

Can anyone help with it?

Allen

I know nothing about PHP and SQL, but I still try my best to understand it.


Active Member

Posts

Joined
Mon Dec 14, 2009 10:01 pm

Post by fmucar » Fri Apr 02, 2010 8:45 am

Fatal error: Call to a member function http() on a non-object in .../public_html/catalog/controller/module/currency.php on line 20


I have upgraded from 1.4.0 to 1.4.3 with the provided script but the front end does give the error above. admin section works fine.

any ideas?



"restore_url_class_in_oc142" is not exactly solving the problem. I apllied it, site works but none of the categories or products are shown.

Newbie

Posts

Joined
Fri Dec 25, 2009 4:12 am

Post by Qphoria » Fri Apr 02, 2010 11:54 am

all this is unrelated to the script. You are talking about custom mods. Search that error for help on that

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by fmucar » Sat Apr 03, 2010 6:44 am

are you sure that currency is a custom mod?

how do i remove it, i want to upgrade it to 1.4.6 but I think there are a lot of changes because of that i cant upgrade it (i am not really a php programmer) and i will have to continue using 1.4.0

I have around 500 products and dont wanna enter all again from scracth.

Newbie

Posts

Joined
Fri Dec 25, 2009 4:12 am

Post by Qphoria » Sat Apr 03, 2010 7:47 am

currency was deprecated in 1.4.0. Just uninstall it

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by GhostHunt » Wed Apr 07, 2010 5:04 am

I tried to upgrade from 1.4.0 to 1.4.3 and now in the admin console when
I try to manage the stores I get


Permission Denied!

You do not have permission to access this page, please refer to your system administrator.

I used the upgrade script from 1.4.0 to 1.4.3 it ran successfully.

Any ideas?

New member

Posts

Joined
Thu Mar 18, 2010 8:58 am

Post by i2Paq » Wed Apr 07, 2010 5:09 am

GhostHunt wrote:I tried to upgrade from 1.4.0 to 1.4.3 and now in the admin console when
I try to manage the stores I get


Permission Denied!

You do not have permission to access this page, please refer to your system administrator.

I used the upgrade script from 1.4.0 to 1.4.3 it ran successfully.

Any ideas?
Check your file and directory CHMOD rights.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by GhostHunt » Wed Apr 07, 2010 5:16 am

I modify the admininstrator to allow access. So I think I figured that problem out
but the store is bascially blank, I can see my data is still there but the store is not displaying
any categories or products?

New member

Posts

Joined
Thu Mar 18, 2010 8:58 am

Post by SiteE@se » Wed Apr 07, 2010 5:38 am

GhostHunt wrote:I modify the admininstrator to allow access. So I think I figured that problem out
but the store is bascially blank, I can see my data is still there but the store is not displaying
any categories or products?
I seem to recall having a similar problem and, if I remember correctly, I simply went into my root category and then saved it again. Warning - at my age memories fade quickly! ;D

Active Member

Posts

Joined
Mon Dec 17, 2007 7:40 am
Location - UK

Post by GhostHunt » Wed Apr 07, 2010 6:43 am

Its fixed. upgrade completed now on 1.4.3. Next up upgrade to 1.4.4.

1) Under User Groups check to make sure your Top_Administrator has all the NEW privs.
2) Under Categories/Products/Information make sure your store is checked.
3) In the store manager make sure the URL conforms to this format:
http://www.myfavsite.com/store/ (note the last "/")

I had one minor data loss which was easy to fix on the store front customized HTML.

Thanks.

New member

Posts

Joined
Thu Mar 18, 2010 8:58 am

Post by zch0071 » Wed Apr 07, 2010 10:23 pm

I have upgraded from 1.4.0 to 1.4.3 with the provided script but it has error below:

Fatal error: Call to a member function http() on a non-object in .......\catalog\controller\module\currency.php on line 20


any idea?

New member

Posts

Joined
Sun Sep 20, 2009 12:10 am

Post by Qphoria » Thu Apr 08, 2010 12:01 am

Uninstall the currency module from the Extensions->Module area. That module is no longer supported

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by tigerton » Fri Apr 09, 2010 4:56 pm

allenshea wrote:It may still have some problems with this Script, It works fine in English, but in multi-Language I can not add products into cart, after switch from english. The cart is blank.

Fresh new install 1.4.6 in my host is working fine with Multi-Language.

Can anyone help with it?

Allen
I made an upgrade from 1.4.x to 1.4.6 and i also have problems inserting products in the cart. I click add to cart and nothing happens the cart is empty.
I have uploaded a clean version (only files) of 1.4.6 and it still didn't work. So i assume it's either something missing in the Database or something is missing in my language-files?
What could possible cause this error/non happening?
Could someone please send med a clean version database in .sql format so i can upload that one and then import my current database to se if i miss something?

My shop is currently unable to take orders so this is a major problem for me :/

Thanks

Newbie

Posts

Joined
Fri Mar 19, 2010 3:36 pm

Post by HKOCH » Fri Apr 09, 2010 5:42 pm

Just exactly what I have been looking for

A drawing or a document stating the correct definition of the 1.4.6 database structure could help us all.

And yes if this was an SQL script it could be much easier

// Henrik

New member

Posts

Joined
Sun Dec 20, 2009 3:33 am
Location - near to Copenhagen, Denmark
Who is online

Users browsing this forum: Bing [Bot] and 19 guests