Post by Qphoria » Sat Mar 13, 2010 3:28 am

OPENCART 1.4.x UPGRADE SCRIPT
==================================

This script will handle all of the following upgrades:

1.4.0 to 1.4.1
1.4.0 to 1.4.2
1.4.0 to 1.4.3
1.4.1 to 1.4.2
1.4.1 to 1.4.3
1.4.2 to 1.4.3

It WILL NOT handle anything earlier than 1.4.0.
If you have an older version, you will need to follow other upgrade steps first to reach 1.4.0


How to Upgrade your 1.4.x site using this script:
=========================================
1. Backup your current site & db
2. Upload the new 1.4.x files to your site, overwriting all existing files EXCEPT the config.php and admin/config.php files
3. Upload this upgrade script to the "root" of your site. The same place you see config.php, index.php, etc
4. Reference this script by typing:
http://www.yoursite.com/shop/upgrade_140_to_143.php
5. After a few seconds you should see "UPGRADE COMPLETE"
- If you see anything other than UPGRADE COMPLETE then please paste it into the forum thread that you got this file from.
6. Load your site and verify it all works.
Be sure to read the complete readme file for additional info.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by gavin m » Sat Mar 13, 2010 4:35 am

Out standing, an upgrade php script instead of a SQL script.

This is a nice step forward for the upgrade route. Good stuff Q.

Active Member

Posts

Joined
Thu Jun 04, 2009 3:23 pm

Post by Qphoria » Sat Mar 13, 2010 4:49 am

I am working on a way to make it a bit easier to automate the differences and pass that diff script into an upgrade template for future upgrades.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by shoo002 » Sat Mar 13, 2010 5:33 am

I knew it would happen, It had to be me.

Ok, This is what i did.

1. Backup
2. Overwrote OC140 files on my server to OC143 (all files uploaded)
3. Uploaded upgrade_140_to_143.php to root folder
4. Typed http://www.thefishingandleisureshop.com ... to_143.php
5. I'm presented with the install screen. I'm not getting the upgrade complete message at all.

What have I done wrong. Can anyone help please.

Thanks
Stewart

Active Member

Posts

Joined
Sat Jul 04, 2009 9:40 pm


Post by Qphoria » Sat Mar 13, 2010 5:41 am

Ah crap.. forgot to say "DONT COPY OVER THE "CONFIG.PHP" and "ADMIN/CONFIG.PHP" files

restore those from your backup. I'll add it to the readme

- EDIT - OK I updated the readme in the first post

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by shoo002 » Sat Mar 13, 2010 5:45 am

Oh dear I didn't backup these files, i just did a backup using OC Backup function and did an sql backup in phpmyadmin.

Am i screwed Q

Thanks for your quick response
Stewart

Active Member

Posts

Joined
Sat Jul 04, 2009 9:40 pm


Post by i2Paq » Sat Mar 13, 2010 5:55 am

Always make a backup, whatever the readme says.

Norman in 't Veldt
Moderator OpenCart Forums

_________________ READ and Search BEFORE POSTING _________________

Our FREE search: Find your answer FAST!.

[How to] BTW + Verzend + betaal setup.


User avatar
Global Moderator

Posts

Joined
Mon Nov 09, 2009 7:00 pm
Location - Winkel - The Netherlands

Post by Qphoria » Sat Mar 13, 2010 5:57 am

Actually the readme DOES say backup. It just forgot to mention to restore those 2 files
But yea you are pretty screwed

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by shoo002 » Sat Mar 13, 2010 6:12 am

Im not sure if this is any good but as you said i was screwed i thought i'd try what i can to get back to normal, so i uploaded an old config file, which allowed me to get to the "UPGRADE SUCCESS" message.

Now i get these errors, any ideas people.

Ist error when accessing my site

Fatal error: Call to a member function https() on a non-object in /home/brockha1/public_html/catalog/controller/module/login.php on line 15


Admin error

Warning: require_once(DIR_SYSTEMstartup.php) [function.require-once]: failed to open stream: No such file or directory in /home/brockha1/public_html/admin/index.php on line 6

Fatal error: require_once() [function.require]: Failed opening required 'DIR_SYSTEMstartup.php' (include_path='.:/usr/lib/php') in /home/brockha1/public_html/admin/index.php on line 6

Active Member

Posts

Joined
Sat Jul 04, 2009 9:40 pm


Post by JavaComics » Sat Mar 13, 2010 9:30 am

Upgrading from 1.4.0 > 1.4.3

I followed the instructions as directed, but now the front end of my store has no products listed, and all the categories have gone, but everything is still there in the admin panel.

also when trying to edit anything in the store manager i get

Error: Unknown column 'ssl' in 'field list'
Error No: 1054
UPDATE store SET name = 'JavaComics', url = 'http://www.javacomics.co.uk//', `ssl` = '0', title = 'Online Comic Store', meta_description = 'JavaComics', template = 'default', country_id = '222', zone_id = '3547', language = 'en', currency = 'GBP', tax = '1', customer_group_id = '8', customer_price = '0', customer_approval = '0', guest_checkout = '1', account_id = '0', checkout_id = '5', stock_display = '0', stock_check = '0', stock_checkout = '1', stock_subtract = '1', order_status_id = '1', stock_status_id = '8', logo = 'store logo.gif', icon = 'javaicon.png', image_thumb_width = '250', image_thumb_height = '250', image_popup_width = '500', image_popup_height = '500', image_category_width = '120', image_category_height = '120', image_product_width = '120', image_product_height = '120', image_additional_width = '150', image_additional_height = '150', image_related_width = '120', image_related_height = '120', image_cart_width = '75', image_cart_height = '75' WHERE store_id = '1'

Newbie

Posts

Joined
Sat Jan 09, 2010 11:07 pm

Post by Qphoria » Sat Mar 13, 2010 10:31 am

shoo002 wrote: Fatal error: Call to a member function https() on a non-object in /home/brockha1/public_html/catalog/controller/module/login.php on line 15
You can't use 1.4.0 modules with 1.4.2 unless you apply this mod:
http://forum.opencart.com/viewtopic.php ... 906#p58291

JavaComics wrote: Error: Unknown column 'ssl' in 'field list'
Ah sorry, didn't realize 1.4.3 added a new SSL field. I'll add that

- EDIT - OK Added to the file in the first post. redownload and try again

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by JavaComics » Sat Mar 13, 2010 10:40 am

re-downloaded and tried again (only running the php update) got the following error

Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ssl' at line 1
Error No: 1064
DESC `store` ssl

Newbie

Posts

Joined
Sat Jan 09, 2010 11:07 pm

Post by Qphoria » Sat Mar 13, 2010 1:14 pm

Odd. I guess `ssl` is a reserved word. fixed. Try again.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by migz » Sat Mar 13, 2010 3:40 pm

I want to upgrade my opencart w/o affecting my custom template. How do i do this? Any changes in the default template? :)

Active Member

Posts

Joined
Mon Feb 01, 2010 2:13 am

Post by jayson » Sat Mar 13, 2010 5:29 pm

Qphoria,

Thanks for this wonderful upgrade script.
I did followed every detail of the upgrade instructions, unfortunately it did not work for me.
I get a blank screen on front end & back end after running script.

1. I successfully upgraded from 1.3.4 to 1.4.0 At this point everything worked okay.
I should mention that my shopping cart is already modified with the news, calendar modules.
2. I upgrade cart as per the instructions on the script.

Running the script, I got, successfully upgraded.
After this just a blank screen.

Luckily for me, I had 2 backup copies of old cart standing by just in case... :)

Thanks in any case, perhaps I should remove the mods and try it again.

New member

Posts

Joined
Tue Feb 23, 2010 4:29 am

Post by JavaComics » Sat Mar 13, 2010 6:13 pm

That appears to be working now, however i still have no products available in my store, everything is gone, all categories, items everything, but they are all showing in the admin panel still and the box is ticked for the main store

Newbie

Posts

Joined
Sat Jan 09, 2010 11:07 pm

Post by Keert » Sat Mar 13, 2010 8:46 pm

JavaComics: I have the same problem ???

New member

Posts

Joined
Sun Feb 14, 2010 3:57 pm

Post by Qphoria » Sat Mar 13, 2010 9:34 pm

Can you guys check to see if under the product edit screen "data" tab, if your "store" is checked for that product?

Also be sure that the url you are typing in matches the store url in the store manager exactly

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by svabbi » Sat Mar 13, 2010 10:22 pm

I have one problem, products are not showing up in basket after I have added it into basket. Any clue ? Also welcome message is not showing after upgrade. I have upgraded to 1.4.3 - www.ilmvatn.net

New member

Posts

Joined
Wed Sep 23, 2009 6:50 pm

Post by JavaComics » Sat Mar 13, 2010 10:54 pm

The data tab was okay with the store ticked,

the URL in the store manager had an extra / at the end

the store is accessable from http://www.mydomain.com/dev/ with all products showing, just doesnt work from mydomain.com/dev

Newbie

Posts

Joined
Sat Jan 09, 2010 11:07 pm
Who is online

Users browsing this forum: No registered users and 6 guests