Page 1 of 1

Tranfer from local to live server problem

Posted: Fri May 31, 2013 8:33 pm
by sidis
Hello everybody read the topics about the solution of this problem to your forum, however I couldn't manage to find a solution yet. I have upload my website to the server and I did that changes to config.php both in admin and root folder.

// HTTP
define('HTTP_SERVER', 'http://metronscandinavia.se/');
define('HTTP_IMAGE', 'http://metronscandinavia.se/image/');
define('HTTP_ADMIN', 'http://metronscandinavia.se/admin/');

// HTTPS
define('HTTPS_SERVER', 'http://metronscandinavia.se/');
define('HTTPS_IMAGE', 'http://metronscandinavia.se/image/');

// DIR
define('DIR_APPLICATION', '/metronscandinavia.se/public_html/catalog/');
define('DIR_SYSTEM', '/metronscandinavia.se/public_html/system/');
define('DIR_DATABASE', '/metronscandinavia.se/public_html/system/database/');
define('DIR_LANGUAGE', '/metronscandinavia.se/public_html/catalog/language/');
define('DIR_TEMPLATE', '/metronscandinavia.se/public_html/catalog/view/theme/');
define('DIR_CONFIG', '/metronscandinavia.se/public_html/system/config/');
define('DIR_IMAGE', '/metronscandinavia.se/public_html/image/');
define('DIR_CACHE', '/metronscandinavia.se/public_html/system/cache/');
define('DIR_DOWNLOAD', '/metronscandinavia.se/public_html/download/');
define('DIR_LOGS', '/metronscandinavia.se/public_html/system/logs/');

When I go to my website I take an HTTP 500 (Internal Server Error) message.. Is my config file correct?? Can it be the .htaccess file problem??

Re: Tranfer from local to live server problem

Posted: Fri May 31, 2013 10:40 pm
by Xyph3r
are you sure that this is the actual path?

Code: Select all

/metronscandinavia.se/public_html/catalog/
Because I don't think so

should be something like

Code: Select all

/home/xxxxxx/public_html/catalog/

Re: Tranfer from local to live server problem

Posted: Sat Jun 01, 2013 11:33 pm
by MarketInSG
different servers are configured differently.

Create a test.php file and echo your realpath of the test.php file out and you will get the correct path

Re: Tranfer from local to live server problem

Posted: Tue Jun 04, 2013 2:46 pm
by sidis
Thank you for your responses I have tried a different path and now I saw the website but I am getting many errors with
Notice: Undefined index: linkto in /storage/content/03/117503/metronscandinavia.se/public_html/vqmod/vqcache/vq2-catalog_controller_common_header.php on line 88Notice: Undefined index: linkto in /storage/content/03/117503/metronscandinavia.se/public_html/vqmod/vqcache/vq2-catalog_controller_common_header.php on line 95
Have you got any suggestions?

Re: Tranfer from local to live server problem

Posted: Tue Jun 04, 2013 4:12 pm
by MarketInSG
remove the vqmod script that is causing the error in vqmod/xml/ folder

Re: Tranfer from local to live server problem

Posted: Tue Jun 04, 2013 6:21 pm
by sidis
Thank you very much MarketInSG,
I did that and I also correct some issues in my database and now everything is ok except from the image manager. When I am trying to upload a picture I take the login screen without any function like the attachment.. How can I solve this issue??

Re: Tranfer from local to live server problem

Posted: Tue Jun 04, 2013 9:41 pm
by MarketInSG
your image manager seems messed up. Are you using the default or a custom one? If you're using the default one, try uploading the files again.

Re: Tranfer from local to live server problem

Posted: Wed Jun 05, 2013 8:22 am
by butte
. . . with FileZilla Client, if you can (it's for Windows), so as to eliminate file corruptions en route.

Re: Tranfer from local to live server problem

Posted: Wed Jun 05, 2013 4:39 pm
by sidis
Thank you very much for the answers, it was again an issue from my hosting which they have solved!!