Post by timmieboy » Mon Aug 19, 2013 3:58 pm

Hello,

I have a question, when someone is ordering, filling in a form or asking a question thru a form I receive double emails. I even have a module now where I receive 4 emails with the same message.

Any one an idea what to do about this. I already have checked the email configuration of the shop.

Thanks

Active Member

Posts

Joined
Thu Jun 10, 2010 2:56 am

Post by MarketInSG » Mon Aug 19, 2013 5:43 pm

first thing, check your vqcache to see if anything is modifying your system/library/mail.php. If no, check if your files are calling $mail->send(); multiple times. If all the answer is no, perhaps check on your mail server


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by timmieboy » Tue Aug 20, 2013 11:05 pm

OK, thank you. I see some system/library/??.ph files but I have no idea where to look for. I see no system/library/mail.php file.

Can you help me with this?

Active Member

Posts

Joined
Thu Jun 10, 2010 2:56 am

Post by MarketInSG » Wed Aug 21, 2013 9:54 am

i'm sure system/library/mail.php exists. Else, you won't be running your OpenCart without any errors


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by timmieboy » Mon Sep 16, 2013 6:03 pm

Ok, thanks, I found the file but I am not sure what to do with it. This is out of my league.

Active Member

Posts

Joined
Thu Jun 10, 2010 2:56 am

User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by timmieboy » Thu Sep 19, 2013 10:42 pm

No idea, I just found the file

Active Member

Posts

Joined
Thu Jun 10, 2010 2:56 am

Post by MarketInSG » Fri Sep 20, 2013 2:07 pm

disable everything in your vqmod/xml folder except for vqmod_opencart.xml. See if it's still doing so


User avatar
Guru Member

Posts

Joined
Wed Nov 16, 2011 11:53 am
Location - Singapore

Post by Renecek » Sun Jan 08, 2017 1:47 am

Hello,

have this problem too in OpenCart 2.2.0. If I receive order I have double mails with the same informations. Any idea how to fix that please?
This is my vqcache folder..

Attachments

Snímka obrazovky 2017-01-07 o 18.47.19.png

Snímka obrazovky 2017-01-07 o 18.47.19.png (99.67 KiB) Viewed 4395 times


New member

Posts

Joined
Thu Dec 10, 2015 7:12 pm

Post by SonyaElsie » Sun May 10, 2020 9:20 pm

Is there any update on this because I am having this problem too and I have followed the recommended check as above. I have tested and the customer only receives the one email (good) but the assigned admin email receives two.

Please help! I have only been using OpenCart for about 2/3 weeks and I am at the end of my first OpenCart website apart from this small glitch. :)

Newbie

Posts

Joined
Mon Apr 20, 2020 8:41 pm

Post by straightlight » Sun May 10, 2020 10:34 pm

SonyaElsie wrote:
Sun May 10, 2020 9:20 pm
Is there any update on this because I am having this problem too and I have followed the recommended check as above. I have tested and the customer only receives the one email (good) but the assigned admin email receives two.

Please help! I have only been using OpenCart for about 2/3 weeks and I am at the end of my first OpenCart website apart from this small glitch. :)
Which OC version are you using?

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Programmer / Opencart Tester


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by ACHINTGUPTA » Mon Oct 26, 2020 3:13 am

MOD NOTE:
I leave your post here for this time, but please do post in the correct version of OC in the future...
---------------------------------------------------------------------------------------------------------------------------------

I too am facing the issue of double email, which i was not receiving earlier, can someone please help me out I am really new to it.

Newbie

Posts

Joined
Mon Apr 06, 2020 9:59 pm

Post by GWShop » Thu Jul 15, 2021 10:03 pm

I have version 3.0.3.7 and I receive double emails for every order.

What is going on?

New member

Posts

Joined
Mon May 24, 2021 1:46 am

Post by Majnoon » Thu Jul 15, 2021 10:07 pm

GWShop wrote:
Thu Jul 15, 2021 10:03 pm
I have version 3.0.3.7 and I receive double emails for every order.

What is going on?
Are you using some mode or any extension which is making modifications to your mail?
Also what theme you are using?

New member

Posts

Joined
Fri Feb 05, 2021 8:29 pm

Post by GWShop » Tue Jul 20, 2021 10:10 am

I use Spare Parts theme.

And also I have installed these extensions:
xshippingpro mod
OC-3.0.3.7-Greek-Translation-Peoplescode

Thank you.

New member

Posts

Joined
Mon May 24, 2021 1:46 am

Post by xxvirusxx » Tue Jul 20, 2021 2:59 pm

95% the email is added as Store email and in Additional Alert Mail

My converted modules | Buy me a beer | Opencart upgrade service


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by GWShop » Fri Jul 23, 2021 12:18 am

Sorry I can't understand.

In which menus do I have to go in order to solve the problem?

Thank you.

New member

Posts

Joined
Mon May 24, 2021 1:46 am

Post by ADD Creative » Fri Jul 23, 2021 6:54 am

GWShop wrote:
Fri Jul 23, 2021 12:18 am
Sorry I can't understand.

In which menus do I have to go in order to solve the problem?

Thank you.
System -> Settings -> Edit (Your Store) -> Mail (Tab) -> Additional Alert Mail. Check that it's empty.

www.add-creative.co.uk


Expert Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom
Who is online

Users browsing this forum: No registered users and 8 guests