Post by hslee5 » Tue Nov 26, 2019 5:18 pm

Hi all, my website was down.

Here is where the error shown on my website.
"
Fatal error: Uncaught Error: Call to undefined function mysql_connect() in /home/orange2y/public_html/system/database/mysql.php:7 Stack trace: #0 /home/orange2y/public_html/vqmod/vqcache/vq2-system_library_db.php(13): DBMySQL->__construct('localhost', 'orange2y_ocar16...', 'abc123ZZ#', 'orange2y_ocar16...') #1 /home/orange2y/public_html/index.php(46): DB->__construct('mysql', 'localhost', 'orange2y_ocar16...', 'abc123ZZ#', 'orange2y_ocar16...') #2 {main} thrown in /home/orange2y/public_html/system/database/mysql.php on line 7
"

I was told by my hosting provider
"
As per checking, the PHP version that your website is previously running is on version 7.2 which is not compatible with your current website scripts.

Therefore, you are required to check with your website developer and make sure that your website is able to run with the PHP version 7.2 with the MySQLi connection instead of MySQL.
"

May I know how can I solve that issue by myself? As my website developer is no longer running the business.

If anyone know how to solve it, can you please help me, really appreciate if you can help me.

Newbie

Posts

Joined
Tue Dec 30, 2014 5:38 pm

Post by johnp » Tue Nov 26, 2019 9:21 pm

This has been covered plenty of times. Either upload the library file for PHP7 or ask your host to roll back PHP on your account to 5.6.

Opencart 1.5.6.5/OC Bootstrap Pro/VQMOD 2.6.1 lover, user and geek.
Affordable Service - Opencart Installs, Fixing, Development and Upgrades
Plus Ecommerce, Marketing, Mailing List Management and More
FREE Guidance and Advice at http://www.ecommerce-help.co.uk


User avatar
Active Member

Posts

Joined
Fri Mar 25, 2011 10:25 am
Location - Surrey, UK

Post by EvolveWebHosting » Sat Dec 14, 2019 5:17 am

johnp wrote:
Tue Nov 26, 2019 9:21 pm
This has been covered plenty of times. Either upload the library file for PHP7 or ask your host to roll back PHP on your account to 5.6.
I would not suggest anyone roll back or run a website using PHP 5.6. This version has been EOL (End of Life) for over a year now and its highly susceptible to being hacked. Work with a developer if needed and upgrade properly to a version of Opencart that supports PHP 7.2 or 7.3 as they are the only 2 versoins that aren't EOL and actively receive any necessary security patches.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: No registered users and 4 guests