Page 1 of 1

Website recorded the wrong payment method when completing a transaction (OC 2.3.0.2)

Posted: Sat Dec 29, 2018 5:55 am
by medgold0
Hello,

An order was successfully completed on my website today where the payment method in Opencart is listed as “Credit Card / Debit Card (Authorize.net)”; however, I later learned that there had not been any credit card transaction. My website has the module "Pay by Invoice / Purchase order" by GeekoDev installed, and many of my customers check out using Pay By Invoice.

I was very lucky to find out about this issue because I had randomly needed to contact the customer on an unrelated matter, and so decided to ask her about using a credit card since she normally requests to be invoiced. The customer insisted that she used “Pay By Invoice” as the payment method to complete the transaction. I then checked my credit card processing records and no card was processed. So the website is telling me I got paid when actually I didn’t. Normally I would not have found this discrepancy until much later - if at all - and very likely would not have gotten paid.

Please help me determine how this happened so it can be prevented!

Re: Website recorded the wrong payment method when completing a transaction (OC 2.3.0.2)

Posted: Sun Dec 30, 2018 3:10 am
by OSWorX
You are writing that someone has installed this module for you.
Now, you are asking us to help you what someone else did wrong?

Guess nobody else than this guy can help you.
Or you post a request in the commercial section of this forum to get help from another developer.