Page 1 of 1

Authorize.Net SIM (Included module with OC 2.1.0.1)

Posted: Mon Oct 12, 2015 2:13 am
by rotaryracer
Hi all - testing a clean installation of OC 2.1.0.1 and noticed that a Auth.net SIM module is now included. We've been using Qphoria's SIM module for 1.5.4.1 and it works great, but figured I would try the included module in this test instance for comparison. I've added my Auth.net ID and transaction key, tried a new MD5 hash, but despite setting the module to "Live", I keep getting the following error:

Error 13: The merchant login ID or password is invalid or the account is inactive.

Additionally, despite being set to "Live", it is routing me to the test Auth.net server at:

https://test.authorize.net/gateway/transact.dll

My Auth.net account is currently set to Live and processing transactions on our production site without issue. I don't believe I have test credentials to use Auth.net's test server, so maybe that's why I'm getting the Error 13? My sense is that if I change the URL to secure.authorize.net, it should be able to process correctly, but I can't find where the Auth.net URL's are stored.

Either way, is this simply a configuration issue that I'm doing incorrectly or is there an issue with the included SIM module?

Thanks in advance,

Jason

Re: Authorize.Net SIM (Included module with OC 2.1.0.1)

Posted: Thu Apr 14, 2016 10:27 pm
by qch
Hello,

I'm having the same problem with the embedded SIM module in 2.2.0.0

For anyone else having trouble with 2.2.0.0, initially I had this problem when clicking on checkout after adding to cart:
2016-04-14 2:56:22 - PHP Notice: Error: Could not load template /home/www/mysite.com/catalog/view/theme/default/template/journal2/template/payment/authorizenet_sim.tpl! in /home/www/mysite.com/vqmod/vqcache/vq2-system_storage_modification_system_library_template_basic.php on line 39

The fix:
https://github.com/opencart/opencart/issues/4159

Now I have this problem, as described by the above post, when clicking checkout after filling in address details:
The following errors have occurred.
(13) The merchant login ID or password is invalid or the account is inactive.

My Authorize.net account is active and "Live", module has details filled in and also "Live". Cart keeps directing to the test URL, https://test.authorize.net/gateway/transact.dll when it should be directing to https://secure.authorize.net/gateway/transact.dll

Anyone know how to sort this out?

Thank you

Re: Authorize.Net SIM (Included module with OC 2.1.0.1)

Posted: Sat May 28, 2016 8:18 am
by integris
Thanks for the github tip, that fixed it for me as well. But I haven't yet found the fix for the "(13) The merchant login ID or password is invalid or the account is inactive." Did you find it?