Post by lennone » Thu Aug 20, 2015 1:42 am

I got an email from Paypal saying (below). And I cant find anything to help me fix it, Im using the Opencart standard payment gateway called "PayPal Website Payment Pro iFrame" and I do not know how to update it. any help would be appreciated.

We are contacting you regarding a change that you are required to make by 30th August 2015.
PayPal has detected that you have hard coded the following Pro Hosted Solution URL in your code:(Had to remove link)

PayPal does not recommend hard coding. Instead, you should read the URL from the button creation API response.

If you must hard code this URL, you need to update it to the following: https://securepayments.paypal.com/webap ... ionProcess

You can find comprehensive instructions regarding the required integration changes on our Technical Support Help Centre: https://ppmts.custhelp.com/app/answers/detail/a_id/1231

Click the above link or visit the PayPal Technical Support Centre and search for article ID ‘1231’ or ‘Updating API Integration for Pro Hosted’ for instructions on ensuring that your payment processing is not interrupted when we stop supporting the current hardcoded URL.

Important: you must either read the URL from the button creation API response or update your hard code URL by no later than 30 August 2015. Otherwise, your existing hard coded Pro Hosted Solution URL will not be supported after that date.

If you require any additional support, our Merchant Technical Support team are on hand and ready to help. You can contact them by opening a ticket on ...

Thank you for your time.

User avatar
Newbie

Posts

Joined
Wed Aug 19, 2015 10:18 pm
Location - Belfast

Post by Simon_Romin » Thu Aug 20, 2015 7:50 pm

Bumping for answer as this affects my site as well.

I'm contacting Paypal to see if their integration team can assist me and if I do get any results I'll post back but if anyone else has already dealt with this it would be very useful.

Newbie

Posts

Joined
Thu Jan 22, 2015 8:24 pm

Post by Simon_Romin » Thu Aug 20, 2015 9:30 pm

Okay... This might be jumping the gun but I think this is it. I'm going to have someone at PP check over my work so to speak but I believe the solution to this is as follows:

catalog/controller/payment/pp_pro_iframe.php
starts line 14 on mine - replace:

Code: Select all

if ($this->config->get('pp_pro_iframe_test')) {
$data['url'] = 'https://securepayments.sandbox.paypal.com/cgi-bin/webscr';
} else {
$data['url'] = 'https://securepayments.paypal.com/cgi-bin/webscr';
}
with

Code: Select all

if ($this->config->get('pp_pro_iframe_test')) {
        $data['url'] = 'https://securepayments.sandbox.paypal.com/cgi-bin/webscr';
} else {
	$data['url'] = 'https://securepayments.paypal.com/webapps/HostedSoleSolutionApp/webflow/sparta/hostedSoleSolutionProcess';
}
Same file little further down - around line 51 for me:

replace

Code: Select all

if ($this->config->get('pp_pro_iframe_test')) {
$data['url'] = 'https://securepayments.sandbox.paypal.com/cgi-bin/webscr';
} else {
$data['url'] = 'https://securepayments.paypal.com/cgi-bin/webscr';
}
with

Code: Select all

if ($this->config->get('pp_pro_iframe_test')) {
$data['url'] = 'https://securepayments.sandbox.paypal.com/cgi-bin/webscr';
} else {
$data['url'] = 'https://securepayments.paypal.com/webapps/HostedSoleSolutionApp/webflow/sparta/hostedSoleSolutionProcess';
}
I've already put through a test payment and it seems to be working okay but I'm getting PP to check it over to be 100%

Newbie

Posts

Joined
Thu Jan 22, 2015 8:24 pm

Post by lennone » Fri Aug 21, 2015 4:06 am

Damn, you gotta love the forum's - anyway...

Please do let me know if PP say its ok?

Is there a diagnostic? or a way to check compliance?

User avatar
Newbie

Posts

Joined
Wed Aug 19, 2015 10:18 pm
Location - Belfast

Post by squiz » Fri Aug 21, 2015 7:43 pm

It would be great if the OpenCart devs could look at this. If this is correct then all of the OpenCart installs from 1.5.6.4 onwards using PP Pro Iframe are simply going to stop working.

New member

Posts

Joined
Sun Aug 08, 2010 9:43 pm

Post by Simon_Romin » Fri Aug 21, 2015 8:22 pm

lennone wrote:Damn, you gotta love the forum's - anyway...

Please do let me know if PP say its ok?

Is there a diagnostic? or a way to check compliance?

Hi Lennone

Got in touch with PP and they have confirmed that this is the correct fix for this issue. They've checked my site and it is okay.

The best way for you to make sure on your own site would be two fold.

1. Put the changes into place and put a test order - actual money not sandbox - through the site. It should clear correctly.

2. Open an account on http://www.paypal.com/mts and ask them to check your site for this. It's what I did and they answered with 24 hours.

Hope this helps you out

Newbie

Posts

Joined
Thu Jan 22, 2015 8:24 pm

Post by squiz » Fri Aug 21, 2015 9:32 pm

I can confirm that this fix works. Just used and tested it on my website. Thank you Simon_Romin :)

I have attached the full file to this post, but please note the file I upload has only been tested on OpenCart version 1.5.6.4.

New member

Posts

Joined
Sun Aug 08, 2010 9:43 pm

Post by straightlight » Tue Aug 25, 2015 10:11 pm

Thanks for posting this solution. PayPal warnings should not be ignored but rather be considered in order to apply the required changes.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com contractor officials representative


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by teratyke » Wed Sep 09, 2015 7:17 pm

Thank you, this also worked for me in 1.5.6.1 However one minor change for 1.5.6.1 was to add the $this to the start of the line.

Active Member

Posts

Joined
Sun Jun 12, 2011 3:05 pm
Who is online

Users browsing this forum: No registered users and 9 guests