Post by Prostarautoparts » Tue Jan 10, 2017 12:32 pm

I have installed the megapro filter along with the mega vehicle filter and all loaded good, but when I use the extention on my website I get the following error

Fatal error: Uncaught exception 'Exception' with message 'Error: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'INNER JOIN `prostar_product_to_store` AS `p2s` ON `p2s`.`product_i' at line 2<br />Error No: 1064<br />SELECT COUNT(DISTINCT `product_id`) AS `total` FROM( INNER JOIN `prostar_product_to_store` AS `p2s` ON `p2s`.`product_id` = `p`.`product_id` AND `p2s`.`store_id` = 0 INNER JOIN `prostar_product_to_mfv` AS `p2mfv` ON `p2mfv`.`product_id` = `p`.`product_id` AND `p2mfv`.`mfilter_vehicle_make_id` = 1 SELECT COUNT(DISTINCT `product_id`) AS `total` FROM(SELECT DISTINCT `p`.`product_id` FROM prostar_product p LEFT JOIN prostar_product_description pd ON (p.product_id = pd.product_id) LEFT JOIN prostar_product_to_store p2s ON (p.product_id = p2s.product_id) INNER JOIN `prostar_product_to_mfv` AS `p2mfv` ON `p2mfv`.`product_id` = `p`.`product_id` AND `p2mfv`.` in /home3/prostar/public_html/parts/system/library/db/mysqli.php on line 40

Can anyone help me out on this?
my testing site is http://www.prostarautoparts.com/parts


Posts

Joined
Tue Jan 10, 2017 12:26 pm

Post by Johnathan » Tue Jan 10, 2017 11:45 pm

It's unlikely anyone here will be able to assist with a commercial extension. You should contact the developer of the extension for support.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by zaidladha » Sat Jun 03, 2017 2:40 pm

Hi I have the exact same error!!!
I have emailed for support, but did you ever find out the solution??

Active Member

Posts

Joined
Wed Jun 05, 2013 3:07 pm

Post by IP_CAM » Sat Jun 03, 2017 8:55 pm

seemengly not, his shop page still displays the same error.
But:
Unknown column 'product_id' in 'field list'
means, that no product_id COLUMN can be found
in the DB oc_product Table, as it looks, for what reason ever
http://prostarautoparts.com/parts/index ... [946,2000]
Ernie

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'100+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by zaidladha » Sun Jun 04, 2017 3:58 am

Ok, for anyone else who gets this error, I managed to randomly fix it by setting gzip compression to 0 in the admin side. My host enabled gzip compression some other way. It seems I am still benefiting from gzip according to checkgzipcompression.com

Active Member

Posts

Joined
Wed Jun 05, 2013 3:07 pm
Who is online

Users browsing this forum: No registered users and 3 guests