Page 1 of 1

New Shipping Extension ERR_EMPTY_RESPONSE

Posted: Fri Nov 16, 2018 1:41 am
by njansen
I have installed a new shipping extension but whenever the edit button is clicked I get ERR_EMPTY_RESPONSE.

This is the route it's failing on minus the token.
admin/index.php?route=extension/shipping/usps_stamps_smart_flexible&token=

When I FTP into the site I am unable to locate the usps_stamps_smart_flexible file in the route above. In my mind it needs to be there. I've checked and the error.log file is not getting any information.

Any help would be appreciated.

Re: New Shipping Extension ERR_EMPTY_RESPONSE

Posted: Fri Nov 16, 2018 1:43 am
by Johnathan
If the /admin/controller/extension/shipping/usps_stamps_smart_flexible.php file is missing, then you try re-installing the extension. You may have installed the wrong version, or the bundle didn't install properly for some reason. If it's just the missing file that's the issue, re-installing should fix it.

If it doesn't, you should contact the extension developer for support. It's unlikely anyone in the forum will be able to assist you with this since it's a commercial extension.

If the developer is unwilling or unable to help, and you want to hire someone to look at this for you, you should post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.

Re: New Shipping Extension ERR_EMPTY_RESPONSE

Posted: Fri Nov 16, 2018 1:45 am
by OSWorX
I am sure that nobody here can you help - maybe one who has also this extension.

Because it is an extension, you should contact the developer first.
If he does not respond, contact the OpenCart Support (if you have the extension from the Marketplace):
https://www.opencart.com/index.php?rout ... rt/support

Re: New Shipping Extension ERR_EMPTY_RESPONSE

Posted: Fri Nov 16, 2018 1:54 am
by njansen
Johnathan wrote:
Fri Nov 16, 2018 1:43 am
If the /admin/controller/extension/shipping/usps_stamps_smart_flexible.php file is missing, then you try re-installing the extension. You may have installed the wrong version, or the bundle didn't install properly for some reason. If it's just the missing file that's the issue, re-installing should fix it.

If it doesn't, you should contact the extension developer for support. It's unlikely anyone in the forum will be able to assist you with this since it's a commercial extension.

If the developer is unwilling or unable to help, and you want to hire someone to look at this for you, you should post a request in the OpenCart "Commercial Support" forum, which is checked by a number of OpenCart developers. You can also try checking out the OpenCart "Partners" area.
I've uninstalled, but there appears to be some lingering php files that relate to the extension. I installed the wrong version thinking I was on opencart 3.x, but quickly realized I was on 2.x. Should I manually remove all the other files related to the extension that appear?

Re: New Shipping Extension ERR_EMPTY_RESPONSE

Posted: Fri Nov 16, 2018 6:06 am
by Johnathan
Yes, manually remove all extension files to fully uninstall it. You can find out what the files are by unzipping the installation bundle and then going through them one-by-one, finding them on your server, and deleting them.