Post by atmanjunath » Thu Jan 28, 2016 12:15 am

I am using Opencart 2.0.1.1. The left side category menu is occupied the entire screen and product is displayed below the category instead of besides category. Please see the attached file.
Help is requested to rectify this problem.
Thanks.

Attachments

Category-Product Display Screen.jpg

Category & Product Display Screen - Category-Product Display Screen.jpg (278.6 KiB) Viewed 544 times


Newbie

Posts

Joined
Fri Oct 16, 2015 1:10 pm

Post by IP_CAM » Thu Jan 28, 2016 4:02 am

This is not an OC Default Theme, therefore, you'll need to contact the Theme Supplier, to get assisted.
No-one else would be able to know, exept, if one would use the same Theme, and the same Setup, as you do.
Ernie
openshop.li

I'm no longer quite active at the Forum, to reach me, better contact: jti@jacob.ch
My free Opencart LIGHT 1.5.6.5 Code is available on GitHub soon,
a Demoversion of it can be seen in Action here: http://www.bigmax.ch
930+ FREE OC Extension-Repositories - from OC v.1.5.x up, on the
world's largest OC-related Github Site: https://github.com/IP-CAM
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by vcabreu.py » Thu Jan 28, 2016 6:40 am

Ello mate.
I ve fixed this only by inspecting the elements of the page, adding some bootstrap's classes and custom CSS to three elements.
Just do some alterations into your .tpl's and CSS. Lets go...

1- add the bootstrap's classes pull-left and col-md-3 to the div that wraps your category list.
step1.jpg

step1.jpg (331.22 KiB) Viewed 536 times


2- add the bootstrap's class and pull-right to the div #content and an id (like thumbs-wrapper) into the div class col-sm-6 inside it.
step2.jpg

step2.jpg (342.69 KiB) Viewed 536 times


3- add $this somewhere into your CSS, styling the ID you've added into the div.

Code: Select all

#thumbs-wrapper ul,
#thumbs-wrapper ul li
{
  list-style:none;
  padding-right:0;
  -webkit-padding-start: 0;
}
Now it looks fine:
fine.jpg

fine.jpg (264.92 KiB) Viewed 536 times

4- Add the name of your theme on the title of this topic, maybe someone with the same problem can find this steps to fix it.

I hope it helped ya, mate

:joker:

User avatar
Newbie

Posts

Joined
Thu Jan 14, 2016 12:30 am
Location - Americana | São Paulo | Brazil
Who is online

Users browsing this forum: No registered users and 5 guests