Post by ABDULLAH_THE_STUDENT » Thu Dec 23, 2021 6:42 pm

I am using Opencart 2.3.0.2 default theme and I have added a manufacturer carousel at the bottom of my home page. It works and looks perfect on desktops however on mobile phones the manufacturer logo is on the complete left of the screen and it only shows one logo at a time any idea on how to fix this and make it look the same as the desktop version.
My store URL is https://a1sound.co.za/


Posts

Joined
Tue Dec 08, 2020 10:01 pm

Post by by mona » Fri Dec 24, 2021 6:02 pm

Not supported by all browsers but not really a necessity to be supported by all browsers.
Thank you for providing both your OC version and your web address - your efforts are appreciated.

Code: Select all

@media (max-width:767px){
#carousel0 {
	zoom: .5;
}
}

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by ABDULLAH_THE_STUDENT » Mon Jan 10, 2022 9:54 pm

thanks for the response, can you let me know where i must add or edit this code


Posts

Joined
Tue Dec 08, 2020 10:01 pm

Post by by mona » Mon Jan 10, 2022 10:24 pm

Ideally to a custom stylesheet but here is fine
catalog/view/theme/default/stylesheet/stylesheet.css

It is an idea to add a section at the end headed
/* MY CUSTOM STYLES */
add the custom css code below it

Reason : this can help in an upgrade

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by ABDULLAH_THE_STUDENT » Wed Jan 12, 2022 5:51 pm

I have added the code under /* MY CUSTOM STYLES */ but it did not fix the problem as only one manufacturer logo is still showing at a time on the left side of the screen it just made the carousal a bit smaller


Posts

Joined
Tue Dec 08, 2020 10:01 pm

Post by by mona » Wed Jan 12, 2022 9:45 pm

Since you say a bit smaller I will assume it is not small enough for you. However the code is not appearing on your site, so maybe you have not added it to a relevant stylesheet. Maybe you have not refreshed your cache ?

Code: Select all

@media (max-width:767px) {
#carousel0 {
	zoom: .2;
}
}

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am

Post by ABDULLAH_THE_STUDENT » Mon Jan 17, 2022 10:07 pm

I changed the code back to the original after your suggested change as it did not solve the problem. It made the manufacturer carousel smaller however even after the change only one companies logo was showing at a time on the left side of the screen. Do you have any other suggestions to solve this problem


Posts

Joined
Tue Dec 08, 2020 10:01 pm

Post by by mona » Mon Jan 17, 2022 10:16 pm

I am afraid if you are unable to implement a quick css solution it would fall outside of the scope of custom support.

You would be better asking in the commercial section viewforum.php?f=88

DISCLAIMER:
You should not modify core files .. if you would like to donate a cup of coffee I will write it in a modification for you.


Spinning Social : Links : Menus : Payments : Socials : Ads : Screen Backgrounds : Galleries : Headers : Banners : Promos


Active Member

Posts

Joined
Mon Jun 10, 2019 9:31 am
Who is online

Users browsing this forum: No registered users and 4 guests