Post by delidolu1adam » Sat Jan 29, 2022 8:59 am

OpenCart Version: 3.0.2.0
Old PHP Version: 7.4
New PHP Version: 8.0

Hello, I have a hosting service from godaddy. And there are 2 websites here.

Someone is running opencart. The other is running special software.

The first website had 7.4 php version and opencart was working fine.

I installed a special software on the second website and updated to php 8.0 the version as the minimum requirement of this software is php 8.0.

but after doing this the opencart installed website did not open. I got an error like this.

" This page is not working

www.******.com is currently unable to process this request.

HTTP ERROR 500 "

I did some research on this and came across something like this.

viewtopic.php?t=216749

But since this is an old opencart version, I haven't tried it as I don't know if it will work for me.

How can I run opencart in PHP 8.0? What should I do for it. Thanks for your help.

Newbie

Posts

Joined
Fri Mar 18, 2016 9:24 pm

Post by xxvirusxx » Sat Jan 29, 2022 4:18 pm

Add PHP 7.4 version in Opencart htaccess.

My Converted Modules | Opencart Upgrade Service | Free Dashboard Maps | Buy me a beer | My Custom OC 3.0.3.8


User avatar
Expert Member

Posts

Joined
Tue Jul 17, 2012 10:35 pm
Location - România

Post by OSWorX » Sat Jan 29, 2022 4:34 pm

delidolu1adam wrote:
Sat Jan 29, 2022 8:59 am
How can I run opencart in PHP 8.0?
All OpenCart versions 3.x and 2.x need php 7.3.x (with some work, php 7.4.x can be used), 1.5.x may work with php 7.3.x (need also some work).
php 8.x is only for OpenCart 4.x (which is still not published to be used in live stores!).

Full Stack Web Developer :: Dedicated OpenCart Development & Support DACH Region
Contact for Custom Work / Fast Support.


User avatar
Guru Member

Posts

Joined
Mon Jan 11, 2010 10:52 pm
Location - Austria

Post by JNeuhoff » Sat Jan 29, 2022 8:15 pm

Curious: What's preventing OC 3.0.3.8 from supporting PHP 8? Is it just the Twig engine?

Override Engine * Integrated VQMod * Unused Images Manager * Instant Option Price Calculator * Number Option * Google Rich Snippets * Google Tag Manager * Export/Import Tool * SpamBot Buster * Survey Plus


User avatar
Guru Member

Posts

Joined
Wed Dec 05, 2007 3:38 am


Post by delidolu1adam » Sun Jan 30, 2022 9:56 am

xxvirusxx wrote:
Sat Jan 29, 2022 4:18 pm
Add PHP 7.4 version in Opencart htaccess.
Can you be a little more descriptive? I didn't understand exactly what to do. Thanks.

Newbie

Posts

Joined
Fri Mar 18, 2016 9:24 pm

Post by delidolu1adam » Sun Jan 30, 2022 9:58 am

OSWorX wrote:
Sat Jan 29, 2022 4:34 pm
delidolu1adam wrote:
Sat Jan 29, 2022 8:59 am
How can I run opencart in PHP 8.0?
All OpenCart versions 3.x and 2.x need php 7.3.x (with some work, php 7.4.x can be used), 1.5.x may work with php 7.3.x (need also some work).
php 8.x is only for OpenCart 4.x (which is still not published to be used in live stores!).
What is preventing it from working? Is there anything that can be done for this? If we find out what's stopping it from working, maybe I can find someone who can do something about it. Thanks.

Newbie

Posts

Joined
Fri Mar 18, 2016 9:24 pm

Post by EvolveWebHosting » Sun Jan 30, 2022 11:39 am

delidolu1adam wrote:
Sun Jan 30, 2022 9:56 am
xxvirusxx wrote:
Sat Jan 29, 2022 4:18 pm
Add PHP 7.4 version in Opencart htaccess.
Can you be a little more descriptive? I didn't understand exactly what to do. Thanks.
He's saying to add this to the bottom of the .htaccess file for your Opencart install that is not working with PHP 8.0 - as long as you're using cPanel control panel

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php74” package as the default “PHP” programming language.
<IfModule mime_module>
AddHandler application/x-httpd-php .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit

Image
$2.75 per month hosting w/ DirectAdmin - free transfers
$14.99 .com Domain Renewal (includes Whois privacy protection)


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by EvolveWebHosting » Sun Jan 30, 2022 11:41 am

delidolu1adam wrote:
Sun Jan 30, 2022 9:58 am
OSWorX wrote:
Sat Jan 29, 2022 4:34 pm
delidolu1adam wrote:
Sat Jan 29, 2022 8:59 am
How can I run opencart in PHP 8.0?
All OpenCart versions 3.x and 2.x need php 7.3.x (with some work, php 7.4.x can be used), 1.5.x may work with php 7.3.x (need also some work).
php 8.x is only for OpenCart 4.x (which is still not published to be used in live stores!).
What is preventing it from working? Is there anything that can be done for this? If we find out what's stopping it from working, maybe I can find someone who can do something about it. Thanks.
This version was released before PHP 8.0 became available so the standard download is not compatible and will not be. Opencart devs are working on Opencart 4.0 that will support PHP 8.0

If you want to make your version of Opencart work with PHP 8.0, it's best to hire a developer - you can create a post in the Commercial Forums section to screen someone and hire them to do the work.

Image
$2.75 per month hosting w/ DirectAdmin - free transfers
$14.99 .com Domain Renewal (includes Whois privacy protection)


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by IP_CAM » Mon Jan 31, 2022 12:13 am

MaxD's OpenCart latest official version (3.0.3.8)
two times faster
PHP 5.4 to PHP 8 supported
error fixes and updated look
simplified installation:
https://opencart.download/

User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by khnaz35 » Mon Jan 31, 2022 12:14 am

IP_CAM wrote:
Mon Jan 31, 2022 12:13 am
MaxD's OpenCart latest official version (3.0.3.8)
two times faster
PHP 5.4 to PHP 8 supported
error fixes and updated look
simplified installation:
https://opencart.download/
Yes, downloaded and tested works well even with most unlike theme Journal theme.

Urgent Questions shoot here: khnaz35@gmail.com
Enjoy nature ;) :) :-*


User avatar
Active Member

Posts

Joined
Mon Aug 27, 2018 11:30 pm
Location - Malaysia

Post by delidolu1adam » Thu Feb 03, 2022 12:50 am

EvolveWebHosting wrote:
Sun Jan 30, 2022 11:39 am
delidolu1adam wrote:
Sun Jan 30, 2022 9:56 am
xxvirusxx wrote:
Sat Jan 29, 2022 4:18 pm
Add PHP 7.4 version in Opencart htaccess.
Can you be a little more descriptive? I didn't understand exactly what to do. Thanks.
He's saying to add this to the bottom of the .htaccess file for your Opencart install that is not working with PHP 8.0 - as long as you're using cPanel control panel

# php -- BEGIN cPanel-generated handler, do not edit
# Set the “ea-php74” package as the default “PHP” programming language.
<IfModule mime_module>
AddHandler application/x-httpd-php .php .php7 .phtml
</IfModule>
# php -- END cPanel-generated handler, do not edit
Thank you for your descriptive message. The code you gave didn't work, but after some research, I found a code that works on GoDaddy.

<IfModule mime_module>
AddHandler application/x-httpd-alt-php74___lsphp .php .html .htm
</IfModule>

Newbie

Posts

Joined
Fri Mar 18, 2016 9:24 pm

Post by EvolveWebHosting » Thu Feb 03, 2022 6:22 am

Makes sense. The server you're using uses LiteSpeed. Glad you got it sorted out!

Image
$2.75 per month hosting w/ DirectAdmin - free transfers
$14.99 .com Domain Renewal (includes Whois privacy protection)


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA
Who is online

Users browsing this forum: No registered users and 24 guests