Page 1 of 1

[SOLVED] Install 2.3.0.2 on PHP 7.2 - mCrypt

Posted: Wed Feb 27, 2019 9:09 pm
by mupcku
Hello folks! I know there are a planty of topics, about the mcrypt extension, wchich was removed in the last php version, but after all i cant find a general solution for the problem.
I want to install OpenCart 2.3.0.2 on my hosting running php 7.2. Okay, mcrypt is deprecated, so i can downgrade the php to 7.1 - no problem till now....what about if i install the oc on 7.1 and after that to upgrade the php on 7.2 OR how to remove or change the mcrypt for this oc version?
As i learned, this encryption is used only for payment methods, which probably i will not use on my store.
Thank you!

Re: Install 2.3.0.2 on PHP 7.2 - mCrypt

Posted: Wed Feb 27, 2019 9:50 pm
by straightlight
The issue here is the OC version you are using. On recent OC versions, the mcrypt library has been removed due to its deprecation by PHP industry.

Re: Install 2.3.0.2 on PHP 7.2 - mCrypt

Posted: Wed Feb 27, 2019 9:51 pm
by mupcku
straightlight wrote:
Wed Feb 27, 2019 9:50 pm
The issue here is the OC version you are using.
Unfortunately, at the moment im unable to use newer version of oc...

Re: Install 2.3.0.2 on PHP 7.2 - mCrypt

Posted: Wed Feb 27, 2019 9:58 pm
by straightlight
Then, you may want to try this extension: https://www.opencart.com/index.php?rout ... n_id=35487

Re: Install 2.3.0.2 on PHP 7.2 - mCrypt

Posted: Wed Feb 27, 2019 10:00 pm
by mupcku
straightlight wrote:
Wed Feb 27, 2019 9:58 pm
Then, you may want to try this extension: https://www.opencart.com/index.php?rout ... n_id=35487
Great! Thanks!