Post by LourensN » Fri Jan 04, 2019 8:56 pm

Hi Guys,
I have done a clean install of OC2.3.0.2 onto linux server via FTP.
I get an all clear on the installation. I see the front end and it looks 100%.
I go to the Admin login and try to login and get this message:

"Warning: htmlspecialchars(): charset `UTF-8;' not supported, assuming utf-8 in /home/***/public_html/***/system/library/cart/user.php on line 39Warning: Cannot modify header information - headers already sent by (output started at /home/***/public_html/***/admin/controller/startup/error.php:34) in /home/***/public_html/***/system/library/response.php on line 12"

I can't find the issue with the clean install. I see in the error message 'UTF-8;' - not sure which file could be causing the drama. Is there something I should know???

HELP!

Newbie

Posts

Joined
Mon Oct 29, 2012 3:19 pm

Post by ADD Creative » Fri Jan 04, 2019 11:25 pm

It's in the php.ini and admin/php.ini files. You need remove the semicolon from the end of each line.

So

Code: Select all

default_charset	= UTF-8;
To

Code: Select all

default_charset	= UTF-8
Once you have done that you may need to make the change elsewhere in your hosting. You may have a MultiPHP INI Editor in your control panel. Which you can use the editor mode tab to make the change. Or it might be in your .htaccess or user.ini files.

www.add-creative.co.uk


Active Member

Posts

Joined
Sat Jan 14, 2012 1:02 am
Location - United Kingdom

Post by LourensN » Sat Jan 05, 2019 4:36 pm

Hi ADD Creative,
Thank you for your swift reply. Bit of a noob question I know - but this will save me huge frustration!
Thanks again!
Lourens

Newbie

Posts

Joined
Mon Oct 29, 2012 3:19 pm

Post by LourensN » Sun Jan 06, 2019 2:49 pm

Hi,
I have made changes to all .ini & htaccess files. I did find instances, but problem still persists. I will check the control panel to see if there is anything there :)
Thanks
Lourens

Newbie

Posts

Joined
Mon Oct 29, 2012 3:19 pm

Post by azimuddin.hasan » Mon Jul 22, 2019 10:51 pm

Perfect answer [FIX] UTF-8 error on Admin login OC2.3.0.2

step 1 : remove the semicolon from the end of UTF-8 all php.ini files
step 2 : remove the semicolon from the end of UTF-8 all user.ini files
step 3 : remove the semicolon from the end of UTF-8 .htaccess file

no need to change database charset.

Thanks
:) :) :)


Posts

Joined
Sun Jun 18, 2017 10:50 pm

Post by LourensN » Tue Jul 23, 2019 6:00 pm

Thank you azimuddin.hasan - I will give this a try.

If only this information was in the installation info, we noobs would not have to keep asking these silly questions :)

Newbie

Posts

Joined
Mon Oct 29, 2012 3:19 pm
Who is online

Users browsing this forum: No registered users and 4 guests