Post by Mosstyn » Mon May 28, 2018 12:45 am

Hi,

Just wondering if anyone can help. I have designed and tested my site on a spare domain and got everything working message-wise, - I received contact emails and order confirmations, with all orders showing up in the right place. I have now migrated the site to the proper domain, updated the ftp settings, and changed the domain name in the PayPal IPN settings, but I'm now not getting any order confirmations, and the dreaded 'missing orders'.

Previously, when I entered the PayPal callback URL on the working site into the browser I'd get a 404. Now I just get a completely blank page. IPN history is showing 'Retrying' with 503 HTML codes.

URL is http://mydomain.co.uk/index.php?route=e ... d/callback

Maybe I was a bit naive in thinking all I had to do was change the domain name. Have I missed anything? The migration seems to be OK otherwise with DB working, etc.

Using OC 2.3.0.2

Any help would be appreciated.
Cheers.

Newbie

Posts

Joined
Tue Aug 01, 2017 7:02 am

Post by Mosstyn » Fri Jun 01, 2018 5:15 am

UPDATE: Paypal is now sending IPN's so my orders are no longer 'missing', but still no order confirmation emails. Any ideas

Newbie

Posts

Joined
Tue Aug 01, 2017 7:02 am

Post by Rainforest » Fri Jun 01, 2018 7:33 pm

Hey,

I'm not sure if this will help. I had an issue with the IPN url being wrong for some orders and some not. There is an IPN log in Paypal which will show success or not. I did the following to set the correct URL:

o, if anyone has this problem. Here is how I solved it:

1. Went into PayPal and into IPN History
2. Looked to see which IPN messages were successful and which were not.
3. Took the URL of the successful messages and put that as my callback URL (which happens to be totally different than the ones suggested by opencart)
4. Problem solved.

You can see my previous post here with the URLS I tried:
viewtopic.php?f=190&t=201112

Let me know if that helps.

Active Member

Posts

Joined
Fri Jan 28, 2011 3:50 am

Post by Mosstyn » Fri Jun 08, 2018 2:04 am

Hi, Thank you for your reply.

My IPN seems to be working OK.
I've just sent a test order through now, and the IPN history is showing 'Sent' and Opencart is showing the order in the proper place, i.e. not 'missing'.
But still no order confirmation email, or any other order-related email.
I have just tried to send a order history notification update via the order panel, and am getting an 'Internal server error' so I think this could be something to do with it.

Newbie

Posts

Joined
Tue Aug 01, 2017 7:02 am

Post by Mosstyn » Sat Jun 09, 2018 4:49 am

If anyone stumbles upon this post in the annals of time, all I can say is 'check your syntax' and use the Queen's English. After some digging, I discovered 'Internal Server Error' means check you server/hosting error logs. I found those (eventually) and it pointed me to an error concerning the order.php file in catalog/language/en-gb/mail/. Turns out I'd edited some text for the order emails and added an apostrophe. PHP syntax doesn't like extra punctuation so was throwing up a simple typo error which stopped confirmation emails and updates being sent out. Took out the offending article and everything now works sweet.

Newbie

Posts

Joined
Tue Aug 01, 2017 7:02 am
Who is online

Users browsing this forum: No registered users and 9 guests