Post by karthickk3 » Fri Mar 31, 2017 4:18 am

Here is what I did:

1. Ensured that Mod_Rewrite is enabled in my server/site.
2. Change htaccess.txt to .htaccess
3. Copy pasted text to my .htaccess as given here http://textuploader.com/drsb6
4. Enabled SEO URL from the admin/settings
5. Entered SEO Keywords without space/special characters/capital letters

Now when I click a product that's SEO optimized, the url works perfectly i.e., it shows as sitename.com/product-name. But the page content loads homepage only although URL is of product's.

Could you please help me?

Newbie

Posts

Joined
Tue Nov 22, 2016 11:05 pm

Post by imdevlper18 » Mon Apr 10, 2017 3:15 pm

Hello,

Can you tell your store url Or you can also email us directly at support@cartbinder.com

Opencart Extensions | Professional opencart support | Support Ticket | support@cartbinder.com


User avatar
Active Member

Posts

Joined
Sun May 11, 2014 2:04 pm

Post by knowband.plugins » Fri Apr 28, 2017 10:07 pm

Hi,

This issue can resolve through .htaccess file. Please check your .htaccess file

Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} !^www\.
RewriteCond %{HTTP_HOST} !^*ip*
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]

Regards,
Knowband Team

Opencart Plugins: Knowband Store
Email: support@knowband.com


User avatar
Active Member

Posts

Joined
Thu Aug 04, 2016 2:56 pm


Post by soamjena » Tue Jan 23, 2018 5:07 pm

knowband.plugins wrote:
Fri Apr 28, 2017 10:07 pm
Hi,

This issue can resolve through .htaccess file. Please check your .htaccess file

Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} !^www\.
RewriteCond %{HTTP_HOST} !^*ip*
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
Thats already in his file.
Whats wrong ?

User avatar
Active Member

Posts

Joined
Mon Feb 13, 2012 3:35 pm

Post by soamjena » Tue Jan 23, 2018 5:10 pm

knowband.plugins wrote:
Fri Apr 28, 2017 10:07 pm
Hi,

This issue can resolve through .htaccess file. Please check your .htaccess file

Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteCond %{HTTP_HOST} !^www\.
RewriteCond %{HTTP_HOST} !^*ip*
RewriteRule ^(.*)$ http://www.%{HTTP_HOST}/$1 [R=301,L]

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule ^([^?]*) index.php?_route_=$1 [L,QSA]
Thats already in his file.
Whats wrong ?

User avatar
Active Member

Posts

Joined
Mon Feb 13, 2012 3:35 pm

Post by Erik66 » Fri Apr 06, 2018 6:44 pm

I think you have not set the correct setting on the server:
make shore the Rewrite is on
$ sudo a2enmod rewrite
$sudo service apache2 restart

on the server find your /etc/apache2/sites-available
in your installation and change the sites-available **.conf
the <Directory "/var/www/xxxxxxxxxx.xx/public_html"> must match where you have the open cart root

RewriteRule (.*) https://%{HTTP_HOST}%{REQUEST_URI}

<Directory "/var/www/xxxxxxxxxx.xx/public_html">
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>

Newbie

Posts

Joined
Fri Apr 06, 2018 6:33 pm
Who is online

Users browsing this forum: No registered users and 5 guests