Post by elie0315 » Wed Jan 04, 2017 8:34 pm

i try to install opencart 2.3.0.2 on my twamp. when i view the index.php it give me a fatal error: Cannot redeclare class Event in C:\Users....\system\engine\event.php on line 7

it give the same error when i try on version 2.2

how can i fix it?

Newbie

Posts

Joined
Wed Jan 04, 2017 8:31 pm

Post by elie0315 » Thu Jan 05, 2017 10:22 am

The complete error message is here:
Fatal error: Cannot declare class Event, because the name is already in use in C:\Users\Supervisor\Dropbox\TWAMPd\htdocs\www\system\engine\event.php on line 7

Newbie

Posts

Joined
Wed Jan 04, 2017 8:31 pm

Post by gfive » Sun Jul 07, 2019 7:28 pm

I have the same problem, did you got it fixed? If so would you mind sharing your solution/?

Newbie

Posts

Joined
Sun Jul 07, 2019 7:25 pm

Post by straightlight » Sun Jul 07, 2019 9:27 pm

gfive wrote:
Sun Jul 07, 2019 7:28 pm
I have the same problem, did you got it fixed? If so would you mind sharing your solution/?
See this solution: https://github.com/opencart/opencart/issues/6744

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 7 guests