Post by vlim » Fri Nov 18, 2016 4:56 am

Hi,
I cloned my 2.0.3.1 site and I removed these folders as suggested by the Straightlight (catalog/model/total
catalog/model/payment, catalog/controller/payment, catalog/model/shipping, catalog/controller/module, admin/controller/total, admin/controller/payment, admin/controller/shipping, admin/controller/module).

I have an extension problem (point of sale and a possible theme problem) but I also noticed in my admin Extensions all I have is Extension Installer and Modifications. Any ideas what to do?

Thank you
Vanessa

Newbie

Posts

Joined
Sun Jul 26, 2015 9:53 am

Post by cyclops12 » Fri Nov 18, 2016 5:07 am

Have you clicked the refresh in extensions/modifications since the upgrade

Expert Member
Online

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by IP_CAM » Fri Nov 18, 2016 10:42 am

If your Custom Extensions are not specifically matching OC v.2.3.0.2, they will not longer function!
Just to mention this! ;)
Ernie

I'm rarely active at the OC Forum lately. To reach me, contact: jti@jacob.ch
A Demoversion of my free OpenCart LIGHT v.1.5.6.5 Software Edition
can be seen in real Action here: http://www.jti.li/shop/
---
1'100+ FREE OC Extension-Repositories - from OC v.1.5.x up,
on the world's largest OC-related Github Site: https://github.com/IP-CAM
---
Image


User avatar
Legendary Member

Posts

Joined
Tue Mar 04, 2014 1:37 am
Location - Switzerland

Post by vlim » Sun Nov 20, 2016 10:07 am

Hi Ernie and cyclops12,

I have refreshed the modifications, but still no extensions or events. Please see attached
The extensions are proving to be difficult because even if they are disabled I can't really test them unless I delete them and at the moment I've not nothing showing up on my page.

I am wondering if instead of cloning whether I should start with a new 2.3.0.2 version then install the theme (though I don't know how to take the theme changes I've got in 2.0.3.1 over to the new one, which is why I cloned) and upload my existing database into it. Sugguestions would be welcomed.

Thanks,
Vanessa

Attachments

extensionproblem.jpg

extensionproblem.jpg (32.54 KiB) Viewed 681 times


Newbie

Posts

Joined
Sun Jul 26, 2015 9:53 am

Post by cyclops12 » Sun Nov 20, 2016 5:14 pm

Have you gone into system/users/user groups edit your admin group then click "Unselect All" and then click "Select All" on both Access and Modify Permissions then Save

Expert Member
Online

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by vlim » Mon Nov 21, 2016 3:05 am

Dear cyclops12,

Thank you, that restored the extensions, modifications and events.

I still have problems with a disabled extension which I deleted all the files that I could find (following a tutorial from iSenselabs) but then oc said there was a problem with the footer in this folder system/storage/modification/system/engine and I just renamed the original to something else but get a blank screen as it's probably looking for a footer that doesn't exist.
I commented out the lines with the theme hoping it might just take this but no luck.

Suggestions would be welcomed Many thanks, Vanessa

<?php
final class Front {
private $registry;
private $pre_action = array();
private $error;

public function __construct($registry) {
$this->registry = $registry;

if (!defined('DIR_CATALOG') && !defined('DIR_OPENCART')) {
if (version_compare(VERSION, '2.0.3.1', '<=')) {
global $loader;

}


}

}

public function addPreAction(Action $pre_action) {
$this->pre_action[] = $pre_action;
}

public function dispatch(Action $action, Action $error) {
$this->error = $error;

foreach ($this->pre_action as $pre_action) {
$result = $this->execute($pre_action);

if ($result instanceof Action) {
$action = $result;

break;
}
}

while ($action instanceof Action) {
$action = $this->execute($action);
}
}

private function execute(Action $action) {
$result = $action->execute($this->registry);

if ($result instanceof Action) {
return $result;
}

if ($result instanceof Exception) {
$action = $this->error;

$this->error = null;

return $action;
}
}
}

Newbie

Posts

Joined
Sun Jul 26, 2015 9:53 am

Post by cyclops12 » Mon Nov 21, 2016 4:17 am

Have you gone into extensions/modifications and clicked refresh then check for errors

Expert Member
Online

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by vlim » Mon Nov 21, 2016 8:20 am

Hi,
Yes I did, so I've deleted a front.php and then that lead to deleting a footer.tpl. When I delete them I get to my new extension problem then when I go to refresh the front.php keeps reappearing, even when I deleted it already.


Is there are way to start from a fresh 2.3.0.2 and to import themes? I'm guessing I can do an import database from phpAdmin but what about themes that we've purchased? I've got another extension (Point of Sale, POS) that has imcompatibity issues and I can imagine that I'll have theme issues.

Thanks,
Vanessa

Newbie

Posts

Joined
Sun Jul 26, 2015 9:53 am
Who is online

Users browsing this forum: No registered users and 9 guests