Post by JoshAmore » Fri Oct 21, 2016 9:48 am

When I go site I get this error...
Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /public_html/mywebsite.com/shop/system/engine/loader.php:169
Stack trace:
#0 [internal function]: Loader->{closure}(Array, Array)
#1 /public_html/mywebsite.com/shop/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array)
#2 /public_html/mywebsite.com/shop/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array)
#3 /public_html/mywebsite.com/shop/catalog/controller/common/cart.php(37): Proxy->getTotal(Array)
#4 [internal function]: ControllerCommonCart->index(Array)
#5 /public_html/mywebsite.com/shop/system/engine/action.php(51): call_user_func_array(Array, Array)
#6 /public_html/mywebsite.com/shop/system/engine/loader.php(24): Action->execute(Object(Registry), Array)
#7 /public_html/mywebsite.com/shop/catalog/controller/common/header.php(129): Loader->controller('common/cart') in /public_html/mywebsite.com/shop/system/engine/loader.php on line 169

Newbie

Posts

Joined
Fri Oct 21, 2016 9:41 am

Post by paulfeakins » Fri Oct 21, 2016 4:54 pm

How did you do the upgrade?

For quick, professional OpenCart support please email info@antropy.co.uk


User avatar
Expert Member

Posts

Joined
Mon Aug 22, 2011 11:01 pm
Location - Reigate, Surrey, United Kingdom

Post by JoshAmore » Sun Oct 23, 2016 1:20 am

I uploaded the contents of the upload folder into my website folders on cpanel using filezilla.

Newbie

Posts

Joined
Fri Oct 21, 2016 9:41 am

Post by EvolveWebHosting » Sun Oct 23, 2016 2:15 am

JoshAmore wrote:I uploaded the contents of the upload folder into my website folders on cpanel using filezilla.
Are you directly upgrading your live site or upgrading on a copy of your database? If you're trying to directly upgrade, I'd hurry up and get a backup restored to your original site.

The upgrade script with v2.3.0.2 has worked for us with no issues for awhile now. Are you sure all files were uploaded without being corrupted?

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by JoshAmore » Sun Oct 23, 2016 2:18 am

I was sure to backup the site and database before the upload. Currently re-uploading in case files were corrupted

Newbie

Posts

Joined
Fri Oct 21, 2016 9:41 am

Post by EvolveWebHosting » Sun Oct 23, 2016 2:31 am

JoshAmore wrote:I was sure to backup the site and database before the upload. Currently re-uploading in case files were corrupted
I would suggest getting your working site back up and running and then creating a subfolder where you can upload the 2.3.0.2 files, copy your config files and create a new database with a copy of your data. You can then run the upgrade and test everything before moving it over to production and create less downtime and stress.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by JoshAmore » Mon Oct 24, 2016 5:02 am

Well I'm upgrading before I launched. Unfortunately after uploading again I'm still having a similar problem.

Newbie

Posts

Joined
Fri Oct 21, 2016 9:41 am

Post by EvolveWebHosting » Mon Oct 24, 2016 6:04 am

JoshAmore wrote:Well I'm upgrading before I launched. Unfortunately after uploading again I'm still having a similar problem.
Something obviously isn't right but it's hard to figure out without being able to see anything and have access to anything. If you want, feel free to send an email to sales@evolvewebhost.com with the domain and FTP / control panel information if you're comfortable with that.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by aamirdell » Wed Oct 26, 2016 7:58 pm

Hi! I was upgrading opencart 1.5.6.4 to 2.3.0.2 All was fine When I tried to finally upgrade all the patches were successful and it shows a message that your opencart upgrade is successful but as I click Continue it shows a fatal error "Fatal error: Class '\openbay\Openbay' not found in /home/aamirdell/public_html/system/library/openbay.php on line 15" No idea what to do Please help
Unable to access admin panel and also website
Please help as my website is down.

Newbie

Posts

Joined
Sat Jul 16, 2016 2:58 pm

Post by Hannah00 » Wed Nov 02, 2016 4:04 pm

Maybe you can find solution at topic viewtopic.php?f=181&t=167850&p=638763#p638763

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm

Post by cyclops12 » Fri Nov 04, 2016 4:36 am

JoshAmore wrote:When I go site I get this error...
Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /public_html/mywebsite.com/shop/system/engine/loader.php:169
Stack trace:
#0 [internal function]: Loader->{closure}(Array, Array)
#1 /public_html/mywebsite.com/shop/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array)
#2 /public_html/mywebsite.com/shop/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array)
#3 /public_html/mywebsite.com/shop/catalog/controller/common/cart.php(37): Proxy->getTotal(Array)
#4 [internal function]: ControllerCommonCart->index(Array)
#5 /public_html/mywebsite.com/shop/system/engine/action.php(51): call_user_func_array(Array, Array)
#6 /public_html/mywebsite.com/shop/system/engine/loader.php(24): Action->execute(Object(Registry), Array)
#7 /public_html/mywebsite.com/shop/catalog/controller/common/header.php(129): Loader->controller('common/cart') in /public_html/mywebsite.com/shop/system/engine/loader.php on line 169
Read through the first post in here: viewtopic.php?f=191&t=166012

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by dookable » Mon Nov 27, 2017 1:37 am

I have just upgraded from 1.5.5.1 to 2.3.0.2

What I did was.
Download/Exported the following list from my database.
database migration 1551-1

address

category
category description
category path
category to store

coupon
coupon category
coupon history
coupon product

customer
customer ban ip not in 2302
customer group
customer group description
customer history
customer ip
customer login

manufacturer
manufacturer to store

option
option description
option value
option value description

order
order history
order option
order product
order status
order total
order voucher

product
product description
product discount
product image
product option
product option value
product related
product reward
product special
product to category
product to layout
product to store

return
return history

setting

tax rate
tax rule

url alias

voucher
voucher history

zone to geo zone


I then installed a clean copy of 2.3.0.2 with a new clean database.

Once installed, I dropped the above list from the new 2302 database and uploaded the exported list from the previous data base.

All my orders, customer logins, products, categories etc are there. I have had to clean a few products in admin but has been no biggy.

I hope this helps someone :)..

New member

Posts

Joined
Thu Sep 04, 2014 11:29 pm
Who is online

Users browsing this forum: No registered users and 6 guests