Post by cyclops12 » Wed Aug 10, 2016 3:42 am

Just tried upgrading my 2.0.3.1 site to the latest 2.3.0.2

First went into admin and uninstalled all oc and vqmods then set site into maintenance mode

Overwrote my files with the latest 2.3.0.2 files except the config.php and admin/config.php

Used qphorias upgrade install script, along with uploading install/opencart.sql and the install/model/upgrade/1008.php to the install folder.

went to my store/install and got the upgrade screen, clicked continue and all 8 patches were applied then clicked continue and get a 500 error and a blank screen

Admin works good so far, have yet to find the extra theme i added but at least i can get into it.
And the module have been duplicated so now have two lots of them all

But front store is just blank.

Any ideas people??

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Wed Aug 10, 2016 4:30 am

First went into admin and uninstalled all oc and vqmods then set site into maintenance mode
Well done !
Overwrote my files with the latest 2.3.0.2 files except the config.php and admin/config.php
What about the .htaccess file? Was it overwritten or you also excluded the file?
Used qphorias upgrade install script, along with uploading install/opencart.sql and the install/model/upgrade/1008.php to the install folder.
Correct.
went to my store/install and got the upgrade screen, clicked continue and all 8 patches were applied then clicked continue and get a 500 error and a blank screen
Followed is the Essentials topic: http://forum.opencart.com/viewtopic.php?f=190&t=165636 . Follow the alternate way of the error logs instructions and see if you can provide any recent errors based on the date-time period of your upgrade process.
And the module have been duplicated so now have two lots of them all
Duplicated files can be tracked obviously. Otherwise, understandably, it could take quite a while to remove the duplicates.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Wed Aug 10, 2016 4:44 am

Thanks for the quick reply straightlight..

.htaccess was not changed/overwritten

I did find some errors in the error log but not sure what they are.....

Code: Select all

[09-Aug-2016 21:37:55 Europe/London] PHP Fatal error:  Uncaught exception 'Exception' with message 
'Error: Could not load model total!' in xxxx/system/engine/loader.php:169
Stack trace:
#0 [internal function]: Loader->{closure}(Array, Array)
#1 xxxx/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array)
#2 xxxx/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array)
#3 xxxx/catalog/controller/common/cart.php(37): Proxy->getTotal(Array)
#4 [internal function]: ControllerCommonCart->index(Array)
#5 xxxx/system/engine/action.php(51): call_user_func_array(Array, Array)
#6 xxxx/system/engine/loader.php(24): Action->execute(Object(Registry), Array)
#7 xxxx/catalog/controller/common/header.php(129): Loader->controller('common/cart') in xxxx/system/engine/loader.php on line 169
The duplicate modules are due to the latest version path changes so not a big problem to sort

Im sure its something silly otherwise the admin wouldnt work if it was something serious

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Wed Aug 10, 2016 5:03 am

Im sure its something silly otherwise the admin wouldnt work if it was something serious
This theory is incorrect. The admin-end can still operate normally while a serious error event could occur on the store-front end. However, based on the above error, yes, this issue is definitely related to duplicated files. The loader should be restricted to the extension folder as I already have mentioned on this topic: http://forum.opencart.com/viewtopic.php ... 50#p628371 as what is going on is EXACTLY happening the way I thought it would.

Unfortunately, since the extensions error events aren't separated from the core events, it is only harden to tell which ones between new files and core files or duplicated files which ones are really causing the problem. :-\

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Thu Aug 11, 2016 2:04 am

Just an update.... i have renamed the admin/controller/total folder and the front end now appears.
Are these files now somewhere else in 2.3.0.2 ?

Now just got to try to get my other them to appear, it is showing in Cpanel...catalog/view/theme but not appearing in the back end to activate it.

Ideas will be helpful.

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Thu Aug 11, 2016 3:14 am

Qphoria updated the bug reports regarding the conflict model issues: http://forum.opencart.com/viewtopic.php?f=191&t=166012

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by straightlight » Thu Aug 11, 2016 3:32 am

This error message above has now been updated by qphoria on the official bug reports topic for v2.3.0.2: http://forum.opencart.com/viewtopic.php?f=191&t=166012

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Qphoria » Thu Aug 11, 2016 4:27 am

cyclops12 wrote:Just tried upgrading my 2.0.3.1 site to the latest 2.3.0.2

Used qphorias upgrade install script, along with uploading install/opencart.sql and the install/model/upgrade/1008.php to the install folder.
My install script? I don't have an install script for 2.3.0.2 other than the one that comes with the opencart zip.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by cyclops12 » Thu Aug 11, 2016 4:36 pm

I thought we had to use your install.zip instead of the default install folder to upgrade or is that just for 2.2 versions??

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Thu Aug 11, 2016 6:45 pm

cyclops12 wrote:I thought we had to use your install.zip instead of the default install folder to upgrade or is that just for 2.2 versions??
The instructions on the official v2.3.0.2 topic on my behalf specifically indicates two files to be replaced from the v2.2.0.0 upgrade tool as this was a workaround until a new official upgrade tool version would be released for the latest version of Opencart as qphoria already indicates from the official upgrade tool topic a warning message that his original [b[upgrade[/b] tool is only for v2.2.0.0 release.

Topics to see: http://forum.opencart.com/viewtopic.php?f=2&t=166011 and http://forum.opencart.com/viewtopic.php ... it=upgrade .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Thu Aug 11, 2016 9:01 pm

straightlight wrote:
Used qphorias upgrade install script, along with uploading install/opencart.sql and the install/model/upgrade/1008.php to the install folder.
Correct
So why did you reply correct if this was not the case?

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Qphoria » Fri Aug 12, 2016 12:22 am

So let's be clear as maybe it was a bit too small of fine print.
2200-upgrade-only.jpg

2200-upgrade-only.jpg (41.91 KiB) Viewed 10532 times


So don't use it as 2.3.0.x already has all the fixes PLUS additional changes and is more up to date.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by cyclops12 » Fri Aug 12, 2016 1:21 am

Which is exactly why i asked in Opencart v2.3.0.2 released! if this was compatble with 2.3.0.2 and straightlight replied....
straightlight wrote:
cyclops12 wrote:So is this suitable for 2.3.0.2 as it says do not use on future versions from 2.2.0.0
upgrade_install.JPG
This upgrade is getting very confusing

Can we not have an upgrade post specifically for the latest 2.3.0.2 version, or an upgrade version that actually works.... I.E have the qphoria upgrade script included into the latest version

We already have 2.2 versions which have loads of bugs/errors which have been sorted in newer versions yet 2.3.0.0 and 2.3.0.1 are both bad builds apparently.
Which Is why I released this post in case confusion would be brought up: http://forum.opencart.com/viewtopic.php ... 11#p631668 . I tested this myself with the experimental tool and provided the steps on how to complete the upgrade with v2.3.0.2 which differs to the warning message from the experimental topic tool.

A screenshot on the link I provided is also included to provide the results and the facts based on the succession of the upgrade. :)
Maybe i misunderstood but i assumed that it was ok to use.

There are so many link to threads which then have links to other threads which then ultimately link back to 2.2 upgrade instructions, which includes the link to your upgrade.zip

Maybe have ONE new post which incorporates the upgrade to 2.3.0.2, it will be alot easier than keep clicking links just to get back to 2.2

Unless i am missing something ??

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Qphoria » Fri Aug 12, 2016 4:58 am

Yes 2.3.0.2 is working fine with its included upgrade that comes with it.
The only major issue is you just need to be sure to remove the extensions from the old path or make the hacky change to that one line in the compatibility file from the second bug in first post here:
http://forum.opencart.com/viewtopic.php ... 12#p631663

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by cyclops12 » Fri Aug 12, 2016 5:17 am

Thank you Qphoria for clearing that up for me.

So should i redo the upgrade and just use the 2.3.0.2 compiled.zip as it comes then(without the 2 config.php files and .htaccess) and then do the extension hack ??

BTW this is only a test upgrade just to see how much work it would be to upgrade my live site

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by avramalex111 » Fri Aug 12, 2016 12:46 pm

Why so many updates? I use 2.0.3.1 and it is great...these updates can ruin my site and after a while there will be no support for 2.0.3.1...

Web Design
MEMOMED 2018
Librarie Online
Creare Magazin Online


Newbie

Posts

Joined
Tue Jun 23, 2015 12:12 am
Location - Bucuresti

Post by snappyfish » Sat Aug 13, 2016 11:54 pm

Qphoria wrote:Yes 2.3.0.2 is working fine with its included upgrade that comes with it.
The only major issue is you just need to be sure to remove the extensions from the old path or make the hacky change to that one line in the compatibility file from the second bug in first post here:
http://forum.opencart.com/viewtopic.php ... 12#p631663
So 2.0.3.1 can be upgraded with upgrade script that comes in 2.3.0.2 download from below without to many errors?

http://www.opencart.com/index.php?route ... d/download

Active Member

Posts

Joined
Thu Apr 14, 2011 4:36 am

Post by cyclops12 » Sun Aug 14, 2016 1:05 am

snappyfish wrote:
Qphoria wrote:Yes 2.3.0.2 is working fine with its included upgrade that comes with it.
The only major issue is you just need to be sure to remove the extensions from the old path or make the hacky change to that one line in the compatibility file from the second bug in first post here:
http://forum.opencart.com/viewtopic.php ... 12#p631663
So 2.0.3.1 can be upgraded with upgrade script that comes in 2.3.0.2 download from below without to many errors?

http://www.opencart.com/index.php?route ... d/download
Whatever you do DO NOT TRY TO UPGRADE YOUR LIVE SITE, i have tried upgrading a completely fresh 2.0.3.1 using the 2.3.0.2 download and even that doesnt work, so wouldnt like to try it with lots of modifications/extensions installed

Feel free to try to upgrade a test site and post up your findings though

Active Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Qphoria » Thu Aug 18, 2016 12:16 pm

Upgrade to 2.3.0.2 will be fine with the upgrade script as long as you go in and manually move/remove all extension files in the old locations

admin/controller/module
admin/controller/payment
admin/controller/shipping
admin/controller/total
catalog/controller/module
catalog/controller/payment
catalog/model/shipping
catalog/model/total

after you clean out all of those your site should run fine with 2.3.0.2

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by snappyfish » Thu Aug 18, 2016 2:24 pm

Qphoria wrote:Upgrade to 2.3.0.2 will be fine with the upgrade script as long as you go in and manually move/remove all extension files in the old locations

admin/controller/module
admin/controller/payment
admin/controller/shipping
admin/controller/total
catalog/controller/module
catalog/controller/payment
catalog/model/shipping
catalog/model/total

after you clean out all of those your site should run fine with 2.3.0.2
Before or after the upgrade?

Active Member

Posts

Joined
Thu Apr 14, 2011 4:36 am
Who is online

Users browsing this forum: No registered users and 15 guests