Post by dupfold » Tue Aug 09, 2016 11:16 pm

Hello

I recently update from 2.2.0.0 to 2.3.02, but now when I visit site I get the following error message...
Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /home/myshop/public_html/system/engine/loader.php:169 Stack trace: #0 [internal function]: Loader->{closure}(Array, Array) #1 /home/myshop/public_html/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array) #2 /home/myshop/public_html/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array) #3 /home/myshop/public_html/catalog/controller/common/cart.php(37): Proxy->getTotal(Array) #4 [internal function]: ControllerCommonCart->index(Array) #5 /home/myshop/public_html/system/engine/action.php(51): call_user_func_array(Array, Array) #6 /home/myshop/public_html/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #7 /home/myshop/public_html/catalog/controller/common/header.php(129): Loader->controller('common/cart') #8 [internal function]: ControllerCommonHeader->index(Array) #9 /home/myshop/public_html/system/engine/action.php(51): call_user_func_array(Array, Array) #10 / in /home/myshop/public_html/system/engine/loader.php on line 169
Any idea how I can fix this please?

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by straightlight » Wed Aug 10, 2016 1:30 am

Hi dupfold,

Followed is a topic that demonstrates the right paths to use with the extensions / modules: http://forum.opencart.com/viewtopic.php?f=183&t=165958

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by dupfold » Wed Aug 10, 2016 10:08 pm

Thanks straightlight, but the problem is I haven't added any extensions to my knowledge. I original installed 2.2.0.0 but came across the "error undefined" bug as we discussed in another post. I didn't have this existing PHP error within 2.2.0.0 however, and all I done since was update to 2.3.0.2.

The only thing I did differently was to go into system > User Groups and gave 'Administrator' access permissions to all as per updating guide http://docs.opencart.com/upgrading/. There is no option there to set back to default to test, so if you think this could be the issue, is there a corresponding file I can re-upload to set user group back to default settings please?

[UPDATE] I'm sure in previous version, 'Shipping', 'Payments' etc had there own tab under Extensions, although now I can only find them via Extensions > Extensions > 'Choose the extension type'. I've found that every extensions has been duplicated. Could this be the issue and how to fix please?

Example...
Feeds (6)
Google Base
Google Sitemap
OpenBay Pro
Google Base
Google Sitemap
OpenBay Pro

Thank you

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by sarthakinfotech » Thu Aug 11, 2016 12:54 am

hi
its working fine if you follow the instruction given at
http://docs.opencart.com/upgrading/

good day.

Good Day,
Hiren
opencart tips and tricks ,
opencart blogs , opencart extensions/themes , custom development.


User avatar
Active Member

Posts

Joined
Tue Aug 05, 2014 1:12 am
Location - india

Post by straightlight » Thu Aug 11, 2016 1:05 am

sarthakinfotech wrote:hi
its working fine if you follow the instruction given at
http://docs.opencart.com/upgrading/

good day.
The information provided from qphoria regarding the Opencart is parallel in this case. The required manual adjustment is not reflected with the opencart docs.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by cyclops12 » Thu Aug 11, 2016 2:25 am

dupfold wrote:Hello

I recently update from 2.2.0.0 to 2.3.02, but now when I visit site I get the following error message...
Fatal error: Uncaught exception 'Exception' with message 'Error: Could not load model total!' in /home/myshop/public_html/system/engine/loader.php:169 Stack trace: #0 [internal function]: Loader->{closure}(Array, Array) #1 /home/myshop/public_html/system/engine/proxy.php(25): call_user_func_array(Object(Closure), Array) #2 /home/myshop/public_html/catalog/controller/common/cart.php(37): Proxy->__call('getTotal', Array) #3 /home/myshop/public_html/catalog/controller/common/cart.php(37): Proxy->getTotal(Array) #4 [internal function]: ControllerCommonCart->index(Array) #5 /home/myshop/public_html/system/engine/action.php(51): call_user_func_array(Array, Array) #6 /home/myshop/public_html/system/engine/loader.php(24): Action->execute(Object(Registry), Array) #7 /home/myshop/public_html/catalog/controller/common/header.php(129): Loader->controller('common/cart') #8 [internal function]: ControllerCommonHeader->index(Array) #9 /home/myshop/public_html/system/engine/action.php(51): call_user_func_array(Array, Array) #10 / in /home/myshop/public_html/system/engine/loader.php on line 169
Any idea how I can fix this please?
I just upgraded to 2.3.0.2 as well and had similar errors......i just renamed the admin/controller/total folder.
I am waiting too see if this makes any difference codewise but at least i can view my site now.
Maybe this will help you too

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by straightlight » Thu Aug 11, 2016 3:14 am

Qphoria updated the bug reports regarding the conflict model issues: http://forum.opencart.com/viewtopic.php?f=191&t=166012

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by Qphoria » Thu Aug 11, 2016 3:25 am

You will have the same issue with shippings and payments
I've actually posted another quick solution that will maintain compatibility with 2.2.x mods

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by dupfold » Mon Aug 22, 2016 10:39 pm

Thanks all, but I still haven't resolved this.

cyclops12 - Can you explain further please. What did you rename exactly? I already have admin/controller/total folder named exactly that way.

straightlight - I checkout that post, but couldn't find a solution.

If possible could someone who has experienced and resolved this exact error post their solution here please, in newbie friendly way as possible. Or perhaps it would simply be easier to uninstall and reinstall. I understand I'd lose everything (settings, products etc), but thankfully as I'm just starting out there is not much to lose right now.

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by cyclops12 » Tue Aug 23, 2016 12:11 am

I did originally just rename the admin/controller/total folder so it was admin/controller/old_total

But there are more folders which should be deleted ( i would personally just rename them for now in case you need them)

If you read the first post Here it will list the folders that need deleting/renaming

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by dupfold » Wed Aug 24, 2016 9:16 pm

Thanks cyclops12. Deleting those folders worked, although I still had duplicate extension showing, so I've now simply uninstall and reinstalled afresh.

Is updating usually this troublesome?

New member

Posts

Joined
Wed Oct 21, 2015 3:42 am

Post by cyclops12 » Thu Aug 25, 2016 12:52 am

dupfold wrote: Is updating usually this troublesome?
Yup lol
I havent come across a shopping cart system that has been easy to upgrade yet.

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Qphoria » Tue Aug 30, 2016 11:31 pm

cyclops12 wrote:
dupfold wrote: Is updating usually this troublesome?
Yup lol
I havent come across a shopping cart system that has been easy to upgrade yet.

The upgrade script for 2.3.0.2 is actually the best ever for opencart, but the extension restructuring is what is wreaking havoc now... and more so, the fact that it attempts to load from the old area in an attempt to support both formats is the major issue here. It was a nice idea, but it caused more problems in the long run.

The next upgrade script will be updated to remove any files in the old locations as long as they already exist in the new location. That should at least clear up most of the problems. However, there is still the issue of the code trying to load the old versions and doesn't do it well. So maybe that code should just be removed in the next release.

Image
Donate!|OpenCart Basics|GeoZones
Image


User avatar
Administrator

Posts

Joined
Tue Jul 22, 2008 3:02 am

Post by Johnathan » Wed Aug 31, 2016 12:23 am

Qphoria wrote:It was a nice idea, but it caused more problems in the long run.
That's because Daniel didn't follow my original fix when I reported it as an issue on github.

Since he decided to reject my fix and use his own, I rolled mine into an OpenCart 2.3 Extension Compatibility Fix, and haven't heard of anyone having issues with my version. I'm charging for it since I have to maintain and support it myself, but I agree it would have been better if it had made it into the core. I'm not sure why Daniel decided not to use it.

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by cyclops12 » Wed Aug 31, 2016 12:34 am

@Qphoria and @Jonathan

Surely with all the trouble with 2.3.0.0 and 2.3.0.1 which have both now been abandoned and now issues with 2.3.0.2, is it best to wait until we have a proper stable version before upgrading.
Most people are being told to upgrade which will fix previous issues but this only means new issues?

I understand its not easy bringing out a new better version of something that will still be compatible with older versions for upgrading purposes but surely more testing is needed BEFORE releasing these new versions.

Just my opinion, and opencart is by far the easiest cart i have worked with so keep up the good work.......

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Johnathan » Wed Aug 31, 2016 1:28 am

I agree that waiting to upgrade is probably a good idea -- I usually recommend people wait at least a month, if not longer, to make sure an OpenCart release is stable. I generally recommend not upgrading at ALL, unless you really need to. Upgrades almost always cause issues, either from bugs in the new version, or issues caused by old extensions or customizations the store owner has performed.

Hopefully Daniel will release a 2.3.0.3 that fixes the bugs not related to extension filepaths. I don't see him doing anything to fix old extension compatibility, so in my opinion that probably will continue to be an issue in 2.3 (which is why I released my compatibility fix).

Image
Image Image Image Image


User avatar
Global Moderator

Posts

Joined
Fri Dec 18, 2009 3:08 am


Post by cyclops12 » Wed Aug 31, 2016 2:02 am

Thank you for your reply Jonathan

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am

Post by Hannah00 » Wed Aug 31, 2016 11:59 am

If you can not fix this error, I suggest you choose other version. Maybe your site is not compatible with 2.3.0.2. This version is too new for OpenCart dev to learn all about it.

Opencart migration & upgrade tool


User avatar
New member

Posts

Joined
Wed May 04, 2016 5:09 pm

Post by cyclops12 » Wed Aug 31, 2016 4:42 pm

Hannah00 wrote:If you can not fix this error, I suggest you choose other version. Maybe your site is not compatible with 2.3.0.2. This version is too new for OpenCart dev to learn all about it.
Not true...
This will also happen with a completely fresh default version of 2.0.3.1 upgrading to 2.3.0.2, you will still have issues with the extra folders being present creating read errors

Expert Member

Posts

Joined
Sun Sep 27, 2015 1:10 am
Who is online

Users browsing this forum: No registered users and 5 guests