Post by visual » Tue Aug 02, 2016 2:25 am

I posted a thread about a PHP compatibility issue I was having while trying to setup OpenCart 2 and for some reason, the thread has disappeared .. was it removed ? .. have I upset someone ?

I am trying to migrate my domain over to Opencart and this was partially based on the fact there was excellent support from you guys. I am just asking a question that may be a valid one for anyone with an incorrect or earlier version of PHP.

I have been getting this response from the server "PHP5.4+ Required" when I try to go into installing OpenCart on my server. Firstly I tried 2.3.0.1 and now have downloaded and uploaded version 2.3.0.2 (latest) with the same response.

What I am asking is that contrary to the System Requirements advertised of "5.3+" .. is this now not the case with the latest versions ? .. and could someone please tell me if I need to use 1.5.6 to get round this issue ?

If I do indeed need the earlier version .. is there major core differences that will make the 1.5.6 version obsolete soon ? .. I have 3 Websites to build and customise and if OpenCart won't cut it on my server .. then I may have to (dare I swear here :P ) have to look at prestashop or even worse zencart ? :joker:

Newbie

Posts

Joined
Tue Aug 02, 2016 12:36 am

Post by straightlight » Tue Aug 02, 2016 2:30 am

visual wrote:I posted a thread about a PHP compatibility issue I was having while trying to setup OpenCart 2 and for some reason, the thread has disappeared .. was it removed ? .. have I upset someone ?

I am trying to migrate my domain over to Opencart and this was partially based on the fact there was excellent support from you guys. I am just asking a question that may be a valid one for anyone with an incorrect or earlier version of PHP.

I have been getting this response from the server "PHP5.4+ Required" when I try to go into installing OpenCart on my server. Firstly I tried 2.3.0.1 and now have downloaded and uploaded version 2.3.0.2 (latest) with the same response.

What I am asking is that contrary to the System Requirements advertised of "5.3+" .. is this now not the case with the latest versions ? .. and could someone please tell me if I need to use 1.5.6 to get round this issue ?

If I do indeed need the earlier version .. is there major core differences that will make the 1.5.6 version obsolete soon ? .. I have 3 Websites to build and customise and if OpenCart won't cut it on my server .. then I may have to (dare I swear here :P ) have to look at prestashop or even worse zencart ? :joker:
It did not disappeared and it wasn't something you said. The posts have simply been moved to the Bug Reports official topic: http://forum.opencart.com/viewtopic.php?f=191&t=166012 as I even provided some replies to it already.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by visual » Tue Aug 02, 2016 2:33 am

Duh .. sorry straightlight .. You must have moved it while I was looking in the parent place. Guess I'm just a noob :laugh:

Newbie

Posts

Joined
Tue Aug 02, 2016 12:36 am

Post by visual » Tue Aug 02, 2016 2:42 am

Hi Straightlight,

I understand perfectly what you are saying regarding the PHP needing upgrading with my hosting company .. but thereby hangs a tale ...

I have had this issue before with them and they tell me that the version I have is the latest to be supported with CPanel as they "claim" that if I wish to go above this .. I would have to go Cloud Server based. The major issue with this is that I have 3 web domains and each one uses a different PHP version to operate. They have tried to move me to cloud before and all 3 websites were down for nearly a month :crazy:

I have no wish to go back there again as it totally killed site relevance in Google for nearly 6 months, waiting for the crawlers to actually realise that the domains weren't actually dead :-[

Newbie

Posts

Joined
Tue Aug 02, 2016 12:36 am

Post by straightlight » Tue Aug 02, 2016 2:51 am

visual wrote:Hi Straightlight,

I understand perfectly what you are saying regarding the PHP needing upgrading with my hosting company .. but thereby hangs a tale ...

I have had this issue before with them and they tell me that the version I have is the latest to be supported with CPanel as they "claim" that if I wish to go above this .. I would have to go Cloud Server based. The major issue with this is that I have 3 web domains and each one uses a different PHP version to operate. They have tried to move me to cloud before and all 3 websites were down for nearly a month :crazy:

I have no wish to go back there again as it totally killed site relevance in Google for nearly 6 months, waiting for the crawlers to actually realise that the domains weren't actually dead :-[
As time goes by, technology evolves. Opencart as well as many other platforms must fit into the Industrial requirements in order to maintain an revolutionized platform and being conformed with the most reliable server requirements as possible. If one hosting party do not share that particular point of view in order to maintain their domain users, I would definitely suggest to look for other options; such as a new host that would understand the fact that a PHP version cannot be maintained eternally by the Industry and will just keep evolving towards higher versions of PHP that involves larger concept compared to what we used to be handled in the past with PHP 4 and PHP 5.

PHP v5.4 is still a reasonable version to upgrade to as there are more and more hosts that already provides PHP 7 in their hosting plans which would be good benefit for every Opencart merchants to consider in the near future.

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.

F. Rules:

- viewtopic.php?f=176&t=200480
- viewtopic.php?f=176&t=200804


Regards,
Straightlight


Legendary Member

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON

Post by visual » Tue Aug 02, 2016 3:14 am

Damnit .. where's that like button ;D

You are absolutely right in your response Straightlight and I appreciate that it is not a OpenCart basic fault, but rather Hosting Companies refusing to keep up with the demands of the Industry ;)

I knew what the error message was trying to say .. but I can now answer which is the latest version I can use with my PHP version, and that appears to be 2.2.0.0.

I hope not many people have my issue, but thought someone may have access to a list of compatible PHP versions rather than trawling all the downloads from current version backwards. Hopefully I can now at least get some uniformity in all 3 websites PHP wise and look towards a general upgrade of version from here on in instead of either not having backward or forward compatibility issues.

I thank you for taking the time out over my issue .. you are a saint Straightlight .. you are cooler than this dude O0

Kind Regards to you and once again .. many thanks for your help ;)

Newbie

Posts

Joined
Tue Aug 02, 2016 12:36 am
Who is online

Users browsing this forum: No registered users and 10 guests