Post by beeman » Fri May 06, 2016 4:14 am

Hello! After using qphoria's service I've upgraded from 1.5.x to OC 2.2 but I'm getting various errors in error_log. Does anyone know the reason why some of these are popping up? Any help is appreciated!

The main error messages I see are

Code: Select all

PHP Fatal error:  Call to undefined method Exception::getClass() in /home/username/public_html/vqmod/vqcache/vq2-system_engine_front.php on line 61

PHP Fatal error:  Call to undefined method ControllerProductLatest::render() in /home/username/public_html/catalog/controller/product/latest.php on line 303

PHP Fatal error:  Call to undefined method Controllerproductbestseller::render() in /home/username/public_html/catalog/controller/product/bestseller.php on line 302

PHP Fatal error:  Call to undefined method Exception::getClass() in /home/username/public_html/vqmod/vqcache/vq2-system_engine_front.php on line 61

PHP Fatal error:  Call to undefined method ControllerCheckoutSimpleCheckout::render() in /home/username/public_html/catalog/controller/checkout/simplecheckout.php on line 233
These two error messages appeared recently..

Code: Select all

Stack trace:
#0 /home/username/public_html/system/library/db.php(16): DB\MySQLi->query('SELECT google_b...', Array)
#1 /home/username/public_html/catalog/model/feed/google_base.php(4): DB->query('SELECT google_b...')
#2 [internal function]: ModelFeedGoogleBase->getCategories()
#3 /home/username/public_html/vqmod/vqcache/vq2-system_storage_modification_system_engine_loader.php(161): call_user_func_array(Array, Array)
#4 [internal func in /home/username/public_html/system/library/db/mysqli.php on line 40

PHP Fatal error:  Allowed memory size of 134217728 bytes exhausted (tried to allocate 21563 bytes) in /home/username/public_html/system/library/db/mysqli.php on line 33
Entire error_log can be found here http://pastebin.com/9L5jtyB4

Thank you! :)

Newbie

Posts

Joined
Tue Nov 13, 2012 11:12 pm

Post by pm-netti » Fri May 06, 2016 4:35 am

Your need remove files in folder vqmod/vqcache and all all vqmod extension files in folder vqmod/xml.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by beeman » Fri May 06, 2016 11:31 am

pm-netti wrote:Your need remove files in folder vqmod/vqcache and all all vqmod extension files in folder vqmod/xml.
In vqmod/xml there was a folder /vqmod/xml/OLD with all the older extensions, I've moved that folder out of /vqmod/xml just in case it was causing the errors.

I also checked vqmod/vqcache but unsure which files need to be deleted. I have journal 2 theme installed so I believe some are from them so I sent them a support ticket to ask which files are journal 2 related but could you check to see if there is anything that stands out that could cause a problem?

Image

Thanks for the help!

Newbie

Posts

Joined
Tue Nov 13, 2012 11:12 pm

Post by pm-netti » Fri May 06, 2016 4:18 pm

You folder vqmod/vqcache must be empty.

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by beeman » Sun May 08, 2016 3:50 am

pm-netti wrote:You folder vqmod/vqcache must be empty.
Thanks, I deleted all the files but the errors are still showing up.. I did more investigating and I think I found the problem.

Before upgrading I had custom pages like "www.mystore.com/index.php?route=product/latest" so when people visited those pages through Google errors would pop up, I made 301 redirects for them back to their correct pages. I hope that will solve the issue.

Thanks for the help!

Newbie

Posts

Joined
Tue Nov 13, 2012 11:12 pm

Post by pm-netti » Sun May 08, 2016 4:02 am

beeman wrote:
pm-netti wrote:You folder vqmod/vqcache must be empty.
Thanks, I deleted all the files but the errors are still showing up.. I did more investigating and I think I found the problem.

Before upgrading I had custom pages like "www.mystore.com/index.php?route=product/latest" so when people visited those pages through Google errors would pop up, I made 301 redirects for them back to their correct pages. I hope that will solve the issue.

Thanks for the help!
If you are emptied folders vqcache and xml, your is not can be any more errors to vqmod cache files,

Image
- - - OpenCart Upgrade Service - - -


User avatar
Active Member

Posts

Joined
Sat Apr 07, 2012 11:22 pm
Location - Kittilä-Finland

Post by milky » Thu Jun 02, 2016 8:56 pm

Hello,

Did you find a solution? I have a similar problem on the checkout page with Journal installed on OC 2.2.0.0

The personal details form fields are slightly off to the right and I get the following error:
Fatal error: Call to undefined method Exception::getClass() in /home/www/mysite.com/NewStore/system/storage/modification/system/engine/front.php on line 138

Thanks

New member

Posts

Joined
Sat Jan 21, 2012 2:04 am

Post by RumenGeorgieff » Thu Jun 30, 2016 7:52 pm

I have the same error when I try to set SSL on the administration.

Code: Select all

PHP Fatal error:  Call to undefined method Exception::getClass() in /home/user/public_html/site.comk/system/engine/front.php on line 61

New member

Posts

Joined
Tue Nov 05, 2013 2:45 am

Post by lvalics » Tue Jul 26, 2016 1:30 pm

Same 500 error on index.php?route=product/latest
With 2.2 I get more error that I got since I use Opencart :-(

Regards,
Valics Lehel

===================
Google AdWords AdCreator


Newbie

Posts

Joined
Wed Jul 06, 2011 1:04 am

Post by straightlight » Tue Jul 26, 2016 7:49 pm

lvalics wrote:Same 500 error on index.php?route=product/latest
With 2.2 I get more error that I got since I use Opencart :-(
Follow the essentials topic - error logs section - http://forum.opencart.com/viewtopic.php?f=190&t=165636 .

The most generated errors being found on Opencart forum originates from contributed programming. The increased post counters are caused by redundancies of the same solutions that were already provided prior.


Regards,
Straightlight
Opencart.com Administrator / Quality Assurance Analyst / Programmer


Administrator

Posts

Joined
Mon Nov 14, 2011 11:38 pm
Location - Canada, ON
Who is online

Users browsing this forum: No registered users and 13 guests