Post by Randem » Tue Mar 15, 2016 5:17 pm

With a new clean installation of OpenCart v2.2.0.0 there are some issue that you will run into that need to be corrected.

I have made an upgrade script that will get you from v2.1.0.x to v2.2.0.0 - http://www.randemsystems.com/support/op ... 0/#msg6260

If you need to com from an earlier version of OpenCart; Upgrade to v2.1.0.x first - http://www.randemsystems.com/support/op ... 0/#msg6260

Your VQMOD and VQMOD Manager will need to be upgraded if you use either.


Here are some errors you WILL run into:

While attempting to view customer information in the admin panel (Customers) or an attempt to add an order from the admin panel (Sales->Orders):

Parse error: syntax error, unexpected '&&' (T_BOOLEAN_AND), expecting ')' in /home/content/57/10005557/html/opencart2200/admin/controller/customer/customer.php on line 1105

Solution: http://forum.opencart.com/viewtopic.php?f=191&t=159399

The same solution works in the \catalog\controller\account\address.php file you will find the same exact code segment that needs correcting.

-----------

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Randem » Thu Mar 17, 2016 6:13 am

Upgrade and fixes have been updated. More to follow... http://www.randemsystems.com/support/op ... t-only%29/

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Randem » Fri Mar 18, 2016 2:19 pm

So, I set up OpenCart to be HTTPS and attempted to view an order (Sales->Orders) and I get the following message that refers to a JQuery Min file that needs to be modified to accommodate HTTPS. This works fine with HTTP.

It is in the file order_shipping.tpl

Attachments

OpenCartOrders.png

OpenCartOrders.png (19.89 KiB) Viewed 5177 times


NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Randem » Thu Mar 24, 2016 4:31 pm

Updated VQMOD Manager and VQMOD for OpenCart 2.2.0.x will be needed for v2.2.0.x

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Randem » Wed Mar 30, 2016 9:21 am


NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Randem » Sat Apr 02, 2016 7:55 am

The ever so annoying "error undefined" message is really stating that you are attempting to do a cross-domain operation. All this really means is that you must force OpenCart to use either HTTP or HTTPS but not both. The real message should probably be "Cross-Origin Request Blocked"

If your browsers URL is HTTP the add to cart operation is HTTPS you will get this message and the reverse is true also.

This is a job for you .htaccess file and setting all your operations in OpenCart to the same protocol. You will need to do come coding changes to accomplish this task.

More info:

This will help solve your issue. You will need to make some code changes

Fix: Force Admin to SSL - 20160306 - daniGo - v1.0.0

Fix: Force URL's in store to be terminated properly with a trailing slash or any store without trailing slash will default to main store. Force HTTPS protocol to HTTPS if SSL is selected in store settings - v1.0.3

These and other fixes can be found here

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by muhamedauda » Fri May 20, 2016 7:16 pm

HI, I have got this problem into my store ... when viewing orders to make new history on order .. just view order the jquery massage like abvoe appear .. after I installed SSL ...
I know this sure result of SSL store url in admin .. so to fix it .. please make sure the
admin/controller/sale/order.php
in info() function in var : $data['store_url']
about line: 318
make sure it like this:

Code: Select all

		$data['store_url'] = $this->request->server['HTTPS'] ? HTTPS_CATALOG : HTTP_CATALOG;

aqwce.com | مصمم ومطور متاجر اليكترونية | @aqwce


New member

Posts

Joined
Sun Feb 02, 2014 7:26 pm

Post by petes » Tue Sep 06, 2016 11:21 am

In 2.2.0.0 Reward Points still don't get subtracted, I checked the file (reward.php) an it is >= as it's supposed to be.

Newbie

Posts

Joined
Sat Aug 06, 2016 11:07 am
Who is online

Users browsing this forum: No registered users and 6 guests