Post by Randem » Sun Oct 02, 2016 2:24 am

Downgrade? You should have done a backup before starting the upgrade. All you need to do is to restore your backup...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Sun Oct 02, 2016 3:29 am

I have a backup! The upgrade was not performed to the live system. It was cloned to another directory. So, no worries.

Downgrade to what? 1.5.5.1? I want opencart 2. Maybe you mean downgrade to opencart 2.1 which is more stable? If yes, how I can do that? Are there any documents or links to follow?

P.S. I have the suspicion that it is all about my default language (greek). When upgraded to 2.2, it seems that does not recognise the language (english was deleted in first place in 1.5.5.1).When I installed the respective greek language pack for opencart 2.2, I could not change language. I hardcoded the el-gr instead of el in db and now it has the language switcher enabled. When el, it shows everything. When el-gr (2.2) doesn't show anything.

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Sun Oct 02, 2016 3:39 am

If your upgrade did not work then attempting a downgrade would be a big mistake. The best way would be to start over again with your 1.5.5.1 system and upgrade to 2.1.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Sun Oct 02, 2016 3:51 am

Randem wrote:If your upgrade did not work then attempting a downgrade would be a big mistake. The best way would be to start over again with your 1.5.5.1 system and upgrade to 2.1.
2.1 is the most stable version in your opinion? Which exactly 2.1 version you suggest?

Thanks!

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Sun Oct 02, 2016 3:54 am

We still use v2.1.1

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Sun Oct 02, 2016 4:17 am

Can I use the procedure described in your signature for doing an upgrade from 1.5.5.1 to 2.1.1 or it is strictly for 1.5.6 to 2.1.0.x?

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Sun Oct 02, 2016 4:37 am

v2.1.x denotes any minor version of v2.1. So yes.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by EvolveWebHosting » Sun Oct 02, 2016 5:25 am

CostasL wrote:Can I use the procedure described in your signature for doing an upgrade from 1.5.5.1 to 2.1.1 or it is strictly for 1.5.6 to 2.1.0.x?
I would highly suggest upgrading to 2.3.0.2 and use the install script that comes with the download. This is the most stable v2.x version, IMO. It's a really smooth process to upgrade now, not like it was early on.

Image
https://www.evolvewebhost.com
$10.49 .com Registration and $9.99 .com Transfers in now
Guaranteed top level opencart performance and support. Risk free 30 day money back guarantee & free transfers.
Image


User avatar
Active Member

Posts

Joined
Fri Mar 27, 2015 11:13 pm
Location - Denver, Colorado, USA

Post by CostasL » Sun Oct 02, 2016 6:05 am

EvolveWebHosting wrote:
CostasL wrote:Can I use the procedure described in your signature for doing an upgrade from 1.5.5.1 to 2.1.1 or it is strictly for 1.5.6 to 2.1.0.x?
I would highly suggest upgrading to 2.3.0.2 and use the install script that comes with the download. This is the most stable v2.x version, IMO. It's a really smooth process to upgrade now, not like it was early on.
I have done this the first time, a week ago. Although I have not disabled my custom modules, the upgrade did work. But unfortunately I decided to drop the installation as there are not enough modules for 2.3 yet and the greek language pack does not exist for now!

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by CostasL » Sun Oct 02, 2016 7:27 am

A question to Randem.
I followed your instructions to upgrade.
In step 10. Go to Extensions->Modules->Account. Choose Edit then enable this module then save it.
How you do that when you cannot login to the admin page?
And when trying to login to admin, I get the error

Code: Select all

Notice: Undefined index: en in /home/xxx/public_html/eshop/admin/index.php on line 119
Notice: Undefined index: en in /home/xxx/public_html/eshop/admin/index.php on line 122
Notice: Undefined index: en in /home/xxx/public_html/eshop/admin/index.php on line 123
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/eshop/admin/index.php:80) in /home/xxx/public_html/eshop/system/library/currency.php on line 45
Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/eshop/admin/index.php:80) in /home/xxx/public_html/eshop/system/library/response.php on line 12

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Sun Oct 02, 2016 7:47 am

What does your config.php files look like in the root and admin folder?

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Sun Oct 02, 2016 7:52 am

Code: Select all

// DIR
define('DIR_APPLICATION', '/home/xxx/public_html/eshop/catalog/');
define('DIR_SYSTEM', '/home/xxx/public_html/eshop/system/');
define('DIR_LANGUAGE', '/home/xxx/public_html/eshop/catalog/language/');
define('DIR_TEMPLATE', '/home/xxx/public_html/eshop/catalog/view/theme/');
define('DIR_CONFIG', '/home/xxx/public_html/eshop/system/config/');
define('DIR_IMAGE', '/home/xxx/public_html/eshop/image/');
define('DIR_CACHE', '/home/xxx/public_html/eshop/system/storage/cache/');
define('DIR_DOWNLOAD', '/home/xxx/public_html/eshop/system/storage/download/');
define('DIR_LOGS', '/home/xxx/public_html/eshop/system/storage/logs/');
define('DIR_MODIFICATION', '/home/xxx/public_html/eshop/system/storage/modification/');
define('DIR_UPLOAD', '/home/xxx/public_html/eshop/system/storage/upload/');
and for admin

Code: Select all

define('DIR_APPLICATION', '/home/xxx/public_html/eshop/admin/');
define('DIR_SYSTEM', '/home/xxx/public_html/eshop/system/');
define('DIR_LANGUAGE', '/home/xxx/public_html/eshop/admin/language/');
define('DIR_TEMPLATE', '/home/xxx/public_html/eshop/admin/view/template/');
define('DIR_CONFIG', '/home/xxx/public_html/eshop/system/config/');
define('DIR_IMAGE', '/home/xxx/public_html/eshop/image/');
define('DIR_CACHE', '/home/xxx/public_html/eshop/system/storage/cache/');
define('DIR_DOWNLOAD', '/home/xxx/public_html/eshop/system/storage/download/');
define('DIR_LOGS', '/home/xxx/public_html/eshop/system/storage/logs/');
define('DIR_MODIFICATION', '/home/xxx/public_html/eshop/system/storage/modification/');
define('DIR_UPLOAD', '/home/xxx/public_html/eshop/system/storage/upload/');
define('DIR_CATALOG', '/home/xxx/public_html/eshop/catalog/');

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Sun Oct 02, 2016 8:38 am

Now the part of the config files that show HTTP and HTTPS...

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Sun Oct 02, 2016 8:46 am

Randem wrote:Now the part of the config files that show HTTP and HTTPS...
It's not that! I have tried both http and https.

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by CostasL » Mon Oct 03, 2016 7:31 am

Hi again,

I am coming back with a new effort to upgrade and new errors.
I deleted all installation and I followed back again Randem's instructions to make a new installation and upgrade.
When running step 8. I get the following errors in a blank page:

Code: Select all

Notice: Undefined index: oc_customer_group in /home/xxx/public_html/eshop/install/model/upgrade.php on line 343

Warning: in_array() expects parameter 2 to be array, null given in /home/xxx/public_html/eshop/install/model/upgrade.php on line 343

Notice: Undefined index: oc_product_option in /home/xxx/public_html/eshop/install/model/upgrade.php on line 359

Warning: in_array() expects parameter 2 to be array, null given in /home/xxx/public_html/eshop/install/model/upgrade.php on line 359

Warning: Cannot modify header information - headers already sent by (output started at /home/xxx/public_html/eshop/install/model/upgrade.php:343) in /home/xxx/public_html/eshop/system/library/response.php on line 12
If I re-run the install, the opencart store is showing without a layout (like no css is there) and the following errors appear:

Code: Select all

Warning: fopen(/home/xxx/public_html/eshop/system/storage/logs/): failed to open stream: Is a directory in /home/xxx/public_html/eshop/system/library/log.php on line 6
.
.
.
.
.
.
Fatal error: Call to a member function get() on a non-object in /home/xxx/public_html/eshop/index.php on line 97
Note that I cannot login to admin panel.

Is my db exporting wrong so the data migration causes the problem?
Is there anyone who can help?
Is there anyone who have faced these errors before?

Thanks anyway

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Mon Oct 03, 2016 7:46 am

What is the structure of your table oc_product_option?

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by CostasL » Mon Oct 03, 2016 3:10 pm

Randem wrote:What is the structure of your table oc_product_option?
You are right! they were empty. i don't know why these tables were not exported right...
So should I try the whole procedure again? Because I tried import these 2 tables but there was no luck. I get the fopen() errors again.

Newbie

Posts

Joined
Sat Oct 01, 2016 6:51 am

Post by Randem » Mon Oct 03, 2016 3:43 pm

It looks like step 5 - 7 was not completed properly. The tables 'oc_product_option' and 'oc_customer_group' are created in those steps. It looks like the opencart.sql file provided was not copied to the proper location.

If you want you can create the empty database (step 5) then use the opencart.sql provided to create the new database tables then complete step 5 to see how that works.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am
Who is online

Users browsing this forum: No registered users and 10 guests