Post by famarinu » Wed Jan 27, 2016 3:41 pm

Good morning,
I have a problem with the settings of the email in OpenCart 2.1
My settings are:

Mail Protocol: SMTP
SMTP hostname: smtpout.secureserver.net
SMTP Username: info@lecoccolekids.com
SMTP Password: xxxx
SMTP Port: 465
SMTP Timeout: 5

with ssl enabled.

The error that gives me is:
1/27/2016 7:22:34 - PHP Notice: Error: EHLO not accepted from server! in /home/kids2/public_html/eshop/system/library/mail.php on line 199

While if I put:

SMTP Port: 3535
SMTP Timeout: 5

with ssl disabled.

He tells me email sent, but the email does not arrive and the error log does not give me no errors.

Services that the service has not been able to help me!
Thank you!
Last edited by famarinu on Wed Jan 27, 2016 4:36 pm, edited 1 time in total.

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by Randem » Wed Jan 27, 2016 4:28 pm

Hi famarinu,

NEVER put passwords in your posts. Edit your post and remove it.
Also try SMTP port 587 for your email with or without SSL.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by famarinu » Wed Jan 27, 2016 4:37 pm

You are definitely right!

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by famarinu » Wed Jan 27, 2016 5:20 pm

same problem, with and without SSL gives me this error:
Notice: Error: EHLO not accepted from server! in /public_html/eshop/system/library/mail.php on line 199

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by Randem » Wed Jan 27, 2016 5:26 pm

It seems that your mail server may not be capable of accepting extended SMTP commands. Most servers that cannot just return a normal HELO answer and continue from there. Check with GoDaddy to see why the server responds this way.

Another thing, have you install and email third party extensions or changed the email code?

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by famarinu » Wed Jan 27, 2016 5:54 pm

I try to contact them again godaddy.
I do not have an installation of third parties or modified code.
thanks for your help!

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by famarinu » Wed Jan 27, 2016 7:39 pm

I called support godaddy and have changed some settings .
Now working but with the mail no SMTP protocol

Active Member

Posts

Joined
Tue Nov 10, 2015 8:33 pm

Post by Randem » Thu Jan 28, 2016 2:44 am

Did you setup SMTP/POP3 email on Godaddy? You have to do that in your account.

NEVER take serious; anyone who gives negative impact statements with no ABSOLUTE proof!
OpenCart Helpful Information * Upgrade 1.5 to 2.1 * Upgrade 2.1 to 2.2
"Why do people NEVER have enough time to do it right but ALWAYS enough time to do it over?"
DO NOT EVER GIVE SOMEONE YOU DON"T KNOW ADMIN ACCESS TO ANYTHING!
I am NOT affiliated with OpenCart


User avatar
Active Member

Posts

Joined
Sat Sep 27, 2014 9:17 am

Post by Leoden » Wed Apr 04, 2018 4:10 am

greetings,
if you are using godaddy shared webhosting here is a solution https://leoden.com/en/opencart-support.html

_______________________
LEODEN OpenCart Support
https://leoden.com


User avatar
Newbie

Posts

Joined
Wed Apr 04, 2018 2:41 am

Who is online

Users browsing this forum: No registered users and 3 guests